Bug 77843 - FILEOPEN: particular doc file with floating table, no longer imported as text frame
Summary: FILEOPEN: particular doc file with floating table, no longer imported as text...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: DOC-Tables
  Show dependency treegraph
 
Reported: 2014-04-24 01:47 UTC by Yousuf Philips (jay) (retired)
Modified: 2019-09-30 09:16 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
table with document title not position correctly (8.32 KB, image/jpeg)
2014-04-24 01:47 UTC, Yousuf Philips (jay) (retired)
Details
the converted .doc file (186.50 KB, application/msword)
2014-04-24 01:47 UTC, Yousuf Philips (jay) (retired)
Details
Issue fixed. Comparison between Libreoffice 5.0.1.2 and Word 2010 (85.14 KB, image/jpeg)
2015-09-08 14:58 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-04-24 01:47:02 UTC
Created attachment 97839 [details]
table with document title not position correctly

I downloaded the .docx file found at < http://download.microsoft.com/documents/rus/microsoft4you/How_to_license_the_operating_system_Windows_8_new.docx > and used the microsoft compatibility pack to convert it to a .doc file. Then i opened the .doc file in LibO and on the first page, the table with the title is incorrectly positioned. This is a regression since 4.1.
Comment 1 Yousuf Philips (jay) (retired) 2014-04-24 01:47:49 UTC
Created attachment 97840 [details]
the converted .doc file
Comment 2 Jorendc 2014-04-26 13:30:03 UTC
Reproducible, tested using Windows 8.1 with LibreOffice Version: 4.3.0.0.alpha1+
Build ID: f4a6837025a293312cbc43b9c527851362f11030
TinderBox: Win-x86@47-TDF, Branch:MASTER, Time: 2014-04-26_09:21:18

It is even worse in 4.3 (see my bug report: bug 77723).

Kind regards,
Joren
Comment 3 Jorendc 2014-04-26 13:50:21 UTC
Also reproducible using Windows 8.1 with LibreOffice Version: 4.1.5.3 
Build ID: 1c1366bba2ba2b554cd2ca4d87c06da81c05d24

Indeed NOT reproducible using Version 4.0.6.2 (Bouw-id: 2e2573268451a50806fcd60ae2d9fe01dd0ce24)

Reproducible using Versie: 4.1.0.4 
Build ID: 89ea49ddacd9aa532507cbf852f2bb22b1ace28

So, indeed a regression between 4.0 vs 4.1 branch.
Comment 4 Joel Madero 2014-05-30 05:58:35 UTC
This one was a bit rough to bibisect - the dialog has changed and the new one doesn't have horizontal/vertical position - instead it has other values that always seems to be saying 0" but something indeed is changing. Hope the bibisect is correct.

6e5f82006fc43350e99921f79aa713701147d9ac is the first bad commit
commit 6e5f82006fc43350e99921f79aa713701147d9ac
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Thu Oct 17 05:16:54 2013 +0000

    source-hash-1472b5f87314fe660ef1a7b254e51272669f12f6
    
    commit 1472b5f87314fe660ef1a7b254e51272669f12f6
    Author:     Alia Almusaireae <almusaireae@kacst.edu.sa>
    AuthorDate: Mon May 6 09:11:30 2013 +0300
    Commit:     Bosdonnat Cedric <cedric.bosdonnat@free.fr>
    CommitDate: Mon May 13 15:12:01 2013 +0000
    
        zoomandviewlayout.ui widget
    
        Change-Id: I8d607a5960ffc3c69ffa97ca3e2ebae555044581
        Reviewed-on: https://gerrit.libreoffice.org/3794
        Reviewed-by: Bosdonnat Cedric <cedric.bosdonnat@free.fr>
        Tested-by: Bosdonnat Cedric <cedric.bosdonnat@free.fr>

:100644 100644 b3d561c5462e2082e8239a025b32f49179640532 3054ac942c5d4b65fec372169cf9a5cf3c8b1f32 M	autogen.log
:100644 100644 6128b74db3cb1f6c27b1a45c50f7c153ff97a258 e407fbaabbe6f6ff899f60b6c361ac957a64c045 M	ccache.log
:100644 100644 edebfbdcc3e04b63975a647dc7c0b96c150fbbd0 a9ad80935f7065b3323e9f96d191a888839923ef M	commitmsg
:100644 100644 809776d76c5acff63ae05acc840151ed3d6c838f 9d4891958550c345355ce51538d22d0bf9417611 M	dev-install.log
:100644 100644 6568832225733800f0f023ebbe299e1af2ffa2d7 9066bd3d8d2d22fa93737a7c071da2c6ef04d83a M	make.log
:040000 040000 2f51c32806a14b911a2cd80cfe103e8d9b000711 d881f8f7d4858f58d394c03c09f66a630c11dd57 M	opt

# bad: [793dbf6f80f497dfe587d560d6257f42a24273f6] source-hash-1581b1fc3ac82a7bd62df968226e98604a4ca52d
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# good: [8092559c5013969ebda017d79200463b9b975038] source-hash-fd84daf696a368c2c7561b5253b32a63ecdeca4a
git bisect good 8092559c5013969ebda017d79200463b9b975038
# bad: [0270ef1b76a6de423b30f7927362cc01c1a0fc38] source-hash-b1f7dd66b898b03cb4bd8d434b6370310ea95946
git bisect bad 0270ef1b76a6de423b30f7927362cc01c1a0fc38
# good: [aedcb9e93c73792e6d4f6bc5d74050efbe5af7c1] source-hash-358b60b3b172968a7605b428af01df456d7669b2
git bisect good aedcb9e93c73792e6d4f6bc5d74050efbe5af7c1
# bad: [63ac4ab9665db60fac1e1813c9c80da52b2e87c6] source-hash-66e39940d763586060c4bcc8c3cd213495c40b79
git bisect bad 63ac4ab9665db60fac1e1813c9c80da52b2e87c6
# good: [ec9e268ce152176463e07e09901e4a99d65d86ee] source-hash-1b14676b5f95dd51d6266a6ab7bd713a5ddcff2f
git bisect good ec9e268ce152176463e07e09901e4a99d65d86ee
# good: [bf5d7e3794ac23c52e833b6822032f5f11272d0e] source-hash-a2c34b3d9ac2d7e43e52846308cc63447fd51f23
git bisect good bf5d7e3794ac23c52e833b6822032f5f11272d0e
# bad: [5aaaa56b691a456d6c40a20ceca4574681f49634] source-hash-3fb33e3e04c7f339e1e15d24529e8ea1d4dbe321
git bisect bad 5aaaa56b691a456d6c40a20ceca4574681f49634
# good: [f6bdd95ecd512f4b82331a676c309081026b9bfd] source-hash-2ede6c95e6481c92cc199e7d74fd36c841636304
git bisect good f6bdd95ecd512f4b82331a676c309081026b9bfd
# bad: [6e5f82006fc43350e99921f79aa713701147d9ac] source-hash-1472b5f87314fe660ef1a7b254e51272669f12f6
git bisect bad 6e5f82006fc43350e99921f79aa713701147d9ac
# first bad commit: [6e5f82006fc43350e99921f79aa713701147d9ac] source-hash-1472b5f87314fe660ef1a7b254e51272669f12f6
Comment 5 Michael Stahl (CIB) 2014-07-04 22:32:32 UTC
the problem is that the table used to be imported wrapped inside
a text frame (to fake floating table) but now it's a plain table.

regression from:

commit 8fe8bd6c3b5b1a539b7370f8c457fa69c061d2de
Author:     Miklos Vajna <vmiklos@suse.cz>
AuthorDate: Mon May 13 11:24:58 2013 +0200

    Related: fdo#61594 SwWW8ImplReader::StartApo: don't always start a frame
    

well since Writer can't do floating tables we can't handle
every document perfectly...
Comment 6 Björn Michaelsen 2014-10-16 14:59:22 UTC Comment hidden (obsolete)
Comment 7 Xisco Faulí 2015-09-08 14:58:09 UTC
Created attachment 118528 [details]
Issue fixed. Comparison between Libreoffice 5.0.1.2 and Word 2010
Comment 8 Xisco Faulí 2015-09-08 14:58:21 UTC
I can no longer reproduce this issue with

Version: 5.0.1.2
Build ID: 81898c9f5c0d43f3473ba111d7b351050be20261
Locale: es-ES (es_ES)

and Office Word 2010

on Windows 7 (64-bit)

Thus, I close this as RESOLVED WORKSFORME
Comment 9 Robinson Tryon (qubit) 2015-12-15 11:03:44 UTC Comment hidden (obsolete)