Download it now!
Bug 77888 - [basic] Macro editor: Digital Signature menu entry isn't working
Summary: [basic] Macro editor: Digital Signature menu entry isn't working
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Digital-Signatures
  Show dependency treegraph
 
Reported: 2014-04-24 10:41 UTC by Thomas Arnhold
Modified: 2020-09-27 10:30 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Arnhold 2014-04-24 10:41:58 UTC
Open the macro editor (Tools > Macros > Organize Macros > LibreOffice Basic). Then click on "Edit". The macro editor is now opened.

Go straight to the menu entry "File > Digital Signatures" and click on. Nothing happens. If you do the same in writer, calc,... the signature dialog openes.

Expected behavior: The signature dialog should open.
Comment 1 Buovjaga 2014-10-31 19:54:24 UTC
Confirmed.

Win 7 64-bit Version: 4.4.0.0.alpha1+
Build ID: 56019dcb79475606952a954fe732a3109441ffec
TinderBox: Win-x86@39, Branch:master, Time: 2014-10-30_07:27:11
Comment 2 Buovjaga 2015-01-07 16:41:26 UTC
Reproduced with 3.5:

Ubuntu 14.10 64-bit
LibreOffice 3.5.0rc3 
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735
Comment 3 QA Administrators 2016-01-17 20:03:32 UTC Comment hidden (obsolete)
Comment 4 Markus Wernig 2017-01-30 09:55:19 UTC Comment hidden (obsolete)
Comment 5 Buovjaga 2017-01-30 10:19:28 UTC
(In reply to Markus Wernig from comment #4)
> I cannot reproduce this in 5.2.3.3 on Linux.
> 
> The "File->Digital Signatures" dialog opens, regardless of what other dialog
> is opened.

Please try it from the File menu of the *macro editor* window.
I can still reproduce.

Win 7 64-bit
Version: 5.2.5.1 (x64)
Build ID: 0312e1a284a7d50ca85a365c316c7abbf20a4d22
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Locale: fi-FI (fi_FI); Calc: CL
Comment 6 Markus Wernig 2017-01-30 10:44:39 UTC
Ah, forget my last comment. Wrong dialog. Confirm OP.
Comment 7 QA Administrators 2018-01-31 03:42:56 UTC Comment hidden (obsolete)
Comment 8 Thomas Arnhold 2018-01-31 06:32:54 UTC
Bug is still present in 5.4.4.

I Also tested it with 3.3.0 where it was also present.
Comment 9 QA Administrators 2019-02-01 03:45:51 UTC Comment hidden (obsolete)
Comment 10 Thomas Arnhold 2020-09-27 09:10:47 UTC
Resolved at least with:

Version: 7.0.1.2
Build ID: 00(Build:2)
CPU threads: 4; OS: Linux 5.8; UI render: default; VCL: gtk3
Locale: de-DE (de_DE.UTF-8); UI: en-US
=7.0.1-1
Calc: threaded
Comment 11 Buovjaga 2020-09-27 10:30:45 UTC
True, but we don't know who fixed it, so WFM

Version: 7.1.0.0.alpha0+ (x64)
Build ID: dba1a27be2438b5dbd1f8d253acb3850c9c044da
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: fi-FI (fi_FI); UI: en-US
Calc: threaded