Download it now!
Bug 77914 - FILEOPEN .bmp imported from .vsd file displayed as a black rectangle
Summary: FILEOPEN .bmp imported from .vsd file displayed as a black rectangle
Status: RESOLVED DUPLICATE of bug 73523
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-25 07:01 UTC by Florian Reisinger
Modified: 2015-02-01 12:20 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Test suit - Licenced CC-BY 4.0 (212.69 KB, application/x-zip-compressed)
2014-04-25 07:02 UTC, Florian Reisinger
Details
image exported by libvisio (354.44 KB, image/bmp)
2014-04-25 14:20 UTC, David Tardon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Reisinger 2014-04-25 07:01:37 UTC
Hi,
I will attach a zip file containing 3 documents, the original one, the LibO export done with Version: 4.3.0.0.alpha1+
Build ID: 808d273db098e2269e53813595a6bfc7b160e28e
TinderBox: Win-x86@39, Branch:master, Time: 2014-04-25_02:09:26 snd the export result of Visio 2013
As you can see the picture is black. (It is a picture of the content right above)
Comment 1 Florian Reisinger 2014-04-25 07:02:29 UTC
Created attachment 97941 [details]
Test suit - Licenced CC-BY 4.0
Comment 2 David Tardon 2014-04-25 14:20:11 UTC
Created attachment 97957 [details]
image exported by libvisio

This is a libreoffice bug: gthump can display the exported image just fine.
Comment 3 Julien Nabet 2014-04-26 05:41:56 UTC
On pc Debian x86-64 with master sources updated today, I can reproduce this.

I noticed this log repeated 7 times:
warn:legacy.osl:6461:1:svx/source/sdr/contact/viewcontactofsdrpathobj.cxx:67: PolyPolygon object without geometry detected, this should not be created (!)
Comment 4 David Tardon 2015-02-01 12:20:14 UTC

*** This bug has been marked as a duplicate of bug 73523 ***