Bug 77915 - FILEOPEN [vsdx] shape color not imported
Summary: FILEOPEN [vsdx] shape color not imported
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Visio
  Show dependency treegraph
 
Reported: 2014-04-25 07:06 UTC by Florian Reisinger
Modified: 2019-08-31 11:59 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Testsuite licenced under CC-BY 4.0 (215.04 KB, application/x-zip-compressed)
2014-04-25 07:06 UTC, Florian Reisinger
Details
4.4.3.2 (9.74 KB, image/png)
2015-06-08 17:43 UTC, Florian Reisinger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Reisinger 2014-04-25 07:06:23 UTC
I did the same with bug #77914
I will attach a test suite with the original vsdx and with exports from Visio 2013 and LibreOffice Version: 4.3.0.0.alpha1+
Build ID: 808d273db098e2269e53813595a6bfc7b160e28e
TinderBox: Win-x86@39, Branch:master, Time: 2014-04-25_02:09:26

IS/SHOULD: Picture not important (as this is the same as vsd, pls refer to #77914. It is also valid with this testcase [Pls tell me if you prefer a bug for both versions]), color of the symbols is not imported (black instead of blue)
Comment 1 Florian Reisinger 2014-04-25 07:06:55 UTC
Created attachment 97942 [details]
Testsuite licenced under CC-BY 4.0
Comment 2 David Tardon 2014-04-25 14:38:16 UTC
The image color problem is the same as in bug 77914. The black shapes need further investigation.
Comment 3 QA Administrators 2015-06-08 14:42:28 UTC Comment hidden (obsolete)
Comment 4 Florian Reisinger 2015-06-08 17:43:00 UTC
Created attachment 116377 [details]
4.4.3.2

No change with 

Version: 4.4.3.2
Build-ID: 88805f81e9fe61362df02b9941de8e38a9b5fd16
Gebietsschema: de_AT
Comment 5 QA Administrators 2016-09-20 10:01:38 UTC Comment hidden (obsolete)
Comment 6 eisa01 2018-03-31 19:41:47 UTC
Still present

The figures are now rendered with a black outline only

Version: 6.1.0.0.alpha0+
Build ID: a488c7ad2763b944713997911c1ddb0315d8c93f
CPU threads: 2; OS: Mac OS X 10.12.6; UI render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2018-03-26_00:38:29
Locale: en-US (en_US.UTF-8); Calc: group
Comment 7 QA Administrators 2019-04-01 03:24:39 UTC Comment hidden (obsolete)
Comment 8 eisa01 2019-04-20 17:57:28 UTC
Still present

The figures are now rendered with soft grey outlines only (almost impossible to see, could be another bug as connectors are the same way)

Version: 6.3.0.0.alpha0+
Build ID: ea9c13be02ba731074fa4207944ff7df40a0fb5c
CPU threads: 2; OS: Mac OS X 10.13.6; UI render: default; VCL: osx; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2019-04-10_20:43:17
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded