Bug 77936 - When enable QuickStarter in Ubuntu Unity, there is no systray in the notification area
Summary: When enable QuickStarter in Ubuntu Unity, there is no systray in the notifica...
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
(earliest affected) release
Hardware: All Linux (All)
: medium minor
Assignee: Not Assigned
Depends on:
Reported: 2014-04-25 16:43 UTC by Phil Wolff
Modified: 2017-04-10 11:46 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description Phil Wolff 2014-04-25 16:43:41 UTC
Marking "Enable systray Quickstarter" in LO preferences does *not* display the Quickstarter icon in the systray.

Ubuntu 14.04 (both 32- and 64-bit x86), compiz, Unity, com.canonical.unity.panel.systray-whitelist set to 'all'
Comment 1 Kevin Suo 2014-06-21 09:49:44 UTC
I can confirm this in Ubuntu 14.04 x86,
Build ID: 9ed0c4329cf13f882dab0ee8b9ecd7b05e4aafbb

Steps to reproduce:
1. Check "Enable systray QuickStarter" in "Tools - Options - LibreOffice - Memory";
2. Close and re-run libreoffice;
3. Close libreoffice again.

Current Behaviour:
There is no systray shown. However, if you check the system monitor, you will see the soffice.bin process still running.

I revised the title to make it more clear.
I set platform to ALL as I also reproduce in x86
Functionality not working, -> it's a major bug.
Comment 2 Kevin Suo 2014-06-21 09:56:28 UTC
Just for info:
I installed libreoffice by downloading the deb archive from TDF website, and did "sudo dpkg -i ./DEBS/*.deb".

I noticed this issue when I was testing the case #31 of MozTrap.
Comment 3 Yousuf Philips (jay) (retired) 2014-06-21 10:02:16 UTC
Quickstarter also has problems on KDE as mentioned in bug 72243.
Comment 4 Alfredo Parisi 2014-06-21 12:35:06 UTC
Ubuntu 14.04 64bit, Gnome 3.10
Quickstart works
Comment 5 Kevin Suo 2014-06-21 13:06:42 UTC
(In reply to comment #4)
> Ubuntu 14.04 64bit, Gnome 3.10
> Version:
> Quickstart works

Then I revised the summary title according to reflect only Ubuntu Unity.
Comment 6 Edmund Laugasson 2015-02-24 16:21:25 UTC
Tested (RC2) in 64-bit Ubuntu 14.04.2 LTS and still the problem exist. Tried Unity and also classical Gnome (gnome-session-flashback 1:3.8.0-1ubuntu12.2) - still no results - no icon in system tray :(
Found some suggestions at http://ask.libreoffice.org/en/question/35602/quickstarter-icon-doesnt-show-under-unity/ and http://askubuntu.com/questions/34796/how-do-i-enable-the-libreoffice-quickstarter-in-unity/589371#589371 but these seems to be not working.
At the same time in LXDE (Lubuntu 14.04 LTS) the systray icon works very well.
Comment 7 Björn Michaelsen 2016-03-29 23:18:27 UTC
AFAICR Ubuntu Unity has an explicit whitelist of tray icons it allows. I assume the Quickstart just isnt on it.
Comment 8 Phil Wolff 2016-03-29 23:46:32 UTC
Look back at my original submission, where it says "systray-whitelist set to 'all'". I'm now at 15.10, the dconf entry whitelist still says 'all', and there's still no LO icon in the notification area.
Comment 9 Buovjaga 2016-06-08 15:10:51 UTC
Wrong status and severity.
Comment 11 Phil Wolff 2017-04-10 11:33:56 UTC
…proving once again that if you ignore something long enough, it'll go away. All hail inaction!!
Comment 12 Buovjaga 2017-04-10 11:42:28 UTC
(In reply to Phil Wolff from comment #11)
> …proving once again that if you ignore something long enough, it'll go away.
> All hail inaction!!

Don't go slandering developers by claiming they actively ignore issues. Read the commit logs since 2014 and then come back hailing inaction, if you still feel like it.
Comment 13 Phil Wolff 2017-04-10 11:46:55 UTC
Well said, O Master of Status Changing.