Bug 78299 - Ctrl+A in table cell selects the whole document instead of just the cell
Summary: Ctrl+A in table cell selects the whole document instead of just the cell
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.3.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-05 13:06 UTC by André Desgualdo Pereira
Modified: 2015-04-25 00:29 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
A document with the bug (11.79 KB, application/vnd.oasis.opendocument.text)
2014-05-05 13:18 UTC, André Desgualdo Pereira
Details

Note You need to log in before you can comment on or make changes to this bug.
Description André Desgualdo Pereira 2014-05-05 13:06:22 UTC
Problem description: 

Steps to reproduce:
1. Open Writer, create a table and put some content into it. 
2. Put the cursor into some cell and press Ctrl+A

Current behavior:
All text in the document is selected. 

Expected behavior:
"Ctrl+A If the active cell is empty, Ctrl+A selects the whole table; otherwise, it selects the contents of the active cell. Press Ctrl+A a second time to select the entire table."

              
Operating System: Ubuntu
Version: 4.2.3.3 release
Comment 1 André Desgualdo Pereira 2014-05-05 13:09:58 UTC
I just realize that it happens in documents created with previous versions of Libreoffice but not in documents created with Libreoffice-4.
Comment 2 André Desgualdo Pereira 2014-05-05 13:16:25 UTC
Forget the previous comment. 
The bug happens when a document has a table right at the top.
Comment 3 André Desgualdo Pereira 2014-05-05 13:18:07 UTC
Created attachment 98485 [details]
A document with the bug
Comment 4 tommy27 2014-05-05 13:35:04 UTC
reproducible with LibO 4.2.3.3 under Win7x64
status -> NEW 
platform -> ALL
edited summary notes
Comment 5 Gaurang 2014-06-10 20:57:54 UTC
I confirm the bug.
It happens only when the table is the first thing in the document.
Comment 6 Norbert X 2014-07-22 10:57:46 UTC
I confirm this bug on LibO Version: 4.2.5.2
Build ID: 420m0(Build:2) in Ubuntu Precise (from PPA).

For me Ctrl+A for selecting only cell is a great advantage of LibO over MSO Word.

For me this bug is reproducible if document has only table.
If I add some text before table this bug is not reproducible.
Comment 7 Gordo 2015-04-25 00:29:55 UTC
Could not reproduce.

Windows Vista 64
Version: 4.4.2.2
Build ID: c4c7d32d0d49397cad38d62472b0bc8acff48dd6

Changed to RESOLVED WORKSFORME.