Bug 78458 - EDITING: PIVOT TABLE, draggin a field delete a field from a different type and can't be removed from fields unless they're doubled clicked first
Summary: EDITING: PIVOT TABLE, draggin a field delete a field from a different type an...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha1
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 86949 88671 93022 94797 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-05-08 22:19 UTC by m.a.riosv
Modified: 2017-05-22 23:04 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample file to test (41.03 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-05-08 22:19 UTC, m.a.riosv
Details
Video file showing the bug. (5.18 MB, application/zip)
2015-04-02 19:13 UTC, m.a.riosv
Details

Note You need to log in before you can comment on or make changes to this bug.
Description m.a.riosv 2014-05-08 22:19:17 UTC
Created attachment 98712 [details]
Sample file to test

Win7x64Ultimate
Version: 4.3.0.0.alpha1+ Build ID: 657004ae5c9f4a07b2cdafbb21bc8657842d4d74
   TinderBox: Win-x86@39, Branch:master, Time: 2014-05-08_00:35:12

In the attached file:

Edit layout pivot table.

Dragging fields from Row/Column/Data fileds to delete it:
First time do nothing.
Subsequents, dragging one of the other field types, deletes a field from a different type.
Comment 1 GerardF 2014-05-09 08:28:09 UTC
Confirmed.

Exactly the same version as reporter.

Dragging a field out the pivot table without editing layout works.
So it is related to the dialog.
Comment 2 m.a.riosv 2014-12-03 09:56:46 UTC
*** Bug 86949 has been marked as a duplicate of this bug. ***
Comment 3 m.a.riosv 2015-01-22 01:38:10 UTC
*** Bug 88671 has been marked as a duplicate of this bug. ***
Comment 4 Julien Nabet 2015-03-28 23:44:16 UTC
On pc Debian x86-64 with master sources updated yesterday, I don't reproduce this, but perhaps I missed something.
Comment 5 m.a.riosv 2015-03-29 00:50:57 UTC
Thanks a lot for take a look Julien.

Reviewed with.
Version: 4.5.0.0.alpha0+ (x64)
Build ID: 4dfa19d61331bab284e188422fbc95baf814b602
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-03-26_22:40:10

Using sample file, impossible drag fields to delete or move from anywhere, even creating a new spreadsheet with a clean profile.

With
Version: 4.4.3.0.0+
Build ID: 3eba5eb1774ab621a1f0f4dcc7e82cce6c025b0a
TinderBox: Win-x86@42, Branch:libreoffice-4-4, Time: 2015-03-27_09:30:51

It's possible drag fields from list to row/column, but drag to delete or move remains impossible.

The first description of the bug is reproducible with:
Version: 4.4.2.2
Build ID: c4c7d32d0d49397cad38d62472b0bc8acff48dd6

(Win7x64Ultimate all)
Comment 6 Julien Nabet 2015-03-30 19:16:27 UTC
More precisely, I can delete fields by putting them back precisely into "available fields" panel (not outside of dialog for example).

It would be strange if it's a Windows only bug.
Comment 7 m.a.riosv 2015-04-02 19:13:32 UTC
Created attachment 114568 [details]
Video file showing the bug.

I hope you can see better what's happen in the attached a video showing the issue. Resolution is not to good but I think it's enough,

And yes it's strange such issue happens only in Windows.


Win7x64Ultimate
Version: 4.5.0.0.alpha0+Build ID: 4dde5a623d563f9007dd3539b835489a27128d65
TinderBox: Win-x86@42, Branch:master, Time: 2015-04-01_11:40:51
Comment 8 m.a.riosv 2015-06-10 10:15:21 UTC
By the way, I forgot to comment, that I have found that fields can be deleted, after select the field with [Del] key. What makes less pain edit pivot tables.
Comment 9 raal 2015-07-30 17:37:09 UTC
*** Bug 93022 has been marked as a duplicate of this bug. ***
Comment 10 m.a.riosv 2015-10-26 11:09:26 UTC
*** Bug 94797 has been marked as a duplicate of this bug. ***
Comment 11 QA Administrators 2017-05-22 13:39:36 UTC Comment hidden (obsolete)
Comment 12 m.a.riosv 2017-05-22 23:04:47 UTC
Works for me.
Version: 5.3.3.2 (x64)
Build ID: 3d9a8b4b4e538a85e0782bd6c2d430bafe583448
CPU Threads: 4; OS Version: Windows 6.19; UI Render: GL; Layout Engine: new; 
Locale: es-ES (es_ES); Calc: group