Bug 78487 - FILEOPEN: DOCX - Footnote line/paragraph spacing not correct
Summary: FILEOPEN: DOCX - Footnote line/paragraph spacing not correct
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.0.beta1
Hardware: All All
: high normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:4.4.0 target:4.3.0 target:4.2.6
Keywords: bibisected, regression
Depends on:
Blocks: DOCX-Footnote-Endnote
  Show dependency treegraph
 
Reported: 2014-05-09 12:49 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-09-29 21:10 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
test case .docx (26.66 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-05-09 12:49 UTC, Yousuf Philips (jay) (retired)
Details
the correct test case .docx (23.42 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-05-09 12:51 UTC, Yousuf Philips (jay) (retired)
Details
footnotes in LibO 4.1 and word 2007 (213.04 KB, image/png)
2014-05-09 12:51 UTC, Yousuf Philips (jay) (retired)
Details
footnotes in LibO 4.2 and 4.3 (148.17 KB, image/png)
2014-05-09 12:52 UTC, Yousuf Philips (jay) (retired)
Details
how the endnotes line spacing looks in 4.2.4, 4.2.6 and 4.3 beta 2 (323.43 KB, image/png)
2014-06-19 20:29 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-05-09 12:49:53 UTC
Created attachment 98754 [details]
test case .docx

I pulled this test case from a docx file created with word 2007. When i open the attached file in LibO, the footnotes have line/paragraph spacing not see when viewing it in word 2007. Tested on Linux Mint with the latest releases of LibO 3.6 - 4.2 and 4.3 alpha. LibO 3.6 - 4.1 has the size of a single empty space between footnotes, 4.2 has the size of two empty spaces between, 4.2.5 and 4.3 alpha have footnote numbers on one line and the footnote text on another line and an actual 3rd line styled as 'footnote'.

Not sure whether to put this as regression as no version has correct, but it seem as LibO version increase, it gets worse.
Comment 1 Yousuf Philips (jay) (retired) 2014-05-09 12:51:15 UTC
Created attachment 98755 [details]
the correct test case .docx
Comment 2 Yousuf Philips (jay) (retired) 2014-05-09 12:51:45 UTC
Created attachment 98756 [details]
footnotes in LibO 4.1 and word 2007
Comment 3 Yousuf Philips (jay) (retired) 2014-05-09 12:52:15 UTC
Created attachment 98757 [details]
footnotes in LibO 4.2 and 4.3
Comment 4 Joel Madero 2014-05-30 05:07:10 UTC
Ubuntu 14.04 x64
LibreOffice 4.3 beta1

Confirmed

New
Normal - can prevent high quality/professional work
High - regression

I think that despite the fact that it never imported correctly, getting worse is still a regression ;) Ideally we'd hope that a developer would fully fix it when fixing the regression but at least get it back to before where it was presentable



Also changing version - let's mark it as 4.3 beta1 since it got substantially worse at that point and that's where the "regression" is - if the solution does not fully resolve the problem we can make a new bug that reflects the "pre-regression" status



ca832321203e0ad5325deb96b5599173e96b4e47 is the first bad commit
commit ca832321203e0ad5325deb96b5599173e96b4e47
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Tue May 20 08:19:30 2014 +0000

    source-hash-e15223582710e9e2e31fad2f557df6ee99501fd0
    
    commit e15223582710e9e2e31fad2f557df6ee99501fd0
    Author:     Tor Lillqvist <tml@collabora.com>
    AuthorDate: Tue Apr 22 09:26:33 2014 +0300
    Commit:     Tor Lillqvist <tml@collabora.com>
    CommitDate: Tue Apr 22 09:43:44 2014 +0300
    
        More hacking on --disable-database-connectivity
    
        Work in progress, still lots of undefineds when attempting to link
        TiledLibreOffice.
    
        Change-Id: I80fa330768d9f9fa9ef65e3693f1d777c0713210

:100644 100644 ca04f472658753b884dcfad16112812f1a3b97d6 343b072c16d68aab203e56b9fcf1331cb6d17bf0 M	ccache.log
:100644 100644 f88d03aff9ad384eabae43fe13ba06fbfc667e70 e6e679b40a1fdaac3ec782e0cbd7a00a544aaf13 M	commitmsg
:100644 100644 302b31edf89e9d0ab0eba690c9e6703b62b36483 ad5ccf334aaa1ebd47cb2ad139f6976b863fca9d M	make.log
:040000 040000 20ca55739d93ab95620562b796f8ec4fb3755e5a 941ef24bddd67db62b8d095120842f58c5fd80b6 M	opt


# bad: [a92705c1fabafddd43d175a0714855cd22551232] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
# good: [6ab7f53af36f13bbefdd4e4fcbd3d1ea432a77d9] source-hash-22029c7e17b4cb48acb058d47ec9c3b6b8b6b294
git bisect start 'latest' 'oldest'
# good: [bebf9d31c8fe9de96798484288a0fffc4d54917d] source-hash-09e5de8278dd8f13adcf614db35c8a8a04ba8e47
git bisect good bebf9d31c8fe9de96798484288a0fffc4d54917d
# good: [fac643700ecfabc737836bbed068776f34037d53] source-hash-40a61d93ade494fa98c23a9fd8776c8dadf8f30f
git bisect good fac643700ecfabc737836bbed068776f34037d53
# bad: [44e392733ca46fb0fde9664f8b33ff4da5295caa] source-hash-062e69f40b749aa8a6058c3e6ca328af86aeb45b
git bisect bad 44e392733ca46fb0fde9664f8b33ff4da5295caa
# good: [3e370810edadd040e63cef076594a2058603b344] source-hash-ddd4b159531e835539e86f76c56d1013de46a2bd
git bisect good 3e370810edadd040e63cef076594a2058603b344
# skip: [c05d75aa2ab2065c8953a1649866074f2e0a75f1] source-hash-28fc951233a58fb4d8515ed4380140aaee0afd32
git bisect skip c05d75aa2ab2065c8953a1649866074f2e0a75f1
# good: [304c44989cd8e7d5074eeb53ca14c54b3b6e2e16] source-hash-f05861de995f8d4edb1a97c616d050f55ec04c32
git bisect good 304c44989cd8e7d5074eeb53ca14c54b3b6e2e16
# bad: [1fd4b5c55c33b4df5d8b74e00fa49d45cf5927a5] source-hash-9f06e4bc3a56806061f759770f758ad3c7ddf09c
git bisect bad 1fd4b5c55c33b4df5d8b74e00fa49d45cf5927a5
# bad: [ca832321203e0ad5325deb96b5599173e96b4e47] source-hash-e15223582710e9e2e31fad2f557df6ee99501fd0
git bisect bad ca832321203e0ad5325deb96b5599173e96b4e47
# good: [9f50955df0d7eebb14a0016b4a4ec461fd66b7f9] source-hash-46cfcd5a05aa1d13fecd73f5a25b64b8d8dd6781
git bisect good 9f50955df0d7eebb14a0016b4a4ec461fd66b7f9
# good: [ddbf1adbc743d78eeb58ee33063e62de85638b4c] source-hash-31792ca5a2ac093bd922723acc2b07ed225e5eaa
git bisect good ddbf1adbc743d78eeb58ee33063e62de85638b4c
# first bad commit: [ca832321203e0ad5325deb96b5599173e96b4e47] source-hash-e15223582710e9e2e31fad2f557df6ee99501fd0
Comment 5 Xisco Faulí 2014-06-05 16:23:29 UTC
it looks like this issue was introduced by abe1e852a232e3bdab7b9177d099fe3929f5a4aa. I couldn't reproduce it when I reverted the commit. It doesn't mean I want it to be reverted ;-)
Comment 6 Yousuf Philips (jay) (retired) 2014-06-05 16:45:30 UTC
Now that i have 3.3 installed, i can confirm that it was inherited from OOo.
Comment 7 Yousuf Philips (jay) (retired) 2014-06-19 20:29:08 UTC
Created attachment 101382 [details]
how the endnotes line spacing looks in 4.2.4, 4.2.6 and 4.3 beta 2

It seems it also affects endnotes as well, as can be seen in attachment 101279 [details] of bug 80175.
Comment 8 Michael Stahl (allotropia) 2014-07-07 19:39:07 UTC
this was fixed on libreoffice-4-2 branch by commit:

commit 9650f663ade4696416b59b5f3976b45d1300554e
Author:     Miklos Vajna <vmiklos@collabora.co.uk>
AuthorDate: Wed Jun 11 12:39:33 2014 +0200

    DOCX import: fix additional empty paragraphs around footnote text

master commit 4d120b6ab181f530d3fedc963b1c6ec777f2608a

libreoffice-4-3 commit e1af737ef9c1ae599cf9758d199edfd7e16da62a
Comment 9 Yousuf Philips (jay) (retired) 2014-07-09 04:32:17 UTC
I can confirm that 4.2.6 and 4.3.1 has it similar to 4.2.4, but shouldnt we be also be looking to get it back to the better 4.1 level.
Comment 10 Robinson Tryon (qubit) 2015-12-17 08:02:57 UTC Comment hidden (obsolete)