Bug 78584 - Black text anti-aliased with colors
Summary: Black text anti-aliased with colors
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-12 06:42 UTC by Ulrich Windl
Modified: 2014-10-31 20:54 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
1:1 partial screen shot showing color where there should be gray only (2.14 KB, image/png)
2014-05-12 06:42 UTC, Ulrich Windl
Details
Zoomed part of attachment #98882 for clarity (12.65 KB, image/png)
2014-05-12 06:44 UTC, Ulrich Windl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ulrich Windl 2014-05-12 06:42:57 UTC
Created attachment 98882 [details]
1:1 partial screen shot showing color where there should be gray only

When first seeing this I thought it's an artefact of my LCD monitor (which has very high display quality), but after taking a screen shot I found out it's the application, not the display:
Some black characters seem colored at some zoom levels. IMHO that's a usability no-no. See screen shots (one regular size, one zoomed for clarity).
Comment 1 Ulrich Windl 2014-05-12 06:44:44 UTC
Created attachment 98883 [details]
Zoomed part of attachment #98882 [details] for clarity
Comment 2 Tomaz Vajngerl 2014-05-12 07:36:25 UTC
http://en.wikipedia.org/wiki/ClearType
Comment 3 Ulrich Windl 2014-05-12 07:48:34 UTC
(In reply to comment #2)
> http://en.wikipedia.org/wiki/ClearType

You probably wanted to say: It's not a bug, it's a feature. See "ClearType, 2014. Wikipedia, the free encyclopedia [online], [Accessed 12 May 2014]. Available from: http://en.wikipedia.org/w/index.php?title=ClearType&oldid=606198945. Page Version ID: 606198945":
"Like most other types of subpixel rendering, ClearType involves a compromise, sacrificing one aspect of image quality (color or chrominance detail) for another (light and dark or luminance detail)."