Download it now!
Bug 78810 - Other: Enhancement: Enable in the sidebar the color selection functionality as in the normal toolbara iconsst selected color can be applied immediately
Summary: Other: Enhancement: Enable in the sidebar the color selection functionality ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Sidebar-Properties 45671
  Show dependency treegraph
 
Reported: 2014-05-17 04:53 UTC by bugquestcontri
Modified: 2017-03-27 08:14 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bugquestcontri 2014-05-17 04:53:12 UTC
Problem description: 
When in the sidebar, a color is applied and needs to be applied immediately again, the color selection window needs to be opened and the color needs to be selected again. 
Further it is not  possible to keep the mouse key pressed,move to the required color, release the mouse key and have the required color applied.

This reduces speed and requires clicking again. 
(Clicking can lead to serious repetitive strain injuries; I suffered from it thus know the problem painfully well.)


Solution and enhancement request:
Enable the functionality of the color buttons of the normal toolbar also in the side bar
Operating System: All
Version: 4.2.4.2 release
Comment 1 Joel Madero 2014-05-21 15:36:53 UTC
Hm I cannot reproduce this. If you're talking about in writer - I did the following:

1. Open writer.

2. Wrote some text on two lines

3. Selected text on first line

4. Set color of text to green using sidebar

5. Selected second line

6. Was able to just push the icon for font color and it applied green to that line as well.

Am I missing something?
Comment 2 Maxim Monastirsky 2014-05-21 20:40:13 UTC
(In reply to comment #1)
> Am I missing something?

@Joel: You checked only the two button from the 'Character' panel, which indeed use split buttons. But none of the other color pickers in the sidebar has this feature. This includes: Paragraph background color, line color, area fill, cell background, border line (the last two in calc).
Comment 3 Pedro 2014-05-23 00:05:04 UTC
Confirmed under Windows XP.
It is easier to test in Calc (this bug affects all modules)

1. Select one cell. 
2. Change background color to Black using the icon in the Formatting (horizontal) toolbar.
3. Click on another cell. 
4. Notice that the background color indicator in the Formatting toolbar icon still shows Black while the Cell Background indicator returned to No Color
4. Clicking on the Background Color icon in the Formatting toolbar instantly turns the cell Black while clicking on the Cell Background icon on the Sidebar requires you to select Black again.

5. A good indicator that these two buttons aren't working together is that the Default color for a cell Background in a new spreadsheet is Yellow according to the icon on the Formatting toolbar but is set to No Color in the Sidebar.
Comment 4 Heiko Tietze 2017-03-27 08:14:57 UTC
Color handling has been improved considerably. WFM now.