Bug 78856 - Malfunction insertCells/insertRows and sum function in spreadsheet
Summary: Malfunction insertCells/insertRows and sum function in spreadsheet
Status: RESOLVED DUPLICATE of bug 77647
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-18 11:39 UTC by bug-fritz
Modified: 2015-02-19 15:23 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
the attached spreadsheet demonstrates the bug, pls run the script BugDemo (15.84 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-05-18 11:39 UTC, bug-fritz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bug-fritz 2014-05-18 11:39:46 UTC
Created attachment 99271 [details]
the attached spreadsheet demonstrates the bug, pls run the script BugDemo

Since several years I am using a  LibreOfficeBasic - script to manage my stock account.
After the installation of XUBUNTU 14.04 (LibreOffice 4.2.3 – rc3 – 0ubuntu2) there was a malfunction. It persists when I changed to LibreOffice 4.2.4.2 from the LibreOffice-Homepage.
The bug occurs in connection with the methods
Sheet.insertCells(CellRangeAddress, com.sun.star.sheet.CellInsertMode.DOWN)
or
Sheet.Rows.insertByIndex(x,y)
and
the sum-function.
Given a spreadsheet table with blocks of rows containing the same numbers of rows and the sum-function for each column of the block in the last rows of a block. If you want to insert free space on top of the table in order to insert a new block using one of the above mentioned methods the blocks will be moved down and the cell addresses in the sum-function should be changed accordingly. 
That is true for the second and all following blocks but not for the first one. The start address of this sum-function is not affected by the movement of the block.
Comment 1 m.a.riosv 2014-05-26 00:00:27 UTC
Hi Fritz, thanks for reporting.

It seems working fine with:
Win7x64
Version: 4.3.0.0.beta1 Build ID: 2e39c7e59c8fc8b16a54c3d981dceef27fb0c07f
http://downloadarchive.documentfoundation.org/libreoffice/old/4.3.0.0.beta1/

I can't verify with:
Version: 4.2.5.0.0+Build ID: 585077d4f681582386baa10acff53abdd280552b
TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-05-25_19:53:59
because I can find a bug in it, that crash in Menu/Tools/Macros/Run Macro

Issues in relation with insert rows have been solved in this bug:
https://bugs.freedesktop.org/show_bug.cgi?id=77647

Please if you are not agree, or you can reproduce in version 4.2.5 or higher, reopen it.

*** This bug has been marked as a duplicate of bug 77647 ***