Bug 78915 - arc svg export bug (plus segment at line end)
Summary: arc svg export bug (plus segment at line end)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-19 15:01 UTC by László Németh
Modified: 2015-06-21 18:11 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
screenshot of the bad segment/line joint (6.11 KB, image/png)
2014-05-19 15:02 UTC, László Németh
Details
source document of the vector graphic (25.25 KB, application/vnd.oasis.opendocument.graphics)
2014-05-19 15:05 UTC, László Németh
Details
SVG export with bad line end (4.78 KB, application/xml)
2014-05-19 20:44 UTC, László Németh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description László Németh 2014-05-19 15:01:03 UTC
Sometimes arc lines get a plus line segment in the SVG export (near zero length, but the line joint results a noticeable visual problem).

The bad part of the attached SVG export, maybe a rounding error (only one of the line ends is bad in the attached test case):

d="M 1964,655 L 1965,655 C 

instead of the same values, eg.:

d="M 1965,655 L 1965,655 C
Comment 1 László Németh 2014-05-19 15:02:14 UTC
Created attachment 99340 [details]
screenshot of the bad segment/line joint
Comment 2 László Németh 2014-05-19 15:05:50 UTC
Created attachment 99341 [details]
source document of the vector graphic
Comment 3 László Németh 2014-05-19 20:44:40 UTC
Created attachment 99356 [details]
SVG export with bad line end
Comment 4 QA Administrators 2015-06-08 14:41:45 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.3 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results;
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-06-08
Comment 5 Buovjaga 2015-06-21 18:11:48 UTC
Joint is ok now (compared in Firefox, zoomed fully).

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 3ecef8cedb215e49237a11607197edc91639bfcd
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-06-19_23:16:58
Locale: fi-FI (fi_FI)