Bug 79080 - 4.3Beta1: Text lost in drawing objects when inserted as "GDI metafile" into a Writer document
Summary: 4.3Beta1: Text lost in drawing objects when inserted as "GDI metafile" into a...
Status: RESOLVED DUPLICATE of bug 78040
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
4.3.0.0.beta1
Hardware: Other All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks:
 
Reported: 2014-05-22 17:48 UTC by Gerry
Modified: 2015-12-15 11:03 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Text in GDI metafile objects lost in LO 4.3Beta (16.02 KB, application/vnd.oasis.opendocument.text)
2014-05-22 17:48 UTC, Gerry
Details
how it looks in libO 4.2.5 and 4.3beta (99.14 KB, image/jpeg)
2014-05-24 23:34 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerry 2014-05-22 17:48:46 UTC
Created attachment 99593 [details]
Text in GDI metafile objects lost in LO 4.3Beta

Writer 4.3Beta1 loses text in GDI metafiles. The drawings were made in LO Draw and then copied and then "Insert as" -> "GDI metafile". This is a regression.

How to reproduce:
* Open attached odt document and see.

System:
Version: 4.4.0.0.alpha0+
Build ID: 2c61edfdf57dabbd86ecc440444b6b00443f916a
TinderBox: Win-x86@39, Branch:master, Time: 2014-05-22_01:01:57

Windows XP SP3 in Virtualbox
Comment 1 Yousuf Philips (jay) (retired) 2014-05-24 23:33:26 UTC
Confirmed in 4.3beta1 and not in 4.2.5.
Comment 2 Yousuf Philips (jay) (retired) 2014-05-24 23:34:23 UTC
Created attachment 99746 [details]
how it looks in libO 4.2.5 and 4.3beta
Comment 3 Joel Madero 2014-05-25 00:34:35 UTC
We should avoid cc'ing Michael on bugs in the future unless he has specifically requested to be cc'ed ;) Will get a bibisect shortly
Comment 4 Joel Madero 2014-05-25 00:51:35 UTC
0c42858a0202dde92bb2263190fac7030d846dab is the first bad commit
commit 0c42858a0202dde92bb2263190fac7030d846dab
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Sun May 11 22:20:50 2014 +0000

    source-hash-2be3417bf6dba2a0897b21e15d22ef2f8aac99e3
    
    commit 2be3417bf6dba2a0897b21e15d22ef2f8aac99e3
    Author:     Caolán McNamara <caolanm@redhat.com>
    AuthorDate: Mon Mar 10 09:45:06 2014 +0000
    Commit:     Caolán McNamara <caolanm@redhat.com>
    CommitDate: Mon Mar 10 11:36:26 2014 +0000
    
        coverity#1103651 Unchecked return value
    
        Change-Id: Iee2bbba1e581364f72a73421ba8e799fa05a94e4

:100644 100644 0c2b4dfe8e947c5f3a92e59ddf9bfa5942d1638d ea96a0526310063bde21923d70f4fa8a33c0dbc4 M	ccache.log
:100644 100644 ccd34f584d111c786b0a501f36a293d14f4c1f06 262bf2e11cbd9f76479f5594fd5a3fb1e53c4967 M	commitmsg
:100644 100644 a7923a2d4a14ba7c495f817b0fb83e3594ec2bc7 e3c3207390a08b6ab0e55ea902d0f41599a0c0cb M	make.log
:040000 040000 9ed00b62d470359016b968190db4cd858bc36922 bb344f1b5623f2f2b3c70ac8faba85c5a362582c M	opt


# bad: [a92705c1fabafddd43d175a0714855cd22551232] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
# good: [6ab7f53af36f13bbefdd4e4fcbd3d1ea432a77d9] source-hash-22029c7e17b4cb48acb058d47ec9c3b6b8b6b294
git bisect start 'latest' 'oldest'
# good: [bebf9d31c8fe9de96798484288a0fffc4d54917d] source-hash-09e5de8278dd8f13adcf614db35c8a8a04ba8e47
git bisect good bebf9d31c8fe9de96798484288a0fffc4d54917d
# bad: [fac643700ecfabc737836bbed068776f34037d53] source-hash-40a61d93ade494fa98c23a9fd8776c8dadf8f30f
git bisect bad fac643700ecfabc737836bbed068776f34037d53
# bad: [d97d068402198fd528087c954ff8bf7fc2380a77] source-hash-3d1b1eea83703919c43620f9adef05e5b24c4bed
git bisect bad d97d068402198fd528087c954ff8bf7fc2380a77
# good: [3028c93bb1bec9aadbc210f29569c0b30b8cfd45] source-hash-3f0a8dc3c8204d6a500a5da64ad57996d593022f
git bisect good 3028c93bb1bec9aadbc210f29569c0b30b8cfd45
# bad: [469dea83beaa20dde4b6d71e9520adbbed0925ca] source-hash-077a74cfc6dbea5ee275fd11b65b523cc525e2e4
git bisect bad 469dea83beaa20dde4b6d71e9520adbbed0925ca
# bad: [31955a7c3a79cfae08392bc6bd21d01311e07b63] source-hash-c59b3d6c5c8096486730007d9b9b053793b90b1e
git bisect bad 31955a7c3a79cfae08392bc6bd21d01311e07b63
# bad: [26011d4c89af02f6d2088817544bb6cf8d9e5dee] source-hash-dd1050b182260a26a1d0ba6d0ef3a6fecc3f4e07
git bisect bad 26011d4c89af02f6d2088817544bb6cf8d9e5dee
# bad: [0c42858a0202dde92bb2263190fac7030d846dab] source-hash-2be3417bf6dba2a0897b21e15d22ef2f8aac99e3
git bisect bad 0c42858a0202dde92bb2263190fac7030d846dab
# first bad commit: [0c42858a0202dde92bb2263190fac7030d846dab] source-hash-2be3417bf6dba2a0897b21e15d22ef2f8aac99e3
Comment 5 Joel Madero 2014-05-25 00:52:04 UTC
Marking as:
Major - appears to user like loss of data
High - regression + data loss
Comment 6 Michael Meeks 2014-05-26 11:14:12 UTC
Tomaz - one that might be interesting wrt. your WMF/EMF+ work, regression testing etc. =)
Comment 7 Tomaz Vajngerl 2014-05-26 11:32:19 UTC
Yes. However this is not a WMF/EMF problem but it could be nicely tested, so I will take this bug.
Comment 8 Michael Stahl (allotropia) 2014-05-30 15:51:50 UTC
was fixed by 86823db3412fc10ca75fa1e0b1900118582149c6

*** This bug has been marked as a duplicate of bug 78040 ***
Comment 9 Robinson Tryon (qubit) 2015-12-15 11:03:02 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]