Download it now!
Bug 79203 - Label Wizard - uninitialized exceptions on starting and selecting database
Summary: Label Wizard - uninitialized exceptions on starting and selecting database
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-25 09:17 UTC by Alex Thurgood
Modified: 2015-01-26 10:59 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
console logs + bt with symbols (10.54 KB, text/plain)
2014-05-27 21:13 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Thurgood 2014-05-25 09:17:55 UTC
How to reproduce :

1) Start LO
2) File > New > Label
3) Select bibliography database in database select dropdown menu

Terminal output :

warn:xmloff.core:12768:1:xmloff/source/core/xmlimp.cxx:858: exception caught
warn:legacy.osl:12768:1:xmloff/source/core/xmlimp.cxx:859: caught an exception!
in function:virtual void SvXMLImport::setTargetDocument(const com::sun::star::uno::Reference<com::sun::star::lang::XComponent>&)
type: com.sun.star.lang.NotInitializedException
context: N8dbaccess17ODatabaseDocumentE

warn:xmloff.core:12768:1:xmloff/source/core/xmlimp.cxx:858: exception caught
warn:legacy.osl:12768:1:xmloff/source/core/xmlimp.cxx:859: caught an exception!
in function:virtual void SvXMLImport::setTargetDocument(const com::sun::star::uno::Reference<com::sun::star::lang::XComponent>&)
type: com.sun.star.lang.NotInitializedException
context: N8dbaccess17ODatabaseDocumentE

warn:xmloff.core:12768:1:xmloff/source/core/xmlimp.cxx:858: exception caught
warn:legacy.osl:12768:1:xmloff/source/core/xmlimp.cxx:859: caught an exception!
in function:virtual void SvXMLImport::setTargetDocument(const com::sun::star::uno::Reference<com::sun::star::lang::XComponent>&)
type: com.sun.star.lang.NotInitializedException
context: N8dbaccess17ODatabaseDocumentE

warn:legacy.osl:12768:1:sw/source/core/uibase/dbui/dbmgr.cxx:1645: Exception in SwDBManager::GetColumnSupplier
Comment 1 Alex Thurgood 2014-05-25 09:22:01 UTC
Debug build of LO master :

Version: 4.4.0.0.alpha0+
Build ID: 675776170671ba0a1fc1b2bf9e915537cd08b080
Comment 2 Lionel Elie Mamane 2014-05-27 07:30:09 UTC
Is there any observable symptom, that is anything that does not work?

The com.sun.star.lang.NotInitializedException in SvXMLImport::setTargetDocument are "usual"; I see them each time I open an .odb file.

The "Exception in SwDBManager::GetColumnSupplier" could be a more interesting lead. If someone has time to attach a debugger and see what exception is thrown from where...
Comment 3 Julien Nabet 2014-05-27 21:13:06 UTC
Created attachment 99987 [details]
console logs + bt with symbols

I attached a gdb session which includes a bt.

Notice this console log:
warn:legacy.tools:29912:1:forms/source/component/FormComponent.cxx:2027: OBoundControlModel::impl_connectDatabaseColumn_noNotify: the form is just *loaded*, but we already have a field!
Comment 4 Lionel Elie Mamane 2014-05-28 04:55:40 UTC
(In reply to comment #3)
> Created attachment 99987 [details]
> console logs + bt with symbols

This seems to be yet another exception in a completely different place than what Alex reported?
Comment 5 Alex Thurgood 2014-05-28 07:18:37 UTC
(In reply to comment #2)
> Is there any observable symptom, that is anything that does not work?
> 
> The com.sun.star.lang.NotInitializedException in
> SvXMLImport::setTargetDocument are "usual"; I see them each time I open an
> .odb file.
> 

OK, I'll ignore that one then.


> The "Exception in SwDBManager::GetColumnSupplier" could be a more
> interesting lead. If someone has time to attach a debugger and see what
> exception is thrown from where...

Am currently rebuilding again from master, will re-test when finished and see what gdb has to say.
Comment 6 Alex Thurgood 2015-01-03 17:39:54 UTC
Adding self to CC if not already on
Comment 7 Alex Thurgood 2015-01-26 10:59:08 UTC
Can't see any visible symptom, closing as wfm