Bug 79284 - FILEOPEN: Open an Ods file crashes/hangs
Summary: FILEOPEN: Open an Ods file crashes/hangs
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.0.0.beta1
Hardware: Other All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks:
 
Reported: 2014-05-27 01:42 UTC by m.a.riosv
Modified: 2015-12-15 11:03 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
File with the issue. (30.87 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-05-27 01:42 UTC, m.a.riosv
Details
Windbg report (5.07 KB, text/plain)
2014-05-27 01:43 UTC, m.a.riosv
Details

Note You need to log in before you can comment on or make changes to this bug.
Description m.a.riosv 2014-05-27 01:42:05 UTC
Created attachment 99907 [details]
File with the issue.

Win7x64
Version: 4.3.0.0.beta1 Build ID: 2e39c7e59c8fc8b16a54c3d981dceef27fb0c07f
Version: 4.4.0.0.alpha0+ Win-x86@39, Branch:master, Time: 2014-05-26_01:36:09

Opening attached file crash. (file from bug https://bugs.freedesktop.org/show_bug.cgi?id=77379)

Last version working for me:
Version: 4.2.5.0.0+ Win-x86@42, Branch:libreoffice-4-2, Time: 2014-05-25_19:53:59
Comment 1 m.a.riosv 2014-05-27 01:43:46 UTC
Created attachment 99908 [details]
Windbg report
Comment 2 tommy27 2014-05-27 05:01:49 UTC
confirmed under Win7x64
file can be opened in 4.2.4.2 and crashes/hangs in 4.3.0.0.beta1
Build ID: 2e39c7e59c8fc8b16a54c3d981dceef27fb0c07f
Comment 3 Xisco Faulí 2014-05-28 15:01:34 UTC
Issue bibisected:

ea5723ff672d4a3ffb9ee123a96dda4681703a50 is the first bad commit
commit ea5723ff672d4a3ffb9ee123a96dda4681703a50
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Wed May 21 08:57:55 2014 +0000

    source-hash-1b8cfd5d1414da9127ff18e4701b40f5bceabb36
    
    commit 1b8cfd5d1414da9127ff18e4701b40f5bceabb36
    Author:     Markus Mohrhard <markus.mohrhard@collabora.co.uk>
    AuthorDate: Tue May 20 23:59:55 2014 +0200
    Commit:     Markus Mohrhard <markus.mohrhard@collabora.co.uk>
    CommitDate: Wed May 21 01:50:44 2014 +0200
    
        remove unnecessary whitespaces
    
        Change-Id: I4d93c0149aaf90e2477c1382aa51f8f08c967626

:100644 100644 501fbfa427b8a231fe035cd8c6c9861d0483e887 03ad3b133ed354d5ab45bdc712a5355013402c17 M	ccache.log
:100644 100644 94e1769dda5ee27e4952754e43c4d26fe19c2009 e900cb9aba87ebf78801bd60b03866aab0460fac M	commitmsg
:100644 100644 8c966b034e7c757c8922b3ba931bd93077f23e64 b8dc772fd79ceee78f8854fb2bdf577904e75049 M	make.log
:040000 040000 5f3414102b71bcb5a2c7f817d6502959169c4345 291f8ca8cacce30d162bc70628131b1a960519bb M	opt


# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# good: [e02439a3d6297a1f5334fa558ddec5ef4212c574] source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb
git bisect good e02439a3d6297a1f5334fa558ddec5ef4212c574
# good: [4850941efe43ae800be5c76e1102ab80ac2c085d] source-hash-980a6e552502f02f12c15bfb1c9f8e6269499f4b
git bisect good 4850941efe43ae800be5c76e1102ab80ac2c085d
# good: [a900e72b6357882284c5955bdf939bf14269f5fb] source-hash-dd1050b182260a26a1d0ba6d0ef3a6fecc3f4e07
git bisect good a900e72b6357882284c5955bdf939bf14269f5fb
# skip: [e80660c5a1d812cd04586dae1f22767fc3778c4a] source-hash-07c60c8ee2d1465544a6a39e57bc06b3690b8dfb
git bisect skip e80660c5a1d812cd04586dae1f22767fc3778c4a
# good: [df9bcaed2faa2a8d11b19f877cdff3a12a887278] source-hash-6ba9692d8bbe3e3c245aca9a7c928e81178d05f1
git bisect good df9bcaed2faa2a8d11b19f877cdff3a12a887278
# good: [741197a13a361480f59eeb3bd1401f984f49f1c0] source-hash-9a61470eb1fa161cba70f2e9c4ea8817dc7f617e
git bisect good 741197a13a361480f59eeb3bd1401f984f49f1c0
# good: [882db5e268e28962bdf805c820a5e031b0df9936] source-hash-383dccc094f8c8c07b4298ce0b7406d18cd61cee
git bisect good 882db5e268e28962bdf805c820a5e031b0df9936
# good: [69e91b0c890097cfb1781733f260644bb1ec9ee8] source-hash-66fce1f61e7e088bd92e19ecb0dd94553de6f824
git bisect good 69e91b0c890097cfb1781733f260644bb1ec9ee8
# good: [426fdcf0b13134ffbc7f92900d5862fad3723192] source-hash-c9f3c508bb1a1d94fd6172b9cdac30278559f31c
git bisect good 426fdcf0b13134ffbc7f92900d5862fad3723192
# bad: [9f0fd4c327fa8765bef8a0e2a0e85a620ab6f835] source-hash-fe1e1d1292973211f0edfa64c05279ca59634652
git bisect bad 9f0fd4c327fa8765bef8a0e2a0e85a620ab6f835
# bad: [ea5723ff672d4a3ffb9ee123a96dda4681703a50] source-hash-1b8cfd5d1414da9127ff18e4701b40f5bceabb36
git bisect bad ea5723ff672d4a3ffb9ee123a96dda4681703a50
# first bad commit: [ea5723ff672d4a3ffb9ee123a96dda4681703a50] source-hash-1b8cfd5d1414da9127ff18e4701b40f5bceabb36
Comment 4 Xisco Faulí 2014-06-04 14:47:22 UTC
Can't be reproduced with Version: 4.4.0.0.alpha0+
Build ID: 6b4c596b01039324cfe78f38c4e3ffb9080bcd34 under Ubuntu 14.04 AMD64
Comment 5 tommy27 2014-06-04 18:27:22 UTC
no crash with Version: 4.4.0.0.alpha0+ under Win7x64
Build ID: dacab84536f61f79a5422e1d8d394019ec62f3ec
TinderBox: Win-x86@39, Branch:master, Time: 2014-06-04_04:27:18

I mark this as RESOLVED WORKSFORME
let's hope it will be backported to 4.3.x as well
Comment 6 m.a.riosv 2014-06-04 21:15:47 UTC
Works for me now with:
Version: 4.2.5.1 Build ID: 881bb88abfe2992c6cede97c23e64a9885de87de
Version: 4.2.6.0.0+ Build ID: f03c2bb813d87bc3c89af78f7f01c587db4c59de
   TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-06-03_01:47:36
Version: 4.4.0.0.alpha0+ Build ID: dacab84536f61f79a5422e1d8d394019ec62f3ec
   TinderBox: Win-x86@39, Branch:master, Time: 2014-06-04_04:27:18

STILL CRASH for me with a clean profile:
Version: 4.3.0.0.beta1+ Build ID: b8cda0d73c0311e71f99cf8d7283abcf62164e30
   TinderBox: Win-x86@42, Branch:libreoffice-4-3, Time: 2014-06-04_12:58:42

Absolutely unacceptable from my POV, close the bug in this way, without verify that it has been effectively resolved against bug version.

Branch:libreoffice-4-3 is our next major release, and the most important at this time, so IMO really serious if it has a crash bug opening the native file format.

We don't know what has resolved the issue in other branches, so we can't assume it will be backported to 4.3.
Comment 7 tommy27 2014-06-05 03:50:31 UTC
(In reply to comment #6)
> ....
>
> STILL CRASH for me with a clean profile:
> Version: 4.3.0.0.beta1+ Build ID: b8cda0d73c0311e71f99cf8d7283abcf62164e30
>    TinderBox: Win-x86@42, Branch:libreoffice-4-3, Time: 2014-06-04_12:58:42
> 
> Absolutely unacceptable from my POV, close the bug in this way, without
> verify that it has been effectively resolved against bug version.
> 

as far as I remember the procedure is that even when a bug is just fixed in master you should mark it RESOLVED

then interested users should ping developers asking for backport.

I add Markus Mohrhard to CC list since I've seen his name in the bibisect stats.
maybe he know what to do.
Comment 8 Markus Mohrhard 2014-06-05 03:56:26 UTC
This is another case of crash related to OpenGL drivers. I'll disable that feature for beta3 so this can be closed. Some people will be able to reproduce this issues and others will not see it.

I just did not have time to disable it for beta2 yet and there are still small chances that we are backporting the missing changes from master and make the feature an experimental one.
Comment 9 Robinson Tryon (qubit) 2015-12-15 11:03:32 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]