Bug 79327 - VIEWING: Regression Font Agate-Normal renders appallingly.
Summary: VIEWING: Regression Font Agate-Normal renders appallingly.
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.7.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-27 17:40 UTC by declan_moriarty
Modified: 2014-06-04 15:22 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
This is a zip file with 3 files and one folder. There are 2 (380.97 KB, application/zip)
2014-05-27 17:58 UTC, declan_moriarty
Details
Document in Word 2000 on Windows XP (61.26 KB, image/jpeg)
2014-05-28 03:17 UTC, Yousuf Philips (jay) (retired)
Details
Document in Word Viewer 2003 on Windows XP (60.86 KB, image/jpeg)
2014-05-28 03:17 UTC, Yousuf Philips (jay) (retired)
Details
Test file of Agate-Normal font created in Word on PC correct. (19.50 KB, application/msword)
2014-05-28 20:02 UTC, declan_moriarty
Details
Agate Normal Word screenshot showing the version of Word on the PC used to create and display it. (110.14 KB, image/tiff)
2014-05-28 20:05 UTC, declan_moriarty
Details
Agate Normal Word displayed in LO 4.0.6.2 on iMac correctly. (336.06 KB, image/tiff)
2014-05-28 20:19 UTC, declan_moriarty
Details
LO 4.0.6.2 font menu showing A-N Font correctly. (1.29 MB, image/tiff)
2014-05-28 21:52 UTC, declan_moriarty
Details
LODev 4.3.0.0 beta font menu showing A-N font as "A" in menu incorrectly. (1.13 MB, image/tiff)
2014-05-28 22:02 UTC, declan_moriarty
Details
This is a test of A-N font from TextEdit which works. (360 bytes, text/rtf)
2014-05-28 22:23 UTC, declan_moriarty
Details
Agate Normal font produced from iText Express rendered correctly. (19.00 KB, application/msword)
2014-05-28 22:34 UTC, declan_moriarty
Details

Note You need to log in before you can comment on or make changes to this bug.
Description declan_moriarty 2014-05-27 17:40:29 UTC
Problem description: 
I an all versions of LibreOffice after 4.0.6.2 the font Agate-Normal renders dreadfully.
Steps to reproduce:
1. Install Agate-Normal font.
2. Create new Writer Document.
3. Select Agate-Normal fort for list.  Type characters in Agate-Normal.

Current behavior:

Characters are displayed all over the line, some characters are displayed at the end of the line (See attachment).  Agate-Normal when selected from the font list has a capital A and not Agate-Normal in the list, this is the first indication of trouble.
Expected behavior:
Text is displayed normally.  Agate-Normal appears normally in the font list.

Note that Agate-Normal passes font validation in Font Book.
System: iMac with OS X 10.7.3

Last Wording Version: LibreOffice 4.0.6.2

Note that I am working with .doc files at the moment, this problem affects ODF files as well, and is a LO Viewing issue, so the format of the text file is immaterial.
Operating System: Mac OS X
Version: 4.3.0.0.beta1
Comment 1 declan_moriarty 2014-05-27 17:58:43 UTC
Created attachment 99970 [details]
This is a zip file with 3 files and one folder.  There are 2
Comment 2 declan_moriarty 2014-05-27 18:02:44 UTC
In the attachment there are 2 screenshots and the file agate normal.doc plus the agate-normal folder with the Agate-Norml font in it.  The 2 screenshots show the font working in LO 4.0.6.2 and not working in LODev 4.3.0.0 Beta.
Comment 3 Yousuf Philips (jay) (retired) 2014-05-28 03:16:52 UTC
Confirmed that it looks dreadfull in Linux Mint in the latest releases from 3.6 to 4.2 and 4.3 beta, but it also looked dreadfull when i looked at it in Word 2000 and Word Viewer 2003 on Windows XP. I believe it must be a font problem.
Comment 4 Yousuf Philips (jay) (retired) 2014-05-28 03:17:26 UTC
Created attachment 99993 [details]
Document in Word 2000 on Windows XP
Comment 5 Yousuf Philips (jay) (retired) 2014-05-28 03:17:46 UTC
Created attachment 99994 [details]
Document in Word Viewer 2003 on Windows XP
Comment 6 declan_moriarty 2014-05-28 19:57:35 UTC
here are 2 attachments.  I created Agate Normal Word.doc in Word XP/2002 on a PC with Agate Normal font installed.  This works properly.  I created a screenshot showing this font being displayed in Word 2002 correctly.  Documents created on the mac with this font in LO after 4.0.6.2 will have a corrupted font.  Documents created on the PC with a good font will work in Word and will display wrongly in LO > 4.0.6.2 on the mac and display properly in LO 4.0.6.2.  They will subsequently display properly in Word on the PC.
Comment 7 declan_moriarty 2014-05-28 19:59:18 UTC
Please see above comment for reason for re-opening bug.
Comment 8 declan_moriarty 2014-05-28 20:02:24 UTC
Created attachment 100048 [details]
Test file of Agate-Normal font created in Word on PC correct.
Comment 9 declan_moriarty 2014-05-28 20:05:27 UTC
Created attachment 100049 [details]
Agate Normal Word screenshot showing the version of Word on the PC used to create and display it.
Comment 10 declan_moriarty 2014-05-28 20:19:23 UTC
Created attachment 100056 [details]
Agate Normal Word displayed in LO 4.0.6.2 on iMac correctly.

This screenshot shows Agate Normal Word.doc being displayed correctly in LO 4.0.6.2 on the iMac.
Comment 11 declan_moriarty 2014-05-28 21:52:12 UTC
Created attachment 100058 [details]
LO 4.0.6.2 font menu showing A-N Font correctly.

This attachment shows that Agate Normal font appears correctly in the font pull down menu on LibreOffice 4.0.6.2.
Comment 12 declan_moriarty 2014-05-28 22:02:59 UTC
Created attachment 100059 [details]
LODev 4.3.0.0 beta font menu showing A-N font as "A" in menu incorrectly.
Comment 13 declan_moriarty 2014-05-28 22:23:42 UTC
Created attachment 100060 [details]
This is a test of A-N font from TextEdit which works.

This attachment opens in Word on the PC correctly.  It also opens in LO 4.0.6.2.
Comment 14 declan_moriarty 2014-05-28 22:34:18 UTC
Created attachment 100061 [details]
Agate Normal font produced from iText Express rendered correctly.

This file displays correctly on the PC in Word.
Comment 15 declan_moriarty 2014-05-28 23:09:13 UTC
I have done more research and files produced on the mac using LibreOffice all versions display badly on the PC.  I have also produced screenshots showing the pulldown menu form LO 4.0.6.2 and LODev 4.3.0.0 that shows Agate-Normal correctly and in the case of LO 4.3 beta as an "A" and nothing else.

Agate Normal displays correctly and can be saved successfully from TextEdit.  This is also true with iTextExpress.

I have produced a screenshot of the FontBook validation window for Agate-Normal showing it passed validation.

I don't know what is making LO 4.0.6.2 save badly, since this version of LO displays the font correctly!
Comment 16 Yousuf Philips (jay) (retired) 2014-06-03 01:44:53 UTC
The problem is in the ttf font. If the ttf font is installed on my Windows 7 machine, the text is messed up in LibO 3.5.7 and 4.0.6 as well as Kingsoft Office. But if i install the .otf font then it show perfect.
Comment 17 Alex Thurgood 2014-06-04 15:10:36 UTC
The whole LO 4.0.x range was pretty buggy and is pretty out of date now.
Comment 18 Alex Thurgood 2014-06-04 15:11:01 UTC
(In reply to comment #17)
> The whole LO 4.0.x range was pretty buggy and is pretty out of date now.

On the Mac anyway
Comment 19 Alex Thurgood 2014-06-04 15:21:30 UTC
Agate font looks ugly to me osx 10.9.3, in font viewer, in Pages, in LO

In Word 2011 for Mac, the last test document looks ok