Bug 79368 - toolbar icons that are not visible (only via overflow-button on right edge) performs the action *twice* when clicked
Summary: toolbar icons that are not visible (only via overflow-button on right edge) p...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: framework (show other bugs)
Version:
(earliest affected)
4.3.0.0.beta1
Hardware: All All
: medium minor
Assignee: Andrzej Hunt
URL:
Whiteboard: target:4.4.0 target:4.3.0 target:4.2.5
Keywords: regression
Depends on:
Blocks: Toolbars-Overflow
  Show dependency treegraph
 
Reported: 2014-05-28 14:17 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-10-07 11:21 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
screencast explaining the bug (2.03 MB, video/webm)
2014-05-28 23:35 UTC, Yousuf Philips (jay) (retired)
Details
the double dialogs in windows 7 (91.98 KB, image/png)
2014-05-30 00:00 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-05-28 14:17:05 UTC
With the insert toolbar open, click the insert image button and after selecting an image and pressing okay, the file dialog appears a second time. This doesnt happen when you do Menu > Insert > Image > From File... This was tested in Linux Mint with 4.2.4 and 4.3. Its possible this might just me my DE messing with me again as it doesnt happen in windows.
Comment 1 Yousuf Philips (jay) (retired) 2014-05-28 14:31:27 UTC
I tested it in 4.1 and it doesnt happen, so i guess its not my DE.
Comment 2 Kevin Suo 2014-05-28 14:59:10 UTC
Hi Philips, I do not reproduce with the following steps:
1. enable "Insert" toolbar (View - Toobars - Insert);
2. Click "From File" icon, choose a image and OK

The file dialog appears just once.

OS: Ubuntu 14.04 x86
LO Version: 4.3.0 beta 1.
Comment 3 Yousuf Philips (jay) (retired) 2014-05-28 23:35:04 UTC
Created attachment 100063 [details]
screencast explaining the bug
Comment 4 Firas Hanife 2014-05-29 22:50:41 UTC
Reproduced on openSUSE 13.1 (KDE) with 4.3.0.0.beta1 (not with 4.2.4.2)
Found a more general issue with Insert toolbar

Step to reproduce (default user settings):
1) Open a new Writer document
2) Open View > Toolbars > Insert
Now if you open "From File" only one dialog "Insert Image" appears.

3) Dock the Insert toolbar so that all the clickable buttons are not visible (you have yo click on >> to see them)
4) Try to open:
"Table"
"Section"
"Bookmark"
"AutoText"
"Special Character"
"From File"
"Movie and Sound"
"Indexes and Tables" (the second dialog appears after closing the first)
Comment 5 Yousuf Philips (jay) (retired) 2014-05-29 23:58:33 UTC
I was mistaken, this doesnt happen in 4.2.4, but it happens in 4.2.6. Also it happens in Windows and its even worse as you cant use LibO after you finish with the dialogs.
Comment 6 Yousuf Philips (jay) (retired) 2014-05-30 00:00:07 UTC
Created attachment 100126 [details]
the double dialogs in windows 7
Comment 7 Yousuf Philips (jay) (retired) 2014-05-30 00:00:54 UTC
(In reply to comment #5)
> and its even worse as you cant use LibO after you
> finish with the dialogs.

Was testing it some more and i couldnt reproduce this anymore for some strange reason, so please ignore this.
Comment 8 Joel Madero 2014-05-30 03:18:33 UTC
Unfortunately this one is not bibisectable - I can confirm the regression but in bibisect package there is a separate issue which prevents getting a bibisect.

Minor - does not prevent professional quality work but can slow you down a tiny bit
Medium - bumped up from low because it's a regression
Comment 9 Michael Stahl (allotropia) 2014-05-30 11:22:34 UTC
this is a generic problem with the toolbars,
if an icon is not visible in the main window but
only on the pop-up thingy, then clicking on it
performs the action twice.

happens in all applications.

it was working in 4.2.4.2 but is broken in current libreoffice-4-2,
sadly there's no 4.2.5.1 version in bugzilla yet.

clearly this should be fixed before the 4.2.5 release.
Comment 10 Michael Stahl (allotropia) 2014-05-30 11:53:14 UTC
regression from:

commit 9e3d6ec6e5333bf1fa4bd151a9897dad20d11a14
Author:     Andrzej Hunt <andrzej.hunt@collabora.com>
AuthorDate: Fri Apr 25 20:25:48 2014 +0100
Commit:     Caolán McNamara <caolanm@redhat.com>
CommitDate: Mon Apr 28 12:08:15 2014 +0000

    fdo#75489 Pass toolbar context menu commands to toolbar for handling.
Comment 11 Andrzej Hunt 2014-06-01 07:49:12 UTC
Fixed in:
http://cgit.freedesktop.org/libreoffice/core/commit/?id=1ae89d189200c1e351a396a3f02612b84a69985f

(Had fdo79368 rather than fdo#79368 in the commit title, hence no automatic notification I presume...)
Comment 12 Michael Stahl (allotropia) 2014-06-10 20:42:38 UTC
fixed in libreoffice-4-3 branch by commit:
50cfa89fe32e9c920cce58221a9ef970149c780c

fixed in libreoffice-4-2 branch by commit:
dfa23c4170a4a5a567fe48bac6682d1a556e77ba

fixed in libreoffice-4-2-5 branch by commit:
f8187a37122c7847fe80d2ba687b67e36ba60d4a