Bug 79371 - CRASH: press delete key in contour dialog
Summary: CRASH: press delete key in contour dialog
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.6.2 release
Hardware: Other All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:4.3.0 target:4.2.5
Keywords: needUITest, regression
Depends on:
Blocks: Contour-Editor
  Show dependency treegraph
 
Reported: 2014-05-28 14:43 UTC by Yousuf Philips (jay) (retired)
Modified: 2018-02-01 18:01 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
sample document so you can start from step 4 (660.80 KB, application/vnd.oasis.opendocument.text)
2014-05-28 14:43 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-05-28 14:43:50 UTC
Created attachment 100034 [details]
sample document so you can start from step 4

1. Open Writer
2. Insert An Image
3. right-click on image Wrap > Contour
4. right-click on image Wrap > Edit Contour
5. select the Contour
6. Press Delete
7. LibO Crashes

Tested in Linux Mint on LibO 4.1.6 and 4.2.4. Its fine in 4.0 and 4.3.

If you reopen LibO after the crash, you get the crash recovery, click 'cancel' and then 'yes'. Then click on Writer and it will jump back into the contour dialog.
Comment 1 Firas Hanife 2014-05-28 18:00:01 UTC
Reproduced on openSUSE 13.1 with 4.1.6.2 and 4.2.4.2.
(So I'm changing affected LibreOffice version)

4.3.0.0.beta1 does not crash.


After the crash (steps described by Jay Philips) and "Document recovery" has been canceled, opening a new Writer document opens "Contour Editor" window.

Steps to reproduce the next crash:
1) "Contour Editor" window is opened
2) Select "Select" (mouse pointer icon)
3) Press Canc

LibreOffice crashes (4.1.6.2 and 4.2.4.2)
Comment 2 Joel Madero 2014-05-28 18:16:01 UTC
Can you test with a daily 4.2?

http://dev-builds.libreoffice.org/daily/libreoffice-4-2/
Comment 3 Julien Nabet 2014-05-28 20:33:18 UTC
On pc Debian x86-64 with 4.2 sources updated today, I don't reproduce this. I used autocontour because the rest didn't seem to work. I must say it's the first time I try this and don't know at all how it works, so perhaps missed something.
Comment 4 Yousuf Philips (jay) (retired) 2014-05-28 23:23:14 UTC
Doesnt happen in 4.2.6.
Comment 5 Julien Nabet 2014-05-28 23:25:09 UTC
So let's put this as WFM (at least from future 4.2.6)
Comment 6 Michael Stahl (allotropia) 2014-05-30 15:41:43 UTC
was fixed by 

commit c4e10ad83fe1fa92a115327c1909218f5dc8c8bd
Author:     Caolán McNamara <caolanm@redhat.com>
AuthorDate: Wed Jan 8 11:22:25 2014 +0000

    Resolves: rhbz#1096486 avoid access to nonexisting parent dialog