Download it now!
Bug 79389 - FILEOPEN: Problem opening .csv file from USGS website
Summary: FILEOPEN: Problem opening .csv file from USGS website
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.2.1 release
Hardware: Other Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: CSV-Import
  Show dependency treegraph
 
Reported: 2014-05-29 00:51 UTC by jnoondam
Modified: 2017-07-20 19:56 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jnoondam 2014-05-29 00:51:26 UTC
Problem description: 

Calc locks up when attempting to import eg.txt (a CSV file from the USGS website). I’m using a Lenovo u430 Touch notebook. Windows 8.1. I checked the memory usage of Calc in the task manager and it doesn’t exceed 60 meg and I have memory free, so there’s got to be something going on there.

I posted to en.libreofficeforum.org and got this reply:

"Linux Mint 16, LibreOffice Version: 4.1.2.3 Build ID: 410m0(Build:3). I got the first 20K lines of the file (Linux command split -l 20000), when opened in Calc it says “The data could not be loaded completely because the maximum number of characters per cell was exceeded.” Maybe it’s related. Hope it helps"

Steps to reproduce:

1. To replicate the problem follow the instructions at this link: http://maps.cga.harvard.edu/qgis/wkshop/import_csv.php

2. You download this file: http://earth-info.nga.mil/gns/html/cntyfile/eg.zip

3. Unzip it, rename from eg.txt to eg.csv 

4. Open it in Calc. 

5. The only delimiter that the tutorial asks you to use is a tab character. So when the text import window appears, make sure only the tab delimiter check box is selected before the OK button is clicked.


Current behavior:

Calc freezes after the OK button is clicked.

Expected behavior:

Calc imports the CSV file and displays the table.
Operating System: Windows 8
Version: 4.2.2.1 release
Comment 1 Yousuf Philips (jay) (retired) 2014-06-15 01:55:55 UTC
On 4.2.4 on Windows 7, it took 14 minutes for the loading bar to begin moving and at 29 minutes, a dialog box stating that LibO could not load completely as the maximum number of characters per cell was exceeded, though pressing okay showed the sheet.

As a comparison, Word 2013 and Kingsoft Writer loaded the csv file in less than 10 seconds, though not rendered correctly as csv delimiter options werent presented.
Comment 2 QA Administrators 2015-07-18 17:44:09 UTC Comment hidden (obsolete)
Comment 3 Buovjaga 2015-10-23 08:21:29 UTC
It now opens in 10 secs. WFM.

New link: geonames.nga.mil/gns/html/cntyfile/eg.zip

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: fcc2415ade6ae93710bbbda9f7e163045e323105
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-10-21_16:55:13
Locale: fi-FI (fi_FI)