Download it now!
Bug 79759 - EDITING: http URLs containing @ not auto-hyperlinked properly
Summary: EDITING: http URLs containing @ not auto-hyperlinked properly
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.3.3 release
Hardware: Other All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-07 04:45 UTC by Aaron Marcuse-Kubitza
Modified: 2016-09-21 23:03 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot of incorrectly auto-hyperlinked URL (63.19 KB, image/png)
2014-06-07 04:45 UTC, Aaron Marcuse-Kubitza
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aaron Marcuse-Kubitza 2014-06-07 04:45:13 UTC
Created attachment 100584 [details]
screenshot of incorrectly auto-hyperlinked URL

Problem description: 

Steps to reproduce:
1. create new spreadsheet
2. insert "http://DwC@vegpath.org" into a cell, but do *not* press Enter
3. press Space
4. note that the URL, although valid, is not auto-hyperlinked properly
5. repeat steps 2-4 with "http://country@DwC@vegpath.org", which is not auto-hyperlinked at all

Current behavior:
URLs auto-hyperlinked incorrectly or not at all

Expected behavior:
URLs are auto-hyperlinked from the http:// to the end of the URL
Operating System: Ubuntu
Version: 4.2.3.3 release
Comment 1 m.a.riosv 2014-06-07 11:59:16 UTC
Hi Aoron, thanks for reporting.

Reproducible:
Win7x64
Version: 4.2.3.3 Id. de compilación: 882f8a0a489bc99a9e60c7905a60226254cb6ff0
Version: 4.2.5.1 Build ID: 881bb88abfe2992c6cede97c23e64a9885de87de
Version: 4.3.0.0.beta1+ Win-x86@42,Branch:libreoffice-4-3,Time:2014-06-04_12:58
Comment 2 QA Administrators 2015-06-08 14:42:20 UTC Comment hidden (obsolete)
Comment 3 Buovjaga 2015-06-21 19:05:48 UTC
Still repro.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 3ecef8cedb215e49237a11607197edc91639bfcd
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-06-19_23:16:58
Locale: fi-FI (fi_FI)
Comment 4 QA Administrators 2016-09-20 10:10:59 UTC Comment hidden (obsolete)
Comment 5 m.a.riosv 2016-09-21 23:03:54 UTC
Works for me.
Win10x64
Version: 5.2.2.1 (x64)
Build ID: 3c2231d4aa4c68281f28ad35a100c092cff84f5d
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
Locale: es-ES (es_ES); Calc: group