Bug 79802 - SLIDESHOW: long text "scroll through" animation shows just black block
Summary: SLIDESHOW: long text "scroll through" animation shows just black block
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
(earliest affected) release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
Whiteboard: BSA
Keywords: preBibisect, regression
Depends on:
Blocks: Slide-Show Object-Animations
  Show dependency treegraph
Reported: 2014-06-08 15:42 UTC by Thomas Buch
Modified: 2022-02-07 09:25 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:

test file for Bug 79802 (11.33 KB, application/vnd.oasis.opendocument.presentation)
2015-04-01 16:09 UTC, Thomas Buch

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Buch 2014-06-08 15:42:28 UTC
The bug appear both on windows XP and Win 8.1

It seems that there is an error (tried with two computers / installations of Impress), if you want to animate one long sentence to "scroll through", which contains more than 60 characters

Please watch this video which will illustrate the problem https://www.youtube.com/watch?v=eRTwcpWVShw

The behavior of the text animation "scroll through" is deferent if you includes "carriage returns" then the entire text block moves (in stead of scrolling in the text in one row)              
Operating System: Windows 8
Version: release
Comment 1 ign_christian 2014-06-15 14:40:33 UTC
Not reproducible under LO - Win7 32bit
Comment 2 Jean-Baptiste Faure 2014-08-06 06:24:42 UTC
Please attach your test file to this bug report. Watching a video is not enough to confirm a bug report.

Set status to NEEDINFO. Please set it back to UNCONFIRMED once you have provided requested informations. Thank you for your understanding.

Best regards. JBF
Comment 3 QA Administrators 2015-04-01 14:47:29 UTC Comment hidden (obsolete)
Comment 4 Thomas Buch 2015-04-01 16:09:23 UTC
Created attachment 114531 [details]
test file for Bug 79802
Comment 5 raal 2015-04-02 13:34:20 UTC
can you test with actual LO I tried with your file on LO, win7 and doesn't see error as in video.
Thank you
Comment 6 Buovjaga 2015-04-10 13:01:29 UTC
(In reply to Thomas Buch from comment #4)
> Created attachment 114531 [details]
> test file for Bug 79802

Confirmed in presentation mode on Windows, black block moving. OpenGL setting made no difference.

Linux is ok.

Win 7 Pro 64-bit, Version:
Build ID: c4c7d32d0d49397cad38d62472b0bc8acff48dd6
Locale: fi_FI

Version: (x64)
Build ID: 53d7c88da82f6d16c0c9a45a86a3f9d505764605
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-04-10_02:14:19
Locale: fi_FI

Ubuntu 14.10 64-bit 
Build ID: 40m0(Build:2)
Locale: en_US
Comment 7 tommy27 2016-04-16 07:28:40 UTC Comment hidden (obsolete)
Comment 8 Jean-Baptiste Faure 2016-05-07 23:20:24 UTC
Not reproducible for me under Linux. Please, test under MS-Windows.

Best regards. JBF
Comment 9 Buovjaga 2016-05-09 11:07:51 UTC
Black block still happening.

Btw. regression as I can't repro in 3.5. ign_christian said in comment 1 that 4.0 did not have it either.

Win 7 Pro 64-bit Version:
Build ID: 3d27afd26f7b85c46a7c7d08498000b9dbcea1c8
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-05-09_02:42:15
Locale: fi-FI (fi_FI)
Comment 10 Aron Budea 2016-09-12 05:25:09 UTC
I assume assignee was set by mistake.
Comment 11 Xisco Faulí 2016-09-13 14:29:25 UTC
As per today, this regression can't be bibisected as it was introduced before 4.4 branch and there's no bibisect repository for the affected branch, thus change 'bibisectRequest' to 'preBibisect'
Comment 12 QA Administrators 2018-05-18 02:33:28 UTC Comment hidden (obsolete)
Comment 13 Roman Kuznetsov 2019-01-14 12:25:40 UTC
still repro in

Build ID: 6b4ea2d8ddd681fec98773d7e0bbec9657a1fc08
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded
Comment 14 Pierre C 2020-09-02 16:18:24 UTC
Tested with LO, it works fine with Skia enabeled
Comment 15 Jean-Baptiste Faure 2022-02-06 22:06:20 UTC
No problem with Version: / LibreOffice Community
Build ID: 8b327cd86d71d71d2f5f883321e5d53e3b42ed4e
CPU threads: 8; OS: Linux 5.13; UI render: default; VCL: gtk3
Locale: fr-FR (fr_FR.UTF-8); UI: en-US
Calc: threaded


Version: / LibreOffice Community
Build ID: 57a9a2f2c7b60b1edffae0a070f0eefaedcf9e6d
CPU threads: 8; OS: Linux 5.13; UI render: default; VCL: gtk3
Locale: fr-FR (fr_FR.UTF-8); UI: fr-FR
Calc: threaded

Best regards. JBF
Comment 16 Buovjaga 2022-02-07 09:25:09 UTC
Not reproduced anymore even without Skia in 7.2.5.

However, there is another bug where it cuts off the beginning of the text, bug 147240.