Bug 79873 - Other: Missing change log
Summary: Other: Missing change log
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: WWW (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-10 09:53 UTC by Marc Joly
Modified: 2014-06-10 12:27 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Joly 2014-06-10 09:53:04 UTC
Problem description: 

Steps to reproduce:
1. Look for LibreOffice's features ChangeLog
2. Don't Find
3. Search more
4. Don't find
5. Search even more
5. Don't Find. Rage.

Current behavior:
No display of useful information about changes since previous versions on https://www.libreoffice.org/download/ pages

Expected behavior:
Display of useful information about changes since previous versions on https://www.libreoffice.org/download/ pages

Operating System: All
Version: 4.4.0.0.alpha0+ Master
Comment 1 chs 2014-06-10 11:24:50 UTC
Release notes are located in two places. The short version is here:
http://www.libreoffice.org/download/release-notes/
and this link is accessible from the download menu. It also points to the longer version on the wiki.

As for the alpha builds, the release notes tend to be a work in progress, nonetheless they always start to be drafted on the wiki:
https://wiki.documentfoundation.org/ReleaseNotes/4.4
Comment 2 Christian Lohmaier 2014-06-10 12:27:28 UTC
to add to that:

http://www.libreoffice.org/download/

→ "Release Notes" link on the right-hand side (or from "Download" navigation menu)
→ http://www.libreoffice.org/download/release-notes/

→ "new features and program enhancements" link
→ https://wiki.documentfoundation.org/ReleaseNotes/4.2#LibreOffice_4.2_Changes

If you want more details, use the list of bug fixes from the notes in the wiki

https://wiki.documentfoundation.org/Category:Release

or if you really want all stuff, view the complete list of changes from the logs from
http://download.documentfoundation.org/libreoffice/src/

(or have a look in the git-webinterface, e.g. http://cgit.freedesktop.org/libreoffice/core/log/?h=libreoffice-4.2.4.2