Bug 80193 - IDE: When going to edit a module in writer or calc, Libre Office crashes.
Summary: IDE: When going to edit a module in writer or calc, Libre Office crashes.
Status: RESOLVED DUPLICATE of bug 84887
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
4.3.0.0.beta2
Hardware: All Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: notBibisectable, regression
Depends on:
Blocks:
 
Reported: 2014-06-18 15:41 UTC by Fernand
Modified: 2015-12-17 10:57 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
windbg backtrace (3.33 KB, application/x-zip-compressed)
2014-07-10 13:11 UTC, Yousuf Philips (jay) (retired)
Details
basic windows has visual drawing problems (166.49 KB, image/png)
2014-07-16 02:45 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fernand 2014-06-18 15:41:36 UTC
Problem description: 
Libre office crashes when I try to edit a module in a writer document or a calc spreadsheat. It does open some modules, but most of the modules I try to Edit, LibreOffice crashes.
No problem though when opening a module in startup screen. 

Steps to reproduce:
1. Open writer document or calc spreadsheet
2. Tools --> Macros --> organise macros --> LibreOfficeDev Basic Macros
3. For example goto LibreOfficeDev Macros --> Tools --> edit Debug Module.

Current behavior:
LibreOffice crashes

Expected behavior:
Open module in Edit mode
              
Operating System: Windows 8
Version: 4.3.0.0.beta2
Comment 1 Julien Nabet 2014-06-18 19:35:02 UTC
On pc Debian x86-64 with 4.3 sources updated some days ago, I don't reproduce this.
For the test, could you rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile#Windows) and give it a new try?
Comment 2 Kevin Suo 2014-07-10 08:38:10 UTC
Hi Fernand and Julien,

I encountered the same problem when I was testing some of the extensions. When I was trying to edit a macro, libreoffice crashes.

Then I reset user profile, and then I do not reproduce it any more; however, after some time the crash appear again.

I have not find a way to 100% reproduce this with a new profile.

@Jay Philipz: Seems that you reproduce the same, did you find the steps?
Comment 3 Kevin Suo 2014-07-10 08:38:54 UTC
My version: 4.3.0.2
OS: WinXP SP3
Comment 4 Yousuf Philips (jay) (retired) 2014-07-10 13:08:06 UTC
After enabling the 'copy only visible cells' extension, i had a crash just opening  Tools --> Macros --> organize macros --> LibreOfficeDev Basic and it restarted, i had another crash after it successfully opened LibreOffice Basic and editing any of the macros in My Macros > SelVisiCell > Module2.

Will attached the backtrace of the second crash. This doesnt happen in 4.2.4.
Comment 5 Yousuf Philips (jay) (retired) 2014-07-10 13:11:12 UTC
Created attachment 102532 [details]
windbg backtrace
Comment 6 riesslibo 2014-07-15 09:05:53 UTC
Can confirm this behaviour for Win7/64 LibO V4.3.0.1 (Beta1):

- Macros brouhgt to the Installation in My Macros via Extension
- Open LO, Open Writer with "Unnamed"Textdoc, goto Extras - Macros - LibOMacros, MyMacros, Bib, Module and click one Macro and the Button Edit, LO Crashs
- After the Document recovery prozess, close the writer doc, (no doc is opened), do the same as above, it works
- Starting LO without open a document, do the same as above, it works

expected behavior:
- start editing the macros also with opened writer document as without
Comment 7 Joel Madero 2014-07-16 02:06:15 UTC
Can't be bibisected, does not affect Linux.

NoRepro:
Ubuntu 14.04
LibreOffice 4.3.0.1 rc
Comment 8 Yousuf Philips (jay) (retired) 2014-07-16 02:45:26 UTC
Created attachment 102883 [details]
basic windows has visual drawing problems

On linux, LibO wont crash from this issue, but i think the problem originates from the basic windows not being drawn properly. As can be seen in the attachment, icons from my main toolbar are being seen in the window and the toolbars arent being rendered correctly. this doesnt happen when i open any other macros.
Comment 9 Julien Nabet 2015-01-26 22:28:41 UTC
Jay: http://extensions.libreoffice.org/extension-center/copy-only-visible-cells indicates the extension (v1.1 version, not v1.0!) is compatible with LO 4.1 and LO 4.2
=> NOTOURBUG?
Comment 10 Yousuf Philips (jay) (retired) 2015-01-27 17:28:01 UTC
Julien: If i remember correctly from what i was told, if an extension can crash LibO, then its is OURBUG and if the extension doesnt work because its not compatible, that is NOTOURBUG.

As i stated in comment 4, LibO crashed simply by opening the Basic Macros dialog (Tools --> Macros --> organize macros --> LibreOfficeDev Basic) and me and Kevin stated that LibO would crash when trying to edit a macro. So IMHO, this is OURBUG.
Comment 11 Julien Nabet 2015-01-29 21:20:57 UTC
Thank you Jay for your feedback.
With master sources updated today, I retrieved the extension, installed it, restarted LO and could edit a macro.
Comment 12 Yousuf Philips (jay) (retired) 2015-01-30 06:51:25 UTC
Julien: You know this is a windows only bug right? :D
Comment 13 Julien Nabet 2015-01-30 06:57:56 UTC
Jay: you're right! :-) Sometimes I need to sleep a little more before doing some QA :-)
Comment 14 Michael Stahl (CIB) 2015-04-16 22:01:09 UTC
looking at the backtrace it's most likely a duplicate of bug 84887

please re-open if you can reproduce it with 4.3.7.1

*** This bug has been marked as a duplicate of bug 84887 ***
Comment 15 Robinson Tryon (qubit) 2015-12-17 10:57:03 UTC
Migrating Whiteboard tags to Keywords: (notBibisectable)
[NinjaEdit]