Download it now!
Bug 80264 - EDITING: Calc OLE object changes horizontal position with every size change
Summary: EDITING: Calc OLE object changes horizontal position with every size change
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: Other Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: OLE-Objects
  Show dependency treegraph
 
Reported: 2014-06-20 05:39 UTC by Bugcruncher
Modified: 2020-09-01 16:15 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample Document (56.98 KB, application/vnd.oasis.opendocument.graphics)
2014-06-20 05:39 UTC, Bugcruncher
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bugcruncher 2014-06-20 05:39:45 UTC
Created attachment 101405 [details]
Sample Document

Problem description: 
With any size change edit a Calc OLE object will change it's horizontal position. During my tests it mostly will be shifted to the left, but also to the right sometimes appears. Writer OLE objects are not affected.

Steps to reproduce:
1. open sample document, if necessary enable snap lines viewing
   in menu "View -> Snap Lines"
2. double click Calc document (Edit mode starts)
   The OLE object moves 1/2 object width to the left, but 
   that seems not to cause the problem:
3. Click somewhere outside the objects, and Calc OLE object
   will be shown at it's old place
4. double click Calc document to start Edit mode
5. drag and drop small black size control point in the middle 
   of the bottom border line of the OLE object 1/4 object
   hight down: 
   some empty rows become visible
6. Click somewhere outside the objects, 
   Bug: Calc OLE object will be shown at a completely different
        place, mostly 1/2 object width shifted to the left

10. Do tests again with Writer OLE object in document: problem
    does not appear

Not a problem with AOO 4.1.0
Operating System: Windows 7
Version: 4.2.4.2 release
Comment 1 Buovjaga 2014-11-01 16:02:45 UTC
Reproduced -> NEW.

Win 7 64-bit Version: 4.4.0.0.alpha1+
Build ID: 1baad070d8c2a38581cf33d803c5043f1974647f
TinderBox: Win-x86@39, Branch:master, Time: 2014-11-01_00:15:06
Comment 2 Buovjaga 2015-01-07 17:34:39 UTC
Lowered version number after reproducing with:

Ubuntu 14.10 64-bit
LibreOffice 3.5.0rc3 
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735
Comment 3 Buovjaga 2015-01-07 18:10:42 UTC
Could repro with 3.3 as well.

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 4 QA Administrators 2016-01-17 20:01:40 UTC Comment hidden (obsolete)
Comment 5 QA Administrators 2017-03-06 13:41:15 UTC Comment hidden (obsolete)
Comment 6 QA Administrators 2019-12-03 14:16:41 UTC Comment hidden (obsolete)
Comment 7 Thomas Lendo 2020-09-01 16:15:52 UTC
Cannot reproduce with
Version: 7.1.0.0.alpha0+ (x64)
Build ID: fb8334aa79e811bb6780e072e24d2580932f1031
CPU threads: 12; OS: Windows 10.0 Build 18363; UI render: Skia/Vulkan; VCL: win
Locale: de-AT (de_AT); UI: de-DE

Closing as WORKSFORME.