Bug 80336 - LibreOffice hangs on latex exportation
Summary: LibreOffice hangs on latex exportation
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: x86 (IA32) Linux (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-21 16:24 UTC by pjflucas
Modified: 2015-03-03 12:58 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
doc file that causes LibreOffice to hang on latex exportation (314.00 KB, application/msword)
2014-06-26 19:54 UTC, pjflucas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pjflucas 2014-06-21 16:24:35 UTC
I tried to use LibreOffice for translating (exporting) a docx file to latex. After presenting the menu where one can fill in details about the latex output,
LibreOffice starts the translation by showing a progress bar at the bottom, and finally hangs. It never produces any output and keeps running for ever. I tried this with several different docx files and the result was always the same.
Comment 1 Firas Hanife 2014-06-25 22:27:59 UTC
Hi pjflucas,
thanks for the report.

To tackle the issue it is needed to have a document to test with and reproduce your issue. So, if you have one, please upload it in this report.

Changing Status to NEEDINFO.
Comment 2 pjflucas 2014-06-26 19:54:47 UTC
Created attachment 101827 [details]
doc file that causes LibreOffice to hang on latex exportation

LibreOffice hangs on translating this word document to latex, but in
my case I tried several other doc files and also docx and it always
hangs. (Reading in the doc or docx file is without any problem.)
Comment 3 Yousuf Philips (jay) (retired) 2014-06-29 03:25:01 UTC
Hello pjflucas,

No my knowledge, LibreOffice doesnt have a latex export option, so how are you doing this exporting.
Comment 4 pjflucas 2014-06-29 16:47:06 UTC
libreoffice to latex translation is an extension of LibreOffice and part of the fc20 package libreoffice-writer2latex-1.0.2-11.fc20. I used it successfully with
OpenOffice on an earlier version of fedora. Given the very high quality of latex
document processing, it is a very useful package.

Peter
Comment 5 Yousuf Philips (jay) (retired) 2014-06-29 18:45:00 UTC
Hi Peter,

Unfortunately, we do not provide support for third party extensions. I would suggest you contact the extension author, as the extension hasnt been updated in more than 2 years, or use an older version of LibreOffice where the extension does work.
Comment 6 pjflucas 2014-06-30 17:32:16 UTC
I figured out that it is the java interface between LibreOffice and writer2latex
that causes the problem. I use the one that comes packaged with fedora 20, i.e.,
libreoffice-writer2latex-1.0.2-11.fc20. This seems to be different from the
one available on the LibreOffice website, but the latter is working.

Peter
Comment 7 Yousuf Philips (jay) (retired) 2014-06-30 18:05:45 UTC
Glad you were able to solve the issue. :)