Bug 80404 - PRINTING: Unable to print documents to Brother printer on Mac
Summary: PRINTING: Unable to print documents to Brother printer on Mac
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.2.1.1 release
Hardware: Other macOS (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 80406 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-06-23 14:26 UTC by Stephen J. Lemmons
Modified: 2015-04-01 14:52 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stephen J. Lemmons 2014-06-23 14:26:44 UTC
My computer is a MAC-PRO (black pipe computer) with the Maverick OS.  The printer problems are with a Brother HL-3170CDW.   Documents from other programs and PC's print fine.   The only program printing problem is with LibreOffice  4.2.1.1.    Documents printed using LibreOffice print command do not print.  I've spent 2 1/2 days tracking this down testing every possibility I could think of.   I can print the document from Apple's Preview module just fine.  When I go into LibreOffice the same document will not print.  

    Steve
Comment 1 Firas Hanife 2014-06-23 15:13:18 UTC
Hi Steve,
thanks for the report.

I highly recommend you to update your LibreOffice version to the latest 4.2.5.2 release and try to reproduce this issue again.
Comment 2 Kevin Suo 2014-06-23 15:33:03 UTC
*** Bug 80406 has been marked as a duplicate of this bug. ***
Comment 3 Stephen J. Lemmons 2014-06-23 15:51:51 UTC
Dear Sir;
 
      I have downloaded 4.2.5.2 and installed it.   I reran the tests and went even further.   What I found was this.  Libre will print documents in its own file extension odt and doc.  The problem comes with printing pdf.  It will open the pdf file, but WILL NOT print them.   It sends them to the printer.  Once the entire file has been sent to the printer the file is then dumped.  Why?  If it opens the file and sends it to the printer I would think they should print, but they don't.
 
      Steve
 
-----Original Message-----
From: bugzilla-daemon@freedesktop.org
Sent: Monday, 23 June, 2014 10:13
To: sjlemmons@1791.com
Subject: [Bug 80404] Printing Documents



 
[ Comment # 1 ]( https://bugs.freedesktop.org/show_bug.cgi?id=80404#c1 ) on [ bug 80404 ]( https://bugs.freedesktop.org/show_bug.cgi?id=80404 ) from [  Firas Hanife ]( mailto:FirasHanife@gmail.com ) 
Hi Steve,thanks for the report.I highly recommend you to update your LibreOffice version to the latest 4.2.5.2release and try to reproduce this issue again.You are receiving this mail because:
You reported the bug.
Comment 4 tommy27 2014-06-23 15:56:01 UTC
I add Bug 80223 to "see also" which incidentally it's about a Brother printer again, but on Windows and on different LibO release.

maybe some driver issues with Brother printers?
did older LibO releases print with the same printer?
Comment 5 tommy27 2014-06-24 04:50:39 UTC
(In reply to comment #3)
> ... Libre will print documents in its own file extension odt and doc.  

Ok. was the 4.2.1.1 release able to print odt and doc?

> The problem comes with printing pdf. 
> It will open the pdf file, but WILL NOT print them.   It sends them to the
> printer.  Once the entire file has been sent to the printer the file is then
> dumped.  
> ...

please define exactly what you mean with "printing PDF"...

are you importing a PDF in LibO Draw then tryng to print it or you export a LibO file to PDF and try to print it from a PDF reader software?

do you have a test PDF file that you cannot print and that you can upload here?


P.S. please do not use your mailer to reply but rather post your comments in Bugzilla page at this link: https://bugs.freedesktop.org/show_bug.cgi?id=80404
Comment 6 tommy27 2014-06-25 20:28:05 UTC
what about the connection of the printer? USB, LAN or Wi-Fi?
Comment 7 tommy27 2014-07-17 19:37:17 UTC
I set status to NEEDINFO waiting for answers to questions in comment 5 and comment 6
Comment 8 QA Administrators 2015-02-19 04:44:24 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team

Message generated on: 2015-02-18
Comment 9 QA Administrators 2015-04-01 14:52:41 UTC
Dear Bug Submitter,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INVALID due to inactivity and
a lack of information which is needed in order to accurately
reproduce and confirm the problem. We encourage you to retest
your bug against the latest release. If the issue is still
present in the latest stable release, we need the following
information (please ignore any that you've already provided):

a) Provide details of your system including your operating
   system and the latest version of LibreOffice that you have
   confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED
and we will attempt to reproduce the issue. Please do not:

a) respond via email 

b) update the version field in the bug or any of the other details
   on the top section of our bug tracker

-- The LibreOffice QA Team This NEEDINFO Message was generated on: 2015-04-01

Warm Regards,
QA Team