Bug 80552 - EDITING: Writer freezes when deleting words from DOC
Summary: EDITING: Writer freezes when deleting words from DOC
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: high critical
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: bibisectRequest
Depends on:
Blocks:
 
Reported: 2014-06-26 09:15 UTC by Rostislav
Modified: 2016-11-09 05:20 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Document causing the problem, screenshot illustrating how to reproduce it (2.78 MB, application/zip)
2014-06-26 09:15 UTC, Rostislav
Details
minimal test document (407.78 KB, application/vnd.oasis.opendocument.text)
2015-07-25 16:52 UTC, Gordo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rostislav 2014-06-26 09:15:41 UTC
Created attachment 101791 [details]
Document causing the problem, screenshot illustrating how to reproduce it

Problem description: 
Writer freezes when trying to delete few words

Steps to reproduce:
1. Open the doc
2. Select few words as shown in the screenshot
3. press delete

Current behavior:
Freezes

Expected behavior:
Works
              
Operating System: Ubuntu
Version: 4.2.3.3 release
Comment 1 Yousuf Philips (jay) (retired) 2014-06-29 01:25:11 UTC
Hi Rostislav,

I was able to delete 5 pages out of provided document without any problems on 4.2.5 and 4.3.0 on Linux Mint as well as 4.2.3 on Ubuntu 14.04 (which i'm assuming you have). I believe the issue maybe caused by something else, but encourage you to do a system update, as LibreOffice 4.2.4 will be available to you.

If it still persists, try clearing your user profile by follow the instructions at the following link < http://ask.libreoffice.org/en/question/903/where-are-the-libreoffice-data-profile-files/ >. Alternatively, if your running an AMD or Nvidia graphics card, attempt to use a different driver. Instructions on how to do so can be found at < http://askubuntu.com/questions/47506/how-do-i-install-additional-drivers >. Please let us know if this solves your issue.
Comment 2 Rostislav 2014-06-29 08:09:32 UTC
Hi Jay,

Thanks for the reply.
I was able to reproduce the bug also in LibreOffice 3.5.4 
(SMP Debian 3.2.57-3+deb7u2 x86_64). 
Note, that the problem happens in a specific place in 
the document -- at line 151 shown in the screenshot.
Did you try that?

It is no problem to delete 5 pages elsewere....

BR,
Rostislav
Comment 3 Yousuf Philips (jay) (retired) 2014-06-30 00:00:47 UTC
Hi Rostislav,

Thanks for that. Yes it froze for me on 3.3.0, 4.2.5, and master on Linux Mint when selecting ", расположенного на ." on line 151 and pressing delete. I let master run for 5 minutes before killing it, assuming it might stop. It also froze on Windows 7 with master.
Comment 4 m.a.riosv 2014-06-30 01:09:50 UTC
I think it is in relation the "Times New Roman Font" and a direct format applied, changed to other font the issue seems solved for me.

There is a font format over the paragraph format.

Maybe the file was not created with LibreOffice in first instance and weird stuffs remains in the file.

If a character style is applied to the all paragraph text the perhaps would better only use a paragraph style modified properly, this can simplified document maintenance.
Comment 5 Jean-Baptiste Faure 2014-06-30 05:09:50 UTC
(In reply to comment #4)
> [...]
> Maybe the file was not created with LibreOffice in first instance and weird
> stuffs remains in the file.

The numbering styles WW8Num1 to WW8Num4 show that this document was created under MS-Word in .doc or .docx format and converted in .odt


Best regards. JBF
Comment 6 tommy27 2014-07-24 01:08:56 UTC
I remove bug from mab4.3 list since it's not 4.3.x specific and affects earlier versions as well.

If it's still considered a MAB it should go into the mab4.2 list
Comment 7 Björn Michaelsen 2014-08-21 12:21:16 UTC Comment hidden (obsolete)
Comment 8 Gordo 2015-07-25 16:52:25 UTC
Created attachment 117434 [details]
minimal test document

By deleting ", расположенного на ", the text below shifts upward bringing with it the table that is split over two pages.  The freeze also happens when placing the cursor in the empty paragraphs before the table and pressing Delete.  They have the paragraph style "Table Contents".

The paragraph style "BodyL." has line spacing of 1.5.  The paragraph has single line spacing applied as direct formatting.

The text is justified.

For the two empty paragraphs, if they are changed to "Default Style" or line spacing of 1.5 ("Default Style" has been modified to 1.5 anyway) then deleting them no longer becomes a problem.

I have created a minimal document from the original.  There is no formatting of line spacing.  It is a table split over two pages with an image anchored as character in one cell and justified text in the other cell.  Trying to delete an empty paragraph before the table results in a freeze.

Windows Vista 64
Version: 4.4.4.3
Build ID: 2c39ebcf046445232b798108aa8a7e7d89552ea8
Comment 9 Robinson Tryon (qubit) 2015-10-07 22:13:05 UTC
Dropping Severity -> critical (we've deprecated the 'blocker' value)
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Severity#Severity_Levels
Comment 10 QA Administrators 2016-11-08 11:07:41 UTC Comment hidden (obsolete)
Comment 11 tommy27 2016-11-09 05:20:39 UTC
tested under Win 8.1 x64

bug is still present in LibO 5.3.2.3 but is gone in 5.3.0.0.alpha1+
Build ID: 32bdc5097013e7efd9c85e1b8df697880e66e925
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; Layout Engine: new; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-11-04_23:30:30
Locale: it-IT (it_IT); Calc: group

hence, RESOLVED WORKSFORME in the 5.3.x branch

a bibisect could be attempted to identify the fixing committ and see if that's can be backported to 5.2.x as well