Bug 80605 - TABLE borders grey when exported to PDF
Summary: TABLE borders grey when exported to PDF
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-27 16:45 UTC by Milan Bouchet-Valat
Modified: 2015-01-21 10:31 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Document showing the problem (13.78 KB, application/vnd.oasis.opendocument.text)
2014-06-27 16:45 UTC, Milan Bouchet-Valat
Details
PDF of the document, bug visible in Adobe Reader (21.34 KB, application/download)
2014-06-27 16:45 UTC, Milan Bouchet-Valat
Details
Screenshot of problem in Adobe Reader (1) (3.65 KB, image/png)
2014-06-27 16:45 UTC, Milan Bouchet-Valat
Details
Screenshot of problem in Adobe Reader (2) (5.40 KB, image/png)
2014-06-27 16:46 UTC, Milan Bouchet-Valat
Details
Correct JPEG export of the document (16.13 KB, image/jpeg)
2014-06-27 16:46 UTC, Milan Bouchet-Valat
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Milan Bouchet-Valat 2014-06-27 16:45:06 UTC
Created attachment 101881 [details]
Document showing the problem

The table in the attached ODT file does not look correct when exported to PDF and viewed in Adobe Reader (see screenshots). More precisely, some borders that appear black and are configured to be black in Writer are grey in the PDF.

When exporting to JPEG, borders are correct, so this looks like a PDF export bug. Interestingly, the problem is not visible when reading the PDF in Evince or Okular. Removing and reenabling black borders does not make any difference.

(This is on Fedora 20.)
Comment 1 Milan Bouchet-Valat 2014-06-27 16:45:35 UTC
Created attachment 101882 [details]
PDF of the document, bug visible in Adobe Reader
Comment 2 Milan Bouchet-Valat 2014-06-27 16:45:58 UTC
Created attachment 101883 [details]
Screenshot of problem in Adobe Reader (1)
Comment 3 Milan Bouchet-Valat 2014-06-27 16:46:11 UTC
Created attachment 101884 [details]
Screenshot of problem in Adobe Reader (2)
Comment 4 Milan Bouchet-Valat 2014-06-27 16:46:39 UTC
Created attachment 101885 [details]
Correct JPEG export of the document
Comment 5 penttila 2014-07-31 17:49:09 UTC
I can confirm that the borders became also gray in my pdf export. (The export was done by 'Export to PDF' and with its default settings.)
On the other hand my .pdf viewer Evince displayed clearly the gray borders!

My test system:
LinuxMint 17 Cinnamon
LibreOffice 4.2.4.2
Evince 3.10.3
Comment 6 Matthew Francis 2015-01-21 08:39:36 UTC
OSX Preview also has no issue with the attached PDF.

This seems to be a rendering bug in Adobe products. Scrolling around the document at different zoom levels in Adobe Reader shows that the rendering of the border is inconsistent when different parts of it scroll in and out of view.

Setting Status -> RESOLVED NOTOURBUG
Comment 7 Milan Bouchet-Valat 2015-01-21 10:25:15 UTC
Wow, I didn't think there were so serious bugs in Adobe Reader.
Comment 8 Milan Bouchet-Valat 2015-01-21 10:31:42 UTC
(In reply to Matthew Francis from comment #6)
> This seems to be a rendering bug in Adobe products. Scrolling around the
> document at different zoom levels in Adobe Reader shows that the rendering
> of the border is inconsistent when different parts of it scroll in and out
> of view.
I don't see any inconsistency here. Depending on the zoom level, the border is grey or black but thinner, but the change always happens exactly at the same place, so everything seems consistent. (That doesn't mean it's not a bug, though.)

I'd be more confident it's not a LO bug if a PDF expert would look at the exported file...