Download it now!
Bug 80636 - FILEOPEN: Online image downloaded but not presented
Summary: FILEOPEN: Online image downloaded but not presented
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86 (IA32) All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Images
  Show dependency treegraph
 
Reported: 2014-06-28 15:45 UTC by oc-spam65
Modified: 2018-05-28 12:25 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Minimal example (image fails to appear) (13.17 KB, application/vnd.oasis.opendocument.text)
2014-06-28 15:45 UTC, oc-spam65
Details
shows the picture dialog with the image in it (128.31 KB, image/png)
2014-06-29 02:29 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description oc-spam65 2014-06-28 15:45:27 UTC
Created attachment 101928 [details]
Minimal example (image fails to appear)

Hello,

In the attached minimal example, there is an image implemented as a hyperlink to http://www.powerguru.org/wordpress/wp-content/uploads/2014/01/Magnetic-circuit-current-sensor.jpg

I expect that the image should be downloaded and displayed, but downloading seems to fail. This is strange because the following command is able to download the image successfully:

$ wget --user-agent="LibreOffice" http://www.powerguru.org/wordpress/wp-content/uploads/2014/01/Magnetic-circuit-current-sensor.jpg

Could you please correct LibreOffice so that it is able to download images from the site mentioned above?

Thank you,

Olivier
Comment 1 oc-spam65 2014-06-28 20:39:50 UTC
More information: 
The original document for the minimal example is coming from the web page http://www.powerguru.org/closed-loop-sensor-with-flux-gate-technology/
A workaround for saving the text and images in an ODT document is the following:
1) With Firefox: save the web page to disk, load the page from disk, select the desired text and images, copy with CTRL-C 
2) Paste to LibreOffice with CTRL-V
Comment 2 Yousuf Philips (jay) (retired) 2014-06-29 02:27:08 UTC
Hello oc-spam65,

I didnt have any problem downloading the image with the wget example. There was another issue that is causing the image not to appear.

Confirmed in Linux Mint in 3.3.0, 4.2.5 and 4.3.0. Also confirmed in Windows 7 on 4.2.4. The image is downloaded from online, as can be seen in the picture dialog box, but isnt rendered in the document.
Comment 3 Yousuf Philips (jay) (retired) 2014-06-29 02:29:42 UTC
Created attachment 101954 [details]
shows the picture dialog with the image in it
Comment 4 oc-spam65 2014-06-29 11:05:28 UTC
Thank you, I had not noticed what you pointed. Indeed, LibreOffice seems to have received the image but does not show it in the document. Also, it displays "Read-Error" if I do "Edit > Links... > Break Link".
Comment 5 Jacques Guilleron 2014-08-06 16:02:07 UTC
Hello oc-spam65,

In your document, try:

Menu Edit > Select All
Menu Edit > Links
In this window, select all the links(clic on the first, Maj + clic on the last)
Select Break Link
Close the window.
All images are now displayed.

The difference with your way is only to first select all the document. This works with all the web page you gave the link.
Does it work for you?

Jacques
Comment 6 oc-spam65 2014-08-06 20:24:22 UTC
No, what you said gave the same as I reported above: "Read-Error"
Checked with LibreOffice version 4.2.5.2 on Debian Linux 64 bits
Comment 7 Jacques Guilleron 2014-08-06 22:37:59 UTC
OK. My os is Windows 7 Home Premium. 

In Tools > Options > LibreOffice Writer > View
In Display > Graphics and objects. 
Be sure this is checked, else you have the file name instead of image.

Regards,

Jacques
Comment 8 oc-spam65 2014-08-06 23:17:48 UTC
I do have "Graphics and objects" activated. As mentioned above, the image is imported correctly if it points to a hard disk file, but not imported correctly if it points to a network URL.
Comment 9 David 2014-08-25 18:48:21 UTC
I tried downloading three times but unable to open 4.3.2, I didn't have any problems opening 4.2
Comment 10 QA Administrators 2015-09-04 02:48:22 UTC Comment hidden (obsolete)
Comment 11 Buovjaga 2015-11-19 08:55:37 UTC
Still not rendered. Display > Graphics and objects is enabled.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 66d2b72667792cb18b25805387824d636e2a455c
TinderBox: Win-x86@39, Branch:master, Time: 2015-11-18_02:35:53
Locale: fi-FI (fi_FI)
Comment 12 oc-spam65 2017-05-25 21:01:03 UTC
Still not rendered
Version: 5.2.7.2
Build ID: 1:5.2.7-1
Comment 13 QA Administrators 2018-05-26 02:41:44 UTC Comment hidden (obsolete)
Comment 14 oc-spam65 2018-05-28 12:25:04 UTC
Image in the minimal example is now rendered.
Version: 6.0.4.1
OS: Linux 4.14