Download it now!
Bug 80736 - "Format Example" not showing up on second time field row for decimal is selected.
Summary: "Format Example" not showing up on second time field row for decimal is selec...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-01 01:54 UTC by Jeff Martin
Modified: 2015-12-09 07:25 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Book list database (21.99 KB, application/vnd.oasis.opendocument.database)
2014-07-01 01:54 UTC, Jeff Martin
Details
default field formats (input masks) on libre base are missing (289.56 KB, image/jpeg)
2015-05-30 15:40 UTC, ELSUPREMO1
Details
field formats (input masks) on libre base are missing on [varchar] (273.49 KB, image/jpeg)
2015-05-30 16:10 UTC, ELSUPREMO1
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeff Martin 2014-07-01 01:54:23 UTC
Created attachment 102038 [details]
Book list database

I right click on the table and select edit which opens the table design.
I have some fields for putting in currency with two decimal places.
The first row I select will show an option for "format example," but if I select another decimal row it will not have that option. I have to exit the window and start over to see what the other rows are set to.
Comment 1 ign_christian 2014-07-01 16:34:13 UTC
Not reproducible in LO 4.2.5.2 - Ubuntu 12.04 x86. 
I can see "Format example" option in all fields with decimal field type, no need to exit & reopen the window.

Jeff, in what LO version you see the problem? Please set that in version field.
Comment 2 Dominik 2014-07-05 07:12:01 UTC
i can't confirm on LO 4.3.0.2 on Win 7.

Does this still occur for you?
Comment 3 Alex Thurgood 2015-01-03 17:41:20 UTC
Adding self to CC if not already on
Comment 4 ELSUPREMO1 2015-05-30 15:40:11 UTC
Created attachment 116178 [details]
default field formats (input masks) on libre base are missing

Hi,

The field formats (input masks) on libre base are missing. Recommend adding some of the common default inut masks in addition to keeping the option available for users to buld thier own input masks.
Comment 5 ELSUPREMO1 2015-05-30 16:06:29 UTC
Comment on attachment 116178 [details]
default field formats (input masks) on libre base are missing

Additional notes:

I just noticed that this is only missing for text "field types" (i.e. [VARCHAR], [LONGVAR CHAR] or other). All other field types work perfectly. 

This is confusing to normal users especially when there is already an category for "text." This feature should be active on all text "field types".
Comment 6 ELSUPREMO1 2015-05-30 16:10:07 UTC
Created attachment 116180 [details]
field formats (input masks) on libre base are missing on [varchar]

UPDATE: default field formats (input masks) on libre base are missing on [varchar]

Additional notes:

I just noticed that this is only missing for text "field types" (i.e. [VARCHAR], [LONGVAR CHAR] or other). All other field types work perfectly. 

This is confusing to normal users especially when there is already an category for "text." This feature should be active on all text "field types".
Comment 7 Robert Großkopf 2015-05-30 20:00:12 UTC
Reply to comment 4-6:
This isn't the bug, that is reported by the bugsubmitter. If you wish other formats for a varchar-field you could add a bug for a feature request. Please describe exactly what you are missing...

The reported bug describes there missing of format-example when changing from one numeric field to another. This bug has never been confirmed. So I set this bug to unconfirmed.
Comment 8 Alex Thurgood 2015-06-04 14:30:25 UTC
Not reproducible on

Version: 4.4.3.2
Build ID: 88805f81e9fe61362df02b9941de8e38a9b5fd16
Locale : fr_

OSX 10.10.3

@Jeff: this was originally reported against 4252. Please test again with a latest production release and report back here, as the problem doesn't seem to affect anyone else.

Setting to NEEDINFO pending requested information. Please set back to UNCONFIRMED if you are still experiencing the problem.
Comment 9 Robert Großkopf 2015-12-05 16:53:12 UTC
Asked for information since 6 months. The bug has never been confirmed by any other person except bugsubmitter.

Should we set this one as worksforme? There won't be any bugfix for LO 4.2 any more ...
Comment 10 Jeff Martin 2015-12-05 19:58:29 UTC
I had forgotten about this one. It's working now with version 5.0.3.2 Either I saw the field wrong or it got fixed. Probably the former.
Comment 11 Alex Thurgood 2015-12-09 07:25:19 UTC
If we can't identify the specific patch then we set it as worksforme