Bug 80739 - FILESAVE: Color filling of symbol changed
Summary: FILESAVE: Color filling of symbol changed
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.0.beta1
Hardware: Other Linux (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2014-07-01 02:54 UTC by Ryszard
Modified: 2015-12-17 08:24 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
file saved in openoffice and previous version of libreoffice (45.60 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-07-01 02:54 UTC, Ryszard
Details
Saved & Reopened in 4.2.5.2 (97.05 KB, image/png)
2014-07-01 03:53 UTC, ign_christian
Details
files created base on template (215.94 KB, application/zip)
2014-07-02 17:38 UTC, Ryszard
Details
printscreen from 4.4 (251.43 KB, application/pdf)
2014-08-20 06:33 UTC, raal
Details
Color is presreved (216.23 KB, image/png)
2015-04-20 12:52 UTC, Yogesh Bharate
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ryszard 2014-07-01 02:54:20 UTC
Created attachment 102040 [details]
file saved in openoffice and previous version of libreoffice

Problem description: After saving old file using new version libreoffice. Symbols previously created are changing fill option, some parts of grouped symbols are gone.

Steps to reproduce:
1. open attached file in new libreoffice version
2. save file
3. open saved file

Current behavior: symbols in file are changing appearance 

Expected behavior: file should look same after saving

              
Operating System: Linux (Other)
Version: 4.2.5.2 release
Last worked in: 4.2.4.2 release
Comment 1 ign_christian 2014-07-01 03:53:17 UTC
Created attachment 102043 [details]
Saved & Reopened in 4.2.5.2

Reproduced with LO 4.2.5.2 and 4.2.0.0.beta1 - Ubuntu 12.04 x86

Not reproduced with LO 4.1.6.2
Comment 2 ign_christian 2014-07-01 03:56:34 UTC
It's surprising that problem can be reproduced with 4.2.0.0.beta1 and 4.2.5.2, but reporter said no reproducible in 4.2.4.2.
Comment 3 ign_christian 2014-07-01 04:48:03 UTC
@Ryszard, what kind of character / font is that?
Comment 4 Ryszard 2014-07-01 12:55:01 UTC
It looks like I was wrong about last working version.
What actually triggered my investigation was the way 4.2.5.2 opened this file (it is my template). I couldn't attached the original file because it was overwritten. When I opened the original template using new LO version, somehow three symbols - 2 from cell V11 (with .002 and letter A) and one from cell Z11 (surface mark looks like check mark) were moved to the left upper corner to same location where "PART NAME" (cells AB33) is. So I moved them back and saved the file. At that moment I have noticed the difference.
Comment 5 ign_christian 2014-07-01 14:14:58 UTC
It's hard to triage the problem with that information.

Could you please provide simple test case with step by step procedure to see that problem?

Anyway..only one problem / bug per report. If there are two problems, so should be two reports.
Comment 6 Ryszard 2014-07-02 15:15:26 UTC
I'm reporting only one bug, even if I saw more problems that I did not mentioned, but since the original file was overwritten I can not show you the problem, my previous comment only explained why I have incorrectly specify last version that was working. As far as changing properties of created graphic symbols on save, there is a attached file and you have reproduced it.
Comment 7 ign_christian 2014-07-02 16:45:25 UTC
So this report is only about changing of symbol color filling since we can only see that part.

I found something interesting: if we select the symbols in 'Sheet1_2', after saving & reopening file, some blue colored symbol shows "Sky Blue" color fill and the others none. Looks like LO doesn't interpret symbol color fill properly.

But I don't know whether that information is enough since attached file isn't original file, unless we have clear steps to reproduce from scratch.

Set back to UNCONFIRMED
Comment 8 Ryszard 2014-07-02 17:38:20 UTC
Created attachment 102150 [details]
files created base on template

I'm sending files that were based on original template, so when you open them you may also see that some objects somehow are moving to left upper corner of the page.
As far as changing background color of the symbols after saving file using 4.2.5.2 version, that's not all, if you will look closer you may see that some elements of few symbols are disappearing.
Comment 9 raal 2014-08-20 06:33:49 UTC
Created attachment 104937 [details]
printscreen from 4.4

I can reproduce with Version: 4.4.0.0.alpha0+
Build ID: e379401618268ed7f7f5885a36b90e1f4f6cd4af
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-08-18_05:51:03

After save - background color of symbols is changed. Symbols are grouped drawing objects.
Comment 10 Matthew Francis 2014-12-06 13:21:20 UTC
Results from bibisect-43all:

There are only 'skip'ped commits left to test.
The first bad commit could be any of:
a66b45cf70625c9b4c0eb867530485b1319e2adb
4360256bc0b1443028a057164fbbdb43847ce68d
We cannot bisect more!

# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# good: [e02439a3d6297a1f5334fa558ddec5ef4212c574] source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb
git bisect good e02439a3d6297a1f5334fa558ddec5ef4212c574
# bad: [4850941efe43ae800be5c76e1102ab80ac2c085d] source-hash-980a6e552502f02f12c15bfb1c9f8e6269499f4b
git bisect bad 4850941efe43ae800be5c76e1102ab80ac2c085d
# skip: [a043626b542eb8314218d7439534dce2fc325304] source-hash-9379a922c07df3cdb7d567cc88dfaaa39ead3681
git bisect skip a043626b542eb8314218d7439534dce2fc325304
# skip: [aba65c3e4c0df07e4909aeefb758cdb688242bf6] source-hash-827524abfb4b577d08276fde40929a9adfb7ff1a
git bisect skip aba65c3e4c0df07e4909aeefb758cdb688242bf6
# skip: [aba65c3e4c0df07e4909aeefb758cdb688242bf6] source-hash-827524abfb4b577d08276fde40929a9adfb7ff1a
git bisect skip aba65c3e4c0df07e4909aeefb758cdb688242bf6
# bad: [c81a8a0dcfc1ed095a80e4485c89dd0fcaf73f31] source-hash-c69ed33628ec0b7abf6296539cf280d6c4265930
git bisect bad c81a8a0dcfc1ed095a80e4485c89dd0fcaf73f31
# bad: [c81a8a0dcfc1ed095a80e4485c89dd0fcaf73f31] source-hash-c69ed33628ec0b7abf6296539cf280d6c4265930
git bisect bad c81a8a0dcfc1ed095a80e4485c89dd0fcaf73f31
# good: [1d4980621741d3050a5fe61b247c157d769988f2] source-hash-89d01a7d8028ddb765e02c116d202a2435894217
git bisect good 1d4980621741d3050a5fe61b247c157d769988f2
# skip: [89110ca258fa7a15dfc546acfb39e76fc3eb2a44] source-hash-e450a2c506ac7cd4433b0f93fc750a89919bc03c
git bisect skip 89110ca258fa7a15dfc546acfb39e76fc3eb2a44
# good: [1cca92a409385d9288c28a54d5e3008e56728bc0] source-hash-7be7824bbbdeee6fa998b950e6046ab37fe690cb
git bisect good 1cca92a409385d9288c28a54d5e3008e56728bc0
# skip: [5fa28ce2931a35ae64ae08d3904cfb76d24459d8] source-hash-2304beaca33c63b94df99cb827716f00ce259f9a
git bisect skip 5fa28ce2931a35ae64ae08d3904cfb76d24459d8
# good: [2a9ff869c5638dc5c3aa387d0fe55c3291c86288] source-hash-01b7e04172889cbc9e4ac404b105e18ddc062d6f
git bisect good 2a9ff869c5638dc5c3aa387d0fe55c3291c86288
# good: [387dd1052972d27a3065a249b357e50e0a29829b] source-hash-35836f350861b33a0c28307a413eff76d0433d1e
git bisect good 387dd1052972d27a3065a249b357e50e0a29829b
# good: [387dd1052972d27a3065a249b357e50e0a29829b] source-hash-35836f350861b33a0c28307a413eff76d0433d1e
git bisect good 387dd1052972d27a3065a249b357e50e0a29829b
# bad: [09fe6d4400fefeaa099d0deb9b77c77992ab897b] source-hash-56364430108893afbcf5d2b51c5aaa37e393e7cc
git bisect bad 09fe6d4400fefeaa099d0deb9b77c77992ab897b
# bad: [09fe6d4400fefeaa099d0deb9b77c77992ab897b] source-hash-56364430108893afbcf5d2b51c5aaa37e393e7cc
git bisect bad 09fe6d4400fefeaa099d0deb9b77c77992ab897b
# good: [5c95a5c8caeeb347ef97f337a237d66c35261710] source-hash-a6d89e17995987549db36695f3ea490a18f30ba4
git bisect good 5c95a5c8caeeb347ef97f337a237d66c35261710
# good: [5c95a5c8caeeb347ef97f337a237d66c35261710] source-hash-a6d89e17995987549db36695f3ea490a18f30ba4
git bisect good 5c95a5c8caeeb347ef97f337a237d66c35261710
# bad: [4360256bc0b1443028a057164fbbdb43847ce68d] source-hash-40543e5321c8f618c125fd6f7f9a24b87431277a
git bisect bad 4360256bc0b1443028a057164fbbdb43847ce68d
# bad: [4360256bc0b1443028a057164fbbdb43847ce68d] source-hash-40543e5321c8f618c125fd6f7f9a24b87431277a
git bisect bad 4360256bc0b1443028a057164fbbdb43847ce68d
# skip: [a66b45cf70625c9b4c0eb867530485b1319e2adb] source-hash-660800d6f33a01ad53fc0f5717e1c33868440d2f
git bisect skip a66b45cf70625c9b4c0eb867530485b1319e2adb
# only skipped commits left to test
# possible first bad commit: [4360256bc0b1443028a057164fbbdb43847ce68d] source-hash-40543e5321c8f618c125fd6f7f9a24b87431277a
# possible first bad commit: [a66b45cf70625c9b4c0eb867530485b1319e2adb] source-hash-660800d6f33a01ad53fc0f5717e1c33868440d2f
Comment 11 Matthew Francis 2015-01-05 08:40:04 UTC
The behaviour seems to have changed as of the below commit.

Adding Cc: to caolanm@redhat.com. Any chance you could take a look at this? Thanks

commit 223f6b631c1b087754c0f9051fb55f029f2503ce
Author:     Armin Le Grand <alg@apache.org>
AuthorDate: Tue Oct 29 14:11:45 2013 +0000
Commit:     Caolán McNamara <caolanm@redhat.com>
CommitDate: Thu Oct 31 15:56:14 2013 +0000

    Resolves: #i123433# Detect pseudo-vertices at svg import...
    
    unify svg:d handling, correct svg:d import for relative sub-polygons in svg
    import; changed default for moveto writes for svg:d in ODF to absolute
    
    (cherry picked from commit f15874d8f976f3874bdbcb53429eeefa65c28841)
Comment 12 Yogesh Bharate 2015-04-20 12:52:01 UTC
1. When we open the attached ods file in Libreoffice, symbols color is white, this rendering issue.
2. When we open roundtripped file in LibreOffice symbols color is same.
[PFA - Color is presreved for more details ]
3. This is fixed in latest ubuntu build.

Build ID:
Version: 5.0.0.0.alpha1+
Build ID: d68cf40b7a16e20e99c15d310b24c91c2ca89ef6
Locale: en_IN
Comment 13 Yogesh Bharate 2015-04-20 12:52:34 UTC
Created attachment 114957 [details]
Color is presreved
Comment 14 Robinson Tryon (qubit) 2015-12-17 08:24:48 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]