Bug 80863 - Poor rendering of UTF8 Tamil fonts in body and UI
Summary: Poor rendering of UTF8 Tamil fonts in body and UI
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.3.0.2 rc
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-03 18:04 UTC by Ve. Elanjelian
Modified: 2015-04-05 00:13 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
The instances are highlighted with a red boxes. (644.40 KB, image/png)
2014-07-03 18:04 UTC, Ve. Elanjelian
Details
Screenshots of Tamil font rendering under GNU/Linux x86_64 LOv4303 (262.53 KB, application/zip)
2014-07-22 04:42 UTC, Owen Genat (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ve. Elanjelian 2014-07-03 18:04:02 UTC
Created attachment 102209 [details]
The instances are highlighted with a red boxes.

LibO often doesn't render Tamil fonts correctly. Spacing between characters is not well handled. And, if long words and sentences are typed, the cursor moves away from from the proper position, making typing difficult.

In the case of UI, unnecessary gaps are noticed within a word, or between an English and a Tamil word.

To test, you may use the Typing application available here: http://thamizha.org/ The images of these instances are also attached for reference.
Comment 1 Owen Genat (retired) 2014-07-22 04:42:04 UTC
Created attachment 103251 [details]
Screenshots of Tamil font rendering under GNU/Linux x86_64 LOv4303

(In reply to comment #0)
> To test, you may use the Typing application available here:
> http://thamizha.org/ 

The only font I could download that was linked under "Thamizha CD v2.0" was lohit-tamil.ttf from the Fedora Project. If you are experiencing these problems using a particular font, please indicate both the font name and where the font can be downloaded from.

Attached screenshots taken under GNU/Linux x86_64 using v4.3.0.3 Build ID: 08ebe52789a201dd7d38ef653ef7a48925e7f9f7 with the Tamil (ta) language pack installed and the UI set to Tamil. I could not reproduce the indicated problems.
Comment 2 Owen Genat (retired) 2014-07-22 04:43:29 UTC
As per comment 1 status set to NEEDINFO. Once the requested font information is provided, please set status back to UNCONFIRMED. Thanks. This may require a l10n team member / expert to assess further. It may also be a Window-specific issue.
Comment 3 QA Administrators 2015-02-19 04:42:38 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team

Message generated on: 2015-02-18
Comment 4 QA Administrators 2015-04-01 14:52:26 UTC
Dear Bug Submitter,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INVALID due to inactivity and
a lack of information which is needed in order to accurately
reproduce and confirm the problem. We encourage you to retest
your bug against the latest release. If the issue is still
present in the latest stable release, we need the following
information (please ignore any that you've already provided):

a) Provide details of your system including your operating
   system and the latest version of LibreOffice that you have
   confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED
and we will attempt to reproduce the issue. Please do not:

a) respond via email 

b) update the version field in the bug or any of the other details
   on the top section of our bug tracker

-- The LibreOffice QA Team This NEEDINFO Message was generated on: 2015-04-01

Warm Regards,
QA Team