Bug 80941 - LibreOffice should be installable from a GUI
Summary: LibreOffice should be installable from a GUI
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other Linux (All)
: lowest enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevEval, topicUI
: 81911 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-07-05 11:20 UTC by Hans Deragon
Modified: 2018-01-22 12:51 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hans Deragon 2014-07-05 11:20:07 UTC
Following is the current instructions for installing the latest version of LibreOffice on a Debian based OS:

-->
When you unpack the downloaded archive, you will see that the contents have been decompressed into a sub-directory. Open a file manager window, and change directory to the one starting with "LibreOffice_", followed by the version number and some platform information.

This directory contains a subdirectory called "DEBS". Change directory to the "DEBS" directory.

Right-click within the directory and choose "Open in Terminal". A terminal window will open. From the command line of the terminal window, enter the following command (you will be prompted to enter your root user's password before the command will execute):

The following commands will install LibreOffice and the desktop integration packages (you may just copy and paste them into the terminal screen rather than trying to type them):

sudo dpkg -i *.deb
<--

This is bad.  It should be much easier than that and should be all GUI based for all OSs.
Comment 1 David Tardon 2014-07-06 06:42:37 UTC
> This is bad.  It should be much easier than that and should be all GUI based
> for all OSs.

IMHO the users who want easy installation should use the packages provided by their distribution.
Comment 2 Hans Deragon 2014-07-06 13:41:02 UTC
Packages from their distributions are always obsolete, never up to date.  So users are forced to install the version provided by the website.
Comment 3 Urmas 2014-07-06 23:31:38 UTC
...because it so-o damned hard to add an installation script as the grown-up software does.
Comment 4 David Tardon 2014-07-07 07:23:17 UTC
(In reply to comment #2)
> Packages from their distributions are always obsolete, never up to date.  

Citation needed. E.g., Fedora normally has bugfix releases available in updates repository a few days after official release (and sometimes on the same day). And really impatient users can update from testing repository.

> So
> users are forced to install the version provided by the website.

Forced? Really? That sounds almost like the old version stopped working when there is a new release... And I am pretty sure that does not happen...
Comment 5 Hans Deragon 2014-07-07 09:53:59 UTC
Current version of LibreOffice for Ubuntu 12.04 LTS is LibreOffice 3.5.7.2.  Ubuntu LTS 12.04 will be supported until April 2017.

And no, people should not be forced to upgrade their OS to get a more recent version of their desktop application.  And even so, the version of LO for Ubuntu 14.04 LTS is probably now frozen and not being updated anymore.

If I report bugs about LibreOffice on this version, the first thing LO people tell me is to try it on the latest version; bug reports from 3.5.7.2 are not accepted.  Also, even if they were, there is no mean to test the bug fix since the repository version of LO is not updated.

Given that exporting to MS format is crucial for many, having the latest version is a must for many to ensure that the least formating is lost during the conversion.  That is my reason why I have to get the latest version of LO.

Why do Windows and Mac, proprietary OS, get so easy installer from the website, but not Linux, an ally of LibreOffice in the open source movement?  Think of the non computer savy user who just wants the latest version.
Comment 6 Joel Madero 2014-07-20 05:32:04 UTC
For Ubuntu 12.04 you can easily install the ppa which will keep you up to date
Comment 7 retired 2014-07-20 06:38:43 UTC
While I understand what Joel and others say, I tend to agree with Hans saying that software should be easily manageable via GUI. That is not the case for Linux. Frm the little experience I've had with Ubuntu, software management is very confusing. While devs and experienced linux geeks might laugh at that, it isn't so laughable for unexperienced users.

Why linux doesn't take this more serious (as many distributions are looking for wider adoption) is a mystery to me. But since this is getting very much OT:

Is this solvable for LO to have easy GUI install / uninstall options on Linx? If not, I tend to set this to NOTOURBUG. Because maybe it really is for the distros to provide better software managing options, that the average user can better grasp.
Comment 8 Joel Madero 2014-07-20 16:33:16 UTC
Well the problem is there are little tweaks in many of the distros packages that we can't just push to everyone. For instance, the Ubuntu ppa version of LibreOffice is in fact different from the debian package that you get from libreoffice.org - and we generally recommend using the ppa because of this.

I really think it's just the consequence of "choice" - when we have hundreds of distros running their own setup, really hard to make a standardized GUI. I'll poke one more person before closing as NOTOURBUG
Comment 9 Joel Madero 2014-07-20 16:38:14 UTC
FWIW - QA has been pretty active in trying to figure out an upgrade mechanism inside of LibreOffice but fixing the current one will take quite a bit of developer time. Our thoughts (which is perhaps enough for this enhancement request):

Inside of the software itself you select what "branch" of LibreOffice you want to be on - Fresh/Stable/Pre-Release, then you set that you either want to manually install it or have it auto install, then when release happens, you're either notified (if you select manual) or it automatically upgrades if you select auto.

If this is acceptable, we're already trying to determine if it's possible and to find a developer to handle it (which is hard to do as they are volunteers and this is no small task).
Comment 10 Yousuf Philips (jay) (retired) 2014-07-20 23:34:29 UTC
I personally wish that a simple installation GUI was available, as LibO has a GUI installation on windows and mac. The main problem is that libreoffice comes with a large number of DEB files that all have to be installed, while with other software, you download a single DEB file and you run it and it opens in a GUI installer app (ubuntu software center or gdebi), then you click install and walla, its done. Hopefully ubuntu's click packages might solve this issue, when its integrate into the system.

I think having one is a real positive for LibO, as it shows that LibO cares enough about their linux users to make it easy for them to install it, the same care that LibO shows to their windows and mac users. Imagine how many windows or mac users would install it if they had to go to the commandline and install LibO that way. This would also reduce the amount of FUD about linux, that its not an OS for beginners, as sometime or another, you'll have to go to the terminal, something which is quite scary for many users. LibO should be aiming to remove all barriers to users attempting to install it, especially when it can be achieved quite easily (referring to DEB installations).

The funniest thing that i found out during my terminal installation attempts in linux is that there is a bash installation script in the RPM installer file.

I think PPAs do solve some of the issue, but of course that is limited to only Ubuntu and its derivatives. The other issue with PPAs is that there still inst a fresh and stable PPA, so users can always stay in that particular branch. I personally have stable (4.1) through the PPA on my Linux Mint 13 (ubuntu 12.04) pc, and fresh (4.2) installed from LibO's website. And any time there is a new version of fresh, i run this batch script from within thunar or caja to simplify the installation

-------------------

#!/bin/bash

echo my_super_user_password | sudo -S dpkg -i DEBS/*.deb
rm -rf DEBS
zenity --info --text="DEBs Installed"

-------------------

Of course this script is primitive as it solves my specific needs, but the RPM included bash script is quite extensive with error checking, prompts, etc. I think having atleast a bash script is a step in the right direction, but think a simple python GUI installation script could easily be created. I think a simple uninstallation script should also be created, as when you upgrade from one stable or fresh branch to other (e.g. 4.1 to 4.2), uninstalling the old version would be useful.
Comment 11 Hans Deragon 2014-07-22 08:27:49 UTC
Here are some requirements I believe should apply to all OS:

1) Easy GUI to install the application.  Must pass the computer neophyte test.
2) Allow the installation of multiple version of LibreOffice.

#2 is harder.  I could open a new bug report for that one.

As for #1, there is no need to try to support all Linux distributions.  Only the main ones are required as most distributions are derivatives of the main ones, which are Suse, Fedora and Debian.  Ubuntu, as a derivative of Debian, should work if a Debian solution is provided.  Else, since this is still the #1 Desktop distribution and many others famous distribution derive from it (including Mint), if the Debian solution does not work on Ubuntu, then work should be done for a working solution on Ubuntu.

For Debian base distribution, would a single meta .deb file do the job?  Click on the .deb and the OS will show you a nice GUI to install it (at least, that is what happens on Ubuntu).  The .deb adds the PPA if not already there and then calls apt-get to another meta .deb which contains all the dependencies required.
Comment 12 Maxim Monastirsky 2014-07-30 12:23:36 UTC
*** Bug 81911 has been marked as a duplicate of this bug. ***
Comment 13 Björn Michaelsen 2014-07-30 13:11:15 UTC
For Ubuntu, there is a GUI to install LibreOffice, namely "Ubuntu software center". Fedora (and all other distros also targeting endusers) have something comparable. And as others noted Ubuntu has very up-to-date versions of LibreOffice in the PPAs. So for Ubuntu at least, this is a non-issue and I fully trust Davids Comment 4 on the situation for Fedora.
Comment 14 Michael Stahl (CIB) 2014-07-30 13:12:23 UTC
by the way, installing any number of different versions of the RPM
packages is already possible, i've got about 100 of them on my
build box, just use the bundled "install" script, it works even
on dpkg based systems...

the reason why LO has so many individual RPM/DEB packages is to
appease the obsessive-compulsive "there must not be any package
that depends on GTK+ / Qt / Java / Python / [whatever else my religion
disallows] installed on my system, and i don't *need* Draw so
want to save 5MB by not installing that" crowd.

perhaps we should just stop distributing binary builds for Linux from TDF,
and just rely on downstream distributions to take care of that?

basically upstream distribution is always going to suck, until
something like http://lwn.net/Articles/562138/ is widely
available - but since Linux distros currently can't agree
even on which low level package manager to use, it's going
to take some years...
Comment 15 Björn Michaelsen 2014-07-30 13:23:18 UTC
(In reply to comment #14)
> perhaps we should just stop distributing binary builds for Linux from TDF,
> and just rely on downstream distributions to take care of that?

Well, distributing no builds at all wouldnt be too good for QA and early testing. But yes, using these builds in production isnt a wise choice in general.

FWIW, I would suggest to just make one binary Linux tarball available upstream. That would allow testing, but wouldnt suggest to promise proper packaging (e.g. with dependency resolution etc.) as RPMs/DEBs do. Also proper packaging cant be provided generically (distro independant) and sanely anyway, as every attempt at that so far shows.
Comment 16 Björn Michaelsen 2014-07-30 13:44:32 UTC
(In reply to comment #5)
> Current version of LibreOffice for Ubuntu 12.04 LTS is LibreOffice 3.5.7.2. 
> Ubuntu LTS 12.04 will be supported until April 2017.

FWIW, this Ubuntu support includes LibreOffice. Note though, that for most issues this means that you have to have a support contract (either at Ubuntu/Canonical or another certified provider: http://www.documentfoundation.org/certification/developers/ ). If you dont want that thanks to open source and early releases, you have another option (both at Ubuntu and at LibreOffice -- or any other open source project): You can download alpha and beta releases or daily builds and make sure you report your issues early. As you are not paying for support, you have no assurance that the issue will be fixed, but reporting early certainly will improve your chances.

> And even so, the version of LO for Ubuntu 14.04 LTS is probably now frozen
> and not being updated anymore.

Wrong. LibreOffice is updated timely on Ubuntu 14.04. If you are overeager to get updates, I suggest to enable the LibreOffice PPA, which will give you updates even quicker.

> If I report bugs about LibreOffice on this version, the first thing LO
> people tell me is to try it on the latest version; bug reports from 3.5.7.2
> are not accepted.  Also, even if they were, there is no mean to test the bug
> fix since the repository version of LO is not updated.

As suggested above: All certified LibreOffice providers can provide you with custom fixes and long term support.

recommended further reading:
http://skyfromme.wordpress.com/2014/05/20/train-stops/
http://summit.ubuntu.com/uds-1308/meeting/21942/client-1308-rolling-libreoffice/
Comment 17 tommy27 2015-08-17 17:28:36 UTC
is this bug still valid with up to date LibO releases?
Comment 18 Adam Kłobukowski 2015-08-17 17:46:16 UTC
Still valid.
Comment 19 Yousuf Philips (jay) (retired) 2015-08-18 18:38:07 UTC
(In reply to Michael Stahl from comment #14)
> by the way, installing any number of different versions of the RPM
> packages is already possible, i've got about 100 of them on my
> build box, just use the bundled "install" script, it works even
> on dpkg based systems...

Would be good to bundle the install script with the DEB zip file if it works on dpkg systems.

The problem ultimately comes down to how linux distributions handle updating packages and even with a GUI installer, it wont solve all the problems that users feel that it will solve, which is why we encourage users to find suitable means provided by their distribution to update LibreOffice (e.g. using PPA for Ubuntu and its derivatives). An example of what the GUI installer wont be able to fix when comparing it to a updated repo or PPA is that when an update comes a long, a user who used the GUI installer while have to go to the website to get the latest version, while a user on an updated repo or PPA can open up synaptic or their update manager and easily update.

We should likely include the necessary instructions on how a linux user can get the latest updated versions through their distro on the libreoffice download page, similar to how Wine does it ( https://www.winehq.org/download/ ).
Comment 20 Jean-Baptiste Faure 2015-08-18 19:42:49 UTC
I disagree with wasting resources to design a GUI installer for Linux. 

If the user is not an advanced user, he should rely on the version provided by its distribution. If this version is too old, he should upgrade its distribution or learn the means provided by its distribution to follow the most recent version of LibreOffice (ad-hoc ppa in Ubuntu for example).

If the user is an advanced user, he will not find any gain using a GUI to do what he certainly already does with a script (== only one command). I build LO several times a day in release configuration and each time I make a standard installation, I only need to type a command like "sudo ./install_LO5". It is far easier than using a GUI because in my script I make 4 installations, LibreOffice, fr localization, fr help and en-us help. How many clicks to do the same in a GUI?

If the user is not an advanced user but want to make QA-test, I think that this user need to become an advanced user and be able to repair its LibreOffice installation and even its system. For him, command line installation is an easier task than losing time with a GUI.


Best regards. JBF
Comment 21 Michael Stahl (CIB) 2015-08-18 20:50:08 UTC
(In reply to Yousuf (Jay) Philips from comment #19)
> Would be good to bundle the install script with the DEB zip file if it works
> on dpkg systems.

i'm afraid you are missing the point - it is possible to install
the *RPM* packages into an arbitrary directory as non-root on a DEB-based
system, and the install script *only* works with RPM packages.

i do not know if it is possible to write a similar script for DEB packages,
nobody has tried it yet, you are welcome to give it a try.
Comment 22 Joel Madero 2015-08-19 02:19:03 UTC
@JBF - this is not at all how we judge enhancements. "I don't think we should waste our time" is not a valid argument for closing an enhancement request - maybe some volunteer thinks this isn't a waste of time at all...we're not paying anyone so it's not wasting anyone's time (because things are taken by choice not dictated).
Comment 23 Jean-Baptiste Faure 2015-08-19 04:19:30 UTC
(In reply to Joel Madero from comment #22)
> @JBF - this is not at all how we judge enhancements. "I don't think we
> should waste our time" is not a valid argument for closing an enhancement
> request - maybe some volunteer thinks this isn't a waste of time at
> all...we're not paying anyone so it's not wasting anyone's time (because
> things are taken by choice not dictated).

I think you don't take into account the time spent by reviewers, QA testers and translators that is required by a new development.

Best regards. JBF
Comment 24 Robinson Tryon (qubit) 2015-12-13 11:24:22 UTC Comment hidden (obsolete)
Comment 25 Dan Dascalescu 2016-06-09 04:24:57 UTC
I'm an advanced enough user to mess with dpkg and install gdebi-core in hopes of solving the dependency hell, but I'm still stuck with a borked installation. Details at https://bugs.documentfoundation.org/show_bug.cgi?id=100284

Point is, please think of users who just don't have the time or knowledge to mess with command-line installations, and provide either an easy install script in the .deb archive, or a graphical installer.

I have some knowledge, definitely not the time, and want the 5.2.0 version because it solves a compatibility problem with wildcards (https://wiki.documentfoundation.org/ReleaseNotes/5.2#Support_wildcards_to_be_compatible_with_XLS.2FXLSX_and_with_ODF_1.2). I've wasted over two hours by now trying to get 5.2 to run.
Comment 26 Bastián Díaz 2016-06-09 06:24:06 UTC
I think here Flatpak help solve the problem. Gnome Software offer native support for Flatpak packages in the next stable release https://mail.gnome.org/archives/ftp-release-list/2016-May/msg00089.html. It is likely that other software stores offer support for Flatpak in the future.

Another solution is to provide a portable version of LibreOffice. This issue is discussed here: Bug 97269
Comment 27 MarjaE 2016-10-15 04:22:33 UTC
(In reply to Jean-Baptiste Faure from comment #20)
> I disagree with wasting resources to design a GUI installer for Linux. 
> 
> If the user is not an advanced user, he should rely on the version provided
> by its distribution. If this version is too old, he should upgrade its
> distribution or learn the means provided by its distribution to follow the
> most recent version of LibreOffice (ad-hoc ppa in Ubuntu for example).

And this is one reason I had to stop using Linux. I used Ubuntu 11.04, in Classic, and restoring and widening scrollbars. I couldn't go back to 10.10 lts because it didn't support the kernel patch for the Alps touchpad on my computer. I didn't go forward to 11.10 because of reports that it went further in disabling scrollbars. I think Shuttleworth had commented that "everyone" can use scrollwheels and gestures, so no one needs scrollbars any more. (Well, I am not everyone, and I use special scrolling software now but would like wider scrollbars too.)

It's probably better for different distros to work out how to make a common installer for multiple distros.
Comment 28 Yousuf Philips (jay) (retired) 2016-10-15 19:14:22 UTC
Though i'm in favour of its implementation, i dont see any libreoffice or linux distribution devs bothering with implementing this as most linux users get libreoffice from their distro and with the availability of snap, flatpak, and appimage versions of libreoffice, users will be able to easy install/run libreoffice without a tradition windows-like GUI installer.
Comment 29 V Stuart Foote 2016-10-15 19:43:31 UTC
+1 on the WONTFIX as not worth dev effort to try to unify an installer--and most distros provide their own packaging as they see fit. 

Ubuntu has PPA option, and otherwise DEB or RPM TDF build packaging as noted.

And for the hardcore, source is available to build.
Comment 30 Hans Deragon 2016-10-15 21:34:01 UTC
At least, could the website http://www.libreoffice.org point users of major Linux distribution on how to get the latest version on their distribution, without resorting to the terminal?

For instance, for Ubuntu users, a link to the Ubuntu PPA and nice, grandma compatible list of instructions on how to get the latest version?
Comment 31 Hans Deragon 2018-01-22 12:51:37 UTC
A Flatpack or Snap could be a solution.  These formats are becoming universal installers.