Bug Hunting Session
Bug 80970 - Serial letters printing dialog does not show when using a .ott document template
Summary: Serial letters printing dialog does not show when using a .ott document template
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-06 10:12 UTC by Michael Satke
Modified: 2015-09-14 10:08 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Satke 2014-07-06 10:12:51 UTC
Serial letters printing works fine for me, as long as I print a a .odt Writer document. I use standard Libreoffice Base databases.

As soon as I try printing a untitled document, opened from a .ott writer document template, both by klicking on the "print" and using the file menu, Libreoffice asks me if I would like to print a serial letter (this is normal behaviour). When I klick "O.K." instead of opening the serial letter printing dialog, nothing happens.

At the moment my workaround is not to use .ott templates for my serial letters, which is a little sad.

Version: 4.1.3.2
Build ID: 410m0(Build:2)
OS: Ubuntu 14.04, 64 bit
Comment 1 Cor Nouws 2014-07-06 12:27:57 UTC
Hi Michael,

Thanks for reporting. Now I wonder if it isn't logic that you start a document from the template and then do a merge with the data, rather then merging within the template.. Can you pls explain that? 
Regards,
Cor
Comment 2 Michael Satke 2014-07-06 16:46:43 UTC
Thanks Cor,

up to now I used document templates to bill my customers. In the past I had many folders containing bill templates. I like templates a lot because they prevent me from overwriting them.

Then I tried to be a real pro and entered my costumer data into a LO Base database, using only one bill document template, which fetched the needed customer data from the db. All worked fine except for the serial printing. So now I save a write-protected .odt document serving as template substitute.

In my view, serial printing should work fine with templates. The template creates an untitled document, which has access to the correct data source. Note that there was no error message.

Cheers
Comment 3 Michael Satke 2014-07-09 15:17:04 UTC
I have some additional inforation:

The very first attept  to do a serial print in an ubuntu desktop session succeedes, any other try (no matter if it was the same document or any other one) brings up the bug again.
Comment 4 Michael Satke 2014-07-09 15:18:13 UTC
(My last comment was about serial printig from an .ott template.)
Comment 5 Buovjaga 2014-11-25 09:32:24 UTC
This should be UNCONFIRMED.
Comment 6 Cor Nouws 2014-11-26 17:47:22 UTC
Michael: create a new document from your template, and put the fields in there (maybe with an autotext).
Or create a new document from your template that already include the fields.
Both scenarios give you an odt file to work with.
Would that work for you (it does for me..)
Comment 7 Michael Satke 2014-11-26 22:08:38 UTC
(In reply to Cor Nouws from comment #6)
> Michael: create a new document from your template, and put the fields in
> there (maybe with an autotext).
> Or create a new document from your template that already include the fields.
> Both scenarios give you an odt file to work with.
> Would that work for you (it does for me..)

Tnx, but I can perform a workaround, like I mentioned, I print a lot of serial letters professionaly. My objective in reporting this is to prevent joe sixpack trying to use this functionality of LO and becoming rejected and frustrated. That's why I hope this bug can be solved with no workarounds. If too complicated, LO could prevent the user from serial printing from within a .ott by requesting the user to first save the document as an .odt file.
Comment 8 Alex Thurgood 2015-01-03 17:40:06 UTC
Adding self to CC if not already on
Comment 9 Alex Thurgood 2015-02-01 15:51:44 UTC
(In reply to Michael Satke from comment #7)


> 
> Tnx, but I can perform a workaround, like I mentioned, I print a lot of
> serial letters professionaly. My objective in reporting this is to prevent
> joe sixpack trying to use this functionality of LO and becoming rejected and
> frustrated. That's why I hope this bug can be solved with no workarounds. If
> too complicated, LO could prevent the user from serial printing from within
> a .ott by requesting the user to first save the document as an .odt file.

From what I recall, when you create a mailmerge document, you get the opportunity to save the document as a template. 

Open Writer document, drag and drop your fields, press Ctrl-P, answer yes to start the mailmerge wizard. Select output to file, then save as indidual documents. You get offered the choice of saving as OTT (among many others), which implies that you can then re-use these documents for mailmerge purposes.

If this isn't working, then it is a bug IMHO, so I would agree with you.
Comment 10 Alex Thurgood 2015-02-01 16:02:06 UTC
This works for me with 

Version: 4.2.7.2
Build ID: 420m0(Build:2)
Linux Mint 17.1

I can create an OTT file containing database fields.
File > Open opens the OTT, not a blank document
Ctrl-P starts the mailmerge wizard
Select the records I want to print/export to document, OK
Document saved containing the appropriate records.
Comment 11 Alex Thurgood 2015-02-01 16:04:17 UTC
My first suggestion would be to update your version of LibreOffice to a current production version. Please retest again and report back with your findings.

Setting to NEEDINFO pending requested information. If you are still having this problem, we would need a detailed step by step example of what you are doing, and sample documents / datasource / ODB file.
Comment 12 Michael Satke 2015-02-02 19:19:58 UTC
The problem occured ONLY when RE-openig a predesigned .OTT file. I use this e.g. for billing my customers.

As you mention, of course a bug should only be filed for non-outdated versions. At the moment I am using

Version: 4.3.3.2
Build-ID: 430m0(Build:2)

Alex, I will do some intensive testing in the next days and tell you whether the problem still exists! If yes, I'll provide all the info plus the terminal outputs. Cheers
Comment 13 QA Administrators 2015-09-04 02:55:46 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team

This NEEDINFO message was generated on: 2015-09-03
Comment 14 Cor Nouws 2015-09-14 10:08:43 UTC
I see enough simple work arounds. And the problem described, is not the normal work flow either. So I set this one as WorksForMe.
Cheers - Cor
Comment 15 Cor Nouws 2015-09-14 10:08:59 UTC
.