Bug 80972 - LibreOffice wont open/initialize
Summary: LibreOffice wont open/initialize
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.3.0.1 rc
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-06 12:30 UTC by Daniel
Modified: 2015-09-04 03:01 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel 2014-07-06 12:30:50 UTC
If I try to open from the dashboard it just don't do anything, but it spins up a python3 proccess.

If I try to open an impress file it says:

Component cannot be loaded, possibly broken or incomplete installation.
Full error message:

 loading component library <file:///usr/lib/libreoffice/program/../program/libsdlo.so> failed.

And if I try to open an writer file it says:

General Error.
General input/output error.


I'm using Ubuntu 14.04 with PPA. Before I had a 4.2.5 install from the PPA, and then I removed the PPA, the dependencies (libreoffice*), the orphaned packages that surfaced and all the config files. Then I added the prereleases PPA, and after I updated and installed libreoffice, it wont start no matter what.
Comment 1 Marina Latini (SUSE) 2014-07-25 11:29:50 UTC
Hi, 
My Ubuntu 14.04 x86_64 works fine with LibO PPA:
deb http://ppa.launchpad.net/libreoffice/libreoffice-4-2/ubuntu trusty main 
deb-src http://ppa.launchpad.net/libreoffice/libreoffice-4-2/ubuntu trusty main 

I can't confirm your bug.
Do you have any news after system updates?

Which LibreOffice version is bugged?
The description bring back to 4.2.5.2 but you set 4.3.0.1 rc. 
Please, specify the oldest one not the newer.
Comment 2 Robinson Tryon (qubit) 2014-07-26 20:13:52 UTC
(need more info from bug reporter, so
Status -> NEEDINFO)
Comment 3 Owen Genat (retired) 2014-08-03 01:10:52 UTC
Same error now reported on the Ask site for Oracle Linux 7 + v4.3.0.4:

http://ask.libreoffice.org/en/question/37825/
Comment 4 Daniel 2014-08-03 17:55:28 UTC
Well, after the official release I made the update from the "fresh" PPA (libreoffice/ppa) and everything works just fine.

I don't have a clue about the error that ocurred, but now it is "solved" as I have the latest version without any problem.
Comment 5 Andrew Spurrier 2014-12-15 05:08:25 UTC
Same issue on RHEL 7.  The solution at http://ask.libreoffice.org/en/question/37825/why-cant-i-open-libreoffice-components-on-oracle-linux-7/

...works for RHEL 7 too.  I guess we are missing the dependency on mesa-libGLU in the libobasis4.3-core04.x86_64.rpm package?  

My desktop is a fresh RHEL 7 Workstation and I installed LibreOffice_4.3.4_Linux_x86-64_rpm.tar.gz today.
Comment 6 Robinson Tryon (qubit) 2014-12-15 13:46:18 UTC
(In reply to Andrew Spurrier from comment #5)
> Same issue on RHEL 7.  

Hmm, might be different issue as we're talking two different distros.

The solution at
> http://ask.libreoffice.org/en/question/37825/why-cant-i-open-libreoffice-
> components-on-oracle-linux-7/
> 
> ...works for RHEL 7 too.  I guess we are missing the dependency on
> mesa-libGLU in the libobasis4.3-core04.x86_64.rpm package?  

Possibly.

> My desktop is a fresh RHEL 7 Workstation and I installed
> LibreOffice_4.3.4_Linux_x86-64_rpm.tar.gz today.

Let's get some more information here. Please try out the 4.3.5.2 RC and/or a 4.4 beta build and let us know if those exhibit the same problem:
http://dev-builds.libreoffice.org/pre-releases/ 

Status -> NEEDINFO  (change back to UNCONFIRMED after you test)
Severity -> major

Thanks!
Comment 7 QA Administrators 2015-07-18 17:36:45 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team

This NEEDINFO message was generated on: 2015-07-18
Comment 8 QA Administrators 2015-09-04 03:01:59 UTC
Dear Bug Submitter,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INVALID due to inactivity and a lack of information which is needed in order to accurately reproduce and confirm the problem. We encourage you to retest your bug against the latest release. If the issue is still present in the latest stable release, we need the following information (please ignore any that you've already provided):

a) Provide details of your system including your operating system and the latest version of LibreOffice that you have confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED and we will attempt to reproduce the issue. 
Please do not:
a) respond via email 
b) update the version field in the bug or any of the other details on the top section of FDO
Message generated on: 2015-09-03