Bug 81097 - protection password lost after crash
Summary: protection password lost after crash
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.0.2 rc
Hardware: All Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 82056 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-07-09 10:14 UTC by bonbon
Modified: 2015-12-28 10:17 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bonbon 2014-07-09 10:14:22 UTC
protection password lost after crash.
Comment 1 Jean-Baptiste Faure 2014-07-19 22:09:31 UTC
Please, could you elaborate a bit?
- which crash ? LibreOffice or MS-Windows ?
- describe step by step how to reproduce the problem
- attach a test file

Set status to NEEDINFO. Please set it back to UNCONFIRMED once you have provides the requested informations. Thank you for your understanding.

Best regards. JBF
Comment 2 bonbon 2014-07-21 07:25:53 UTC
(In reply to comment #1)
> Please, could you elaborate a bit?
> - which crash ? LibreOffice or MS-Windows ?
> - describe step by step how to reproduce the problem
> - attach a test file
> 
> Set status to NEEDINFO. Please set it back to UNCONFIRMED once you have
> provides the requested informations. Thank you for your understanding.
> 
> Best regards. JBF

-Libreoffice Crash.
-When drag to fill, libreoffice often crashs. I set a sheet protection password,but after crashed.open the file again, the password disappears.
Comment 3 Jean-Baptiste Faure 2014-07-21 08:17:55 UTC
(In reply to comment #2)
[...]
> I set a sheet protection password,but after crashed.open the file again, the
> password disappears.

It is normal if the file has not been saved before the crash. In such a case, all not saved modifications are lost. 
Did you save the file just after having set the sheet protection?

Best regards. JBF
Comment 4 bonbon 2014-07-21 13:45:11 UTC
Yes, I have saved it with password. But anytime if crash, the password will be lost.
Comment 5 Jean-Baptiste Faure 2014-07-22 06:34:09 UTC
Not easy to reproduce because LO don't crash for me. Please, could you attach 2 files to this bug report:
1/ a document with password protection, saved and closed just after you set the protection. Take care to not file confidential data in this document.
2/ the same document after a crash.
With both files we could investigate inside each file.

Thank you for your understanding.

Bets regards. JBF
Comment 6 bonbon 2014-07-22 18:06:24 UTC
Sorry I can not send these personal files. And crash is not frequent, so I can not yet just creat these two new files.
Comment 7 raal 2014-08-19 06:45:15 UTC
*** Bug 82056 has been marked as a duplicate of this bug. ***
Comment 8 Buovjaga 2014-11-26 12:44:22 UTC
(In reply to Kevin from comment #6)
> Sorry I can not send these personal files. And crash is not frequent, so I
> can not yet just creat these two new files.

Use this to strip out personal information: https://wiki.documentfoundation.org/QA/BugReport/Attachments#Confidential_Attachments
Comment 9 JuanPy 2015-04-30 15:59:13 UTC
Hi, I'm new to the community, so I apologize in advance if I mess up the procedure a bit.

In my case, I was working with a few Firefox and Chrome windows when my laptop ran out of battery and turned off instead of just hibernating as usual (this has been happening inconsistently for a couple of months now). I think I had a password protected Calc file open, but couldn't tell for sure. I've been using it as a log for 3 or 4 years now, so I use it a lot.

When I turned the computer back on I recovered my internet pages and opened LibreOffice to create a Writer document. LibreOffice interface offered to recover the Calc file and I accepted. As it was recovered I was wondering if it was going to ask for a password or not. It didn't. The file just opened. Then I wrote something to check if it was write-enabled. It was. I saved, closed, and reopened. It just opened without asking for a password.

I changed its name and saved-as with the old name and password protection again. It seems to work fine, but I've just saved it. I'll make sure I let you know if anything happens. Hopefully it will be ok.

Regards.
Comment 10 JuanPy 2015-04-30 16:34:42 UTC
Hi again. My laptop just had a problem again, the screen went black so I had to turn it off by hardware (pressing power button for 6 seconds) while definitely having the Calc file open (the fixed one I talked about in my previous comment).

So when I rebooted the system and restarted LO, it offered to recover the file and, after I accepted, asked for the password before proceeding, as it should. It's working ok now, so hard-resetting Windows is probably not the cause.
Comment 11 QA Administrators 2015-12-27 20:31:45 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least
6 months. Please provide the requested information as soon as
possible and mark the bug as UNCONFIRMED. Due to regular bug
tracker maintenance, if the bug is still in NEEDINFO status with
no change in 30 days the QA team will close the bug as INVALID
due to lack of needed information.

For more information about our NEEDINFO policy please read the
wiki located here:
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Status/NEEDINFO

If you have already provided the requested information, please
mark the bug as UNCONFIRMED so that the QA team knows that the
bug is ready to be confirmed.
 
Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 12 Buovjaga 2015-12-28 10:17:09 UTC
Patrick: I don't know why you set this as fixed, but the correct status after a long time in needinfo would be invalid.
Closing.