Bug 81122 - EDITING: Libreoffice crashes when editing bitmaps with external tool
Summary: EDITING: Libreoffice crashes when editing bitmaps with external tool
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.3.0.2 rc
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-09 17:40 UTC by Callegar
Modified: 2015-02-19 14:58 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Callegar 2014-07-09 17:40:29 UTC
Problem description:

Open a drawing containing a png image and try to edit it using the 'edit ith external tool function'. When saving the file edited in the external tool and closing the external tool, libreoffice hangs for a few seconds and then crashes.


# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00007fd4a2add021, pid=11440, tid=140551696865408
#
# JRE version: OpenJDK Runtime Environment (7.0_55-b14) (build 1.7.0_55-b14)
# Java VM: OpenJDK 64-Bit Server VM (24.51-b03 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C  [libsvxcorelo.so+0x3b8021]  SdrEditView::ReplaceObjectAtView(SdrObject*, SdrPageView&, SdrObject*, unsigned char)+0x61

This is systematic.

Tried with the gimp as an external editing tool.

Issue also happens with LibO stable 4.2 (tested 4.2.5)

Issue also happens when trying to achieve the same goal with cut and paste.

Copy bitmap, paste as new in the gimp, edit in the gimp, select all in the gimp, copy, paste in LibO while having the previous bitmap selected so as to replace it with unaltered size and position. 

Operating System: Ubuntu
Version: 4.3.0.2 rc
Comment 1 Callegar 2014-07-09 17:42:13 UTC
This is probably a regression. I would not be able to say when, but I am pretty sure that this used to work, at least by the cut-and-paste method, in the past.
Comment 2 Kevin Suo 2014-07-10 10:32:22 UTC
No crash with 4.3.0.2, windows XP SP3, using the XP built-in drawing app as editor.
Comment 3 Jean-Baptiste Faure 2014-07-19 08:33:29 UTC
No crash for me with LibreOffice 4.3.1.0.0+ build at home under Ubuntu 14.04 x86-64.

It is surprising that the JVM crashes because Java seems to be not used when editing a PNG picture with external tool. Indeed I configured LibreOffice to not use Java and editing a PNG picture with an external tool works without problem.

Please, could you do the same test?

Other questions: 
1/ are you sure that the picture is in PNG format? 
2/ what is the format of the file with which you encounter this crash? OpenDocument (.odt) or OOXML (.docx)?
3/ did you check if the crash is reproducible with whatever file containing a PNG picture, or do you observe this crash with a particular file?
4/ if you observe the crash with a particular file, please could you attach it to this bug report (after having removed all confidential data)?

Setting status to NEEDINFO; please set it back to UNCONFIRMED when you will have provided the requested informations.

Thank you for your understanding.
Best regards. JBF
Comment 4 QA Administrators 2015-02-19 04:33:46 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team

Message generated on: 2015-02-18
Comment 5 Callegar 2015-02-19 11:12:57 UTC
Seems fine with more recent versions of LibO.  Forgot to update the bug status.
Can be closed for me.
Comment 6 Kevin Suo 2015-02-19 14:58:51 UTC
(In reply to sergio.callegari from comment #5)
Mark as WORKSFORME per comment 5.