Bug 81131 - Having special characters in the name of a shape or a group of shape doesn't show the list of names when inserting from a Draw document
Summary: Having special characters in the name of a shape or a group of shape doesn't ...
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
(earliest affected) rc
Hardware: All All
: medium major
Assignee: Not Assigned
Depends on:
Reported: 2014-07-09 23:39 UTC by Jouni Järvinen
Modified: 2014-10-19 13:02 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:

Example file (8.54 KB, application/vnd.oasis.opendocument.graphics)
2014-07-09 23:39 UTC, Jouni Järvinen

Note You need to log in before you can comment on or make changes to this bug.
Description Jouni Järvinen 2014-07-09 23:39:06 UTC
Created attachment 102506 [details]
Example file

Tested using 4.3.0 RC2 (on Window$ 7 Ultimate x64). No reason to believe doesn't apply to other versions and/or platforms.

During http://ask.libreoffice.org/en/question/36686/how-to-insertimport-a-draw-file-containing-a-single-symbol-without-the-empty-space-into-draw/ it became clear Draw doesn't support at least some characters in the name, given for a particular shape or group of shape(s).

At least slash, /, is unsupported. Others yet to be tested.

If such character is in the name, the window showing tree of names you gave for shapes doesn't appear at all, making Draw take the whole file including empty space. This isn't bad for names which don't have such characters, but for the ones it is.

I don't believe this is that hard for XML, so I don't see why this bug exists in the first place. http://stackoverflow.com/questions/539143/xml-entity-for confirms slash doesn't need escaping.

Or, if this can't be supported anyhow, Draw should warn about it and offer to strip the characters, change to something or allow to cancel so you can change it yourself.
Comment 1 Jouni Järvinen 2014-07-09 23:40:50 UTC
To clarify just in case, the attachment description means the group in the file that makes up the diode.
Comment 2 Urmas 2014-07-10 00:09:03 UTC
Cannot reproduce in master.
Comment 3 Jouni Järvinen 2014-07-10 00:13:20 UTC
(In reply to comment #2)
> Cannot reproduce in master.

Any binaries for installation ?
Comment 5 Jouni Järvinen 2014-07-10 10:51:05 UTC
(In reply to comment #4)
> http://dev-builds.libreoffice.org/daily/master/Win-x86@42/2014-07-09_00.11.
> 17/

The file is like half smaller than the other installers, and its lack of size is backed by having just the optional components in the customization section. Unless I'm missing something, this installer is bad.
Comment 6 Jouni Järvinen 2014-07-12 22:33:33 UTC
While later working with the files I noticed the file started working, and any later file I created with same things worked just fine, and especially ones with mixed cases of group names worked perfectly. And the same example file works just fine, so I dunno.

Could be there's some line of code which causes the selection window to sometimes not appear. We'll see later.

Confirmed working.
Comment 7 Jouni Järvinen 2014-07-12 22:54:53 UTC
Works fine with (portable)
Comment 8 Jouni Järvinen 2014-10-14 15:59:36 UTC
Ahaa, I found that if you insert an OLE object (Insert -> Object -> OLE Object -> Create from file), you insert the whole document, unused space included.

If you insert a file (Insert -> File), it shows list of named groups and if you check the box, will remove unused space.

So no problems here yet.