Bug 81251 - Mail Merge fails in Wizard step 4, create salutation
Summary: Mail Merge fails in Wizard step 4, create salutation
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: Other macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-11 22:18 UTC by Toby
Modified: 2015-02-21 14:21 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Fail message (399.20 KB, image/png)
2014-07-11 22:18 UTC, Toby
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toby 2014-07-11 22:18:02 UTC
Created attachment 102645 [details]
Fail message

Try to choose personalized salutations and every time it fails with message shown in gif.
Comment 1 Cor Nouws 2014-07-12 11:00:11 UTC
Comment on attachment 102645 [details]
Fail message

(correct mime type)
Comment 2 Cor Nouws 2014-07-12 11:02:41 UTC
Hi Toby,

Thanks for the issue. I clarify the summary a bit.
Any idea if this worked in older versions?
(I never use the wizard for mail merg.. sorry ;) )
Cor
Comment 3 Toby 2014-07-13 19:16:16 UTC
No sorry Cor. Never used the mail merge before in Libre either, only in Word.
Toby
Comment 4 Jorendc 2014-07-16 19:51:47 UTC
Fail to reproduce, tested using Linux Mint 17 x64 with LibreOffice Version: 4.4.0.0.alpha0+ Build ID: 7ed283b9bcdde1ae7d858d04880115a1b5a45315
Comment 5 Alex Thurgood 2014-08-06 09:51:13 UTC
Methinks that this has more to do with the Heisenbug that has been seen on OSX with file creation in various other bug reports : (File > New), writing to external FAT disks, etc.


The failure message implies that the temporary file could not be created, or rather, that it only contains 0 bytes. Now whether that is the correct message that should be thrown in such a circumstance is another question.

Alex
Comment 6 Alex Thurgood 2014-08-06 10:06:28 UTC
(In reply to comment #5)
> Methinks that this has more to do with the Heisenbug that has been seen on
> OSX with file creation in various other bug reports : (File > New), writing
> to external FAT disks, etc.
> 
> 
> The failure message implies that the temporary file could not be created, or
> rather, that it only contains 0 bytes. Now whether that is the correct
> message that should be thrown in such a circumstance is another question.
> 
> Alex

Scratch that, it is saying it can't write the file, whether or not it contains any data, I have no idea.
Comment 7 Alex Thurgood 2014-08-06 10:12:01 UTC
@Toby :
Please provide us with more details about how you are using the mailmerge wizard, including precise steps.

When I start the mailmerge wizard from the Tools menu, I see five possible choices from which to start :

- use active document
- create a new document
- use an existing document
- from a template
- from a recently saved document (greyed out)

More details please, and a test document (including an indication of the datasource) would be handy if you have one.
Comment 8 Julien Nabet 2015-02-21 14:21:49 UTC
No feedback since 6 months, I put it as INVALID.

Toby: Don't hesitate to reopen this tracker if you can still reproduce this with recent LO version (4.3.5 or 4.4.0).