Bug 81495 - hyperlinks containing spaces or special characters (é, è, ü, ö accent, umlaut) can not be open
Summary: hyperlinks containing spaces or special characters (é, è, ü, ö accent, umlaut...
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: ruggero
URL:
Whiteboard: NeedsSuse
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-18 12:53 UTC by ruggero
Modified: 2014-08-21 15:14 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
a demo document, where a normal yoperlink open w/o problem. An Hyperlink with specila characters don't (50.96 KB, application/zip)
2014-07-21 15:17 UTC, ruggero
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ruggero 2014-07-18 12:53:20 UTC
I upgraded to SuSe Linux 13.1 recently  (Libreoffice 4.1.6.2).
I discover that crtl-clicking over a hyperlink, when the hyperlink path contains a space, or a non ASCII character like , gives the message "no such file or directory".
The hyperlink can be created.
I upgraded to Libreoffice 4.2.5.2. The problem persist.
I try to delete my user profile (rm .rf ~/.config/libreoffice --> no change

However the problem does not appears on windows (Liberoffice 4.2.4.2).

NOTE: previous version of Libreoffce (unknown), used to open hyperlinks using firefox, that resolved what to do with the file. Both versions 4.1.6.2 and 4.2.5.2 now open my pdf files directly, calling "evince" directly.
The bug could be something as trivial as %s instead of '%s' in some configuration file, but where?
Comment 1 Joel Madero 2014-07-19 06:38:59 UTC
Please attach a document with a hyperlink such as this

Marking as NEEDINFO - once you attach a document mark as UNCONFIRMED. Thanks!
Comment 2 ruggero 2014-07-21 15:17:57 UTC
Created attachment 103195 [details]
a demo document, where a normal yoperlink open w/o problem. An Hyperlink with specila characters don't

dear Joel
I attached here a file, with several hyperlinks.
Only the first one works on (two) opensuse 13.1 computers (desktop manager LXDE).
All the links works on Windows 8.1

The file was created with Libreoffice 4.1.6.2, since I was not able to have relative links working with 4.2.*. In any case, the problem was present with a native 4.2.* file too (but I couldn't test it on win).
Comment 3 Joel Madero 2014-07-21 16:36:20 UTC
Thanks for the great test kit - 

That being said, I cannot confirm:
Ubuntu 14.04 x64
LibreOffice version(s): 4.2.5.2 release, 4.3.0.2 rc

Maybe Suse only problem.
Comment 4 Jorendc 2014-07-21 16:47:09 UTC
I fail to reproduce this issue, tested using Linux Mint 17 x64 with LibreOffice 4.2.5.2.

Ctrl+click on links opens the pdf correctly.

Kind regards,
Joren
Comment 5 ruggero 2014-07-21 17:21:54 UTC
(In reply to comment #3)
> Thanks for the great test kit - 
> 
> That being said, I cannot confirm:
> Ubuntu 14.04 x64
> LibreOffice version(s): 4.2.5.2 release, 4.3.0.2 rc
> 
> Maybe Suse only problem.

I believe much more strict: not SuSe, but SuSe + LXDE.
I straced the process.
libreoffice calls something like open-url (in libreoffice), that in turns
calls xdg-open, with the parameter  "file:///home/ruggero/bug-path/normal/with%20space.pdf". 

xdg-open in turns call pcmanfm that does not understand %20, and emit the "no such file" dialog box.

Calling xdg-open without the %20 but with blank, it works.

Any idea now?

In any case, not a Libreoffice bug
Comment 6 Joel Madero 2014-07-22 05:22:44 UTC
No ideas here sorry, but indeed seems like NOTOURBUG and an issue with PCMANFM. I suggest you file a bug report with them letting them know that their file manager isn't interpreting commands correctly like other file managers. Thanks for reporting back - sorry we couldn't do more for you
Comment 7 ruggero 2014-08-21 15:14:52 UTC
Update:
it seem to be NOT a pcmanfm bug, but a xdg-open bug.

on xdg-utis bugzilla there is a working (and convincing) patch:

https://bugs.freedesktop.org/show_bug.cgi?id=63153
comment 4
>David Costa 2014-06-24 20:20:53 UTC
>
>Created attachment 101693 [details] [review]
>Fix for #63153 by urldecoding
>
>Alternative patch: this takes the code already used in open_generic() to strip >the file:// off the URL and then urldecode the rest of the string.
>The patch is based off the git version of xdg-utils, commit 869b22b7.
>I tested it on ArchLinux with some applications like clementine and calibre.
I tested with libreoffice too.

https://bugs.freedesktop.org/attachment.cgi?id=101693

it seems that there is no intention to apply the patch on the new releasees of xdg-open