Download it now!
Bug 81562 - UI: table view displays content as bold with particular table
Summary: UI: table view displays content as bold with particular table
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-20 13:21 UTC by Alex Thurgood
Modified: 2015-01-26 10:48 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
bugdb (62.40 KB, application/vnd.oasis.opendocument.database)
2014-07-21 15:18 UTC, Alex Thurgood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Thurgood 2014-07-20 13:21:29 UTC
Title pretty much says it all.

Open an embedded Firebird ODB.
Open a table (double-click)
Content of table displayed completely in bold (but not column headers)
Query view displays in normal weighted font.
Comment 1 Alex Thurgood 2014-07-20 13:23:57 UTC
master build id
a24139dafdf044b319bbf7c8e6fb34ee7b0c139d
Comment 2 Alex Thurgood 2014-07-21 15:18:49 UTC
Created attachment 103196 [details]
bugdb
Comment 3 Lionel Elie Mamane 2014-07-21 16:56:07 UTC
Reproduced on Debian GNU/Linux.
Comment 4 Lionel Elie Mamane 2014-07-22 17:29:20 UTC
I'm rather clueless on this one. If someone could bibisect it, I'd be grateful.
Comment 5 Lionel Elie Mamane 2014-07-23 10:45:20 UTC
Opening the file (which is HSQLDB embedded) with older LibreOffice versions, one also gets bold for the table view data.

The attached .odb contains the request for bold style, in its content.xml:

<style:style style:name="ce1" style:family="table-cell">
    <style:paragraph-properties fo:text-align="start"/><style:text-properties style:font-name="Ubuntu" fo:color="#000000" fo:font-size="0.08cm" style:font-pitch="variable" fo:font-style="normal" fo:font-weight="bold"/>
</style:style>


and later

            <db:table-representations>
                <db:table-representation db:name="Inventario">
                    <db:columns>
                        <db:column db:name="Categoria" db:style-name="co1" db:default-cell-style-name="ce1"/><db:column db:name="Codice" db:style-name="co1" db:default-cell-style-name="ce1"/>
                        <db:column db:name="Descrizione" db:style-name="co1" db:default-cell-style-name="ce1"/>
                        <db:column db:name="ID" db:style-name="co1" db:default-cell-style-name="ce1"/>
                        <db:column db:name="Listino 1" db:style-name="co2" db:default-cell-style-name="ce1"/>
                        <db:column db:name="Listino 2" db:style-name="co3" db:default-cell-style-name="ce1"/>
                        <db:column db:name="Listino 3" db:style-name="co3" db:default-cell-style-name="ce1"/>
                        <db:column db:name="Note" db:style-name="co1" db:default-cell-style-name="ce1"/>
                        <db:column db:name="Quantità" db:style-name="co1" db:default-cell-style-name="ce1"/>
                    </db:columns>
                </db:table-representation>
            </db:table-representations>


I have *no* idea how this got in there. Alex, how did you create this? Is font Ubuntu in bold not your default font (system default, LibreOffice default, currently selected in LibreOffice when creating the table, when creating the file, ...) or something like that?

If you create a fresh new file, does it also have table data in bold?
Comment 6 Lionel Elie Mamane 2014-07-23 10:47:12 UTC
If I create a new table in the same file, the data is not in bold, which shows it is attached to that particular table.
Comment 7 Alex Thurgood 2014-07-30 13:40:33 UTC
Hi Lionel,

I don't know where this table came from, other than that it was posted for another bug report - I didn't create the file in the first place.

On OSX 10.9.4 and 
Version: 4.4.0.0.alpha0+
Build ID: a0b89100be8ccc2b60d08d7e3819cd247a6042b0

There is some kind of font substitution going on because the table content looks awful, the font has been replaced with some kind of Gothic script, with only the character outlines visible.

I can also confirm your findings about new table creation - the contents are displayed normally. Not sure what to do about this then.
Comment 8 Alex Thurgood 2014-07-30 13:46:53 UTC
What is certain is that I don't have the Ubuntu font on OSX.
Comment 9 Julien Nabet 2014-10-12 06:54:59 UTC
Alex: if we can't reproduce this by creating a new table, what about putting WFM for the moment? Of course, we may reopen this tracker if we find a way to reproduce it.
Comment 10 Alex Thurgood 2015-01-03 17:41:01 UTC
Adding self to CC if not already on
Comment 11 Alex Thurgood 2015-01-26 10:48:00 UTC
In accordance with comment 9