Bug 81603 - PRINTING: in some case collate option doesn't work in booklet mode
Summary: PRINTING: in some case collate option doesn't work in booklet mode
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-21 13:40 UTC by Paolo Benvenuto
Modified: 2015-06-10 08:01 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
test case (60.02 KB, application/vnd.oasis.opendocument.text)
2014-07-23 14:02 UTC, Paolo Benvenuto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paolo Benvenuto 2014-07-21 13:40:53 UTC
I'm trying to print multiple copies of an A5 document on A4 paper using booklet (depliant) mode with two-sides printing active

the collate option doesn't work any more: either selecting or unselecting it, I get the same uncollated result.

For example, 8 pages document, printing 2 copies:

1st sheet, front: pages 8,1
1st sheet, rear : pages 8,1
2nt sheet, front: pages 2,7
2nd sheet, rear : pages 2,7
3rd sheet, front: pages 6,3
3rd sheet, rear : pages 6,3
4th sheet, front: pages 4,5
4th sheet, rear : pages 4,5

The result should be:

1st sheet, front: pages 8,1
1st sheet, rear : pages 2,7
2nt sheet, front: pages 6,3
2nd sheet, rear : pages 4,5
3rd sheet, front: pages 8,1
3rd sheet, rear : pages 2,7
4th sheet, front: pages 6,3
4th sheet, rear : pages 4,5
Comment 1 sophie 2014-07-23 12:35:00 UTC
Hi Paolo, could you provide your document so we don't have to create from scratch to reproduce the problem? thanks - Sophie
Comment 2 Paolo Benvenuto 2014-07-23 14:02:13 UTC
Created attachment 103337 [details]
test case

test case

Reproduce it:
- open the doc
- file - print
- se copies numeber to 2
- OK

But printing doesn't trigger the bug in these cases:
- file - print and I click the properties dialog and I close it with the OK button and then I print
- I modify extensively the document before printing it
Comment 3 Paolo Benvenuto 2014-08-30 14:07:06 UTC
Apparently fixed in 4.3.1.2
Comment 4 Paolo Benvenuto 2014-08-30 14:29:11 UTC
I was wrong: still present in 4.3.1.2
Comment 5 Joel Madero 2014-11-04 04:06:58 UTC
Never confirmed by QA - moving to UNCONFIRMED
Comment 6 Buovjaga 2014-11-16 10:06:04 UTC
What printer do you have and what Linux distro? Does it print to PDF ok (it does for me on Windows)?

Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 7 QA Administrators 2015-06-08 14:29:19 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least
6 months. Please provide the requested information as soon as
possible and mark the bug as UNCONFIRMED. Due to regular bug
tracker maintenance, if the bug is still in NEEDINFO status with
no change in 30 days the QA team will close the bug as INVALID
due to lack of needed information.

For more information about our NEEDINFO policy please read the
wiki located here:
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Status/NEEDINFO

If you have already provided the requested information, please
mark the bug as UNCONFIRMED so that the QA team knows that the
bug is ready to be confirmed.
 
Thank you for helping us make LibreOffice even better for everyone!

This NEEDINFO Message was generated on: 2015-06-08

Warm Regards,
QA Team
Comment 8 Paolo Benvenuto 2015-06-10 08:01:34 UTC
apparently fixed in 4.4.2.2 40m0 ubuntu