Download it now!
Bug 81629 - Named cell ranges corruption
Summary: Named cell ranges corruption
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-22 02:36 UTC by helplibreoffice
Modified: 2016-02-04 17:18 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description helplibreoffice 2014-07-22 02:36:56 UTC
Named ranges of cells get easily corrupted.

To replicate:
1) Open LO Calc with a new spreadsheet
2) Using menus, go to Insert->Names->Manage
3) Press 'Add' in Manage Names dialog box
4) In Name field, enter anything you want
5) In Range field, enter 'Sheet1.A$1:A$1048576' (exactly, without quotes)
6) Press 'Add' in Define Name dialog box
7) Press 'Add' in Manage Names dialog box
8) In Name field, enter anything you want
9) In Range field, enter 'Sheet1.B$1:B$1048576' (exactly, without quotes)
10) Press 'Add' in Define Name dialog box
11) Press 'Add' in Manage Names dialog box
12) In Name field, enter 'Problems' (without quotes)
13) In Range field, enter 'Sheet1.C$1:C$1048576' (exactly, without quotes)
14) Press 'Add' in Define Name dialog box
15) Press 'OK' in Manage Names dialog box
16) Select cell B1
17) Ignoring the logic of the function, enter =IF(Problems>0,A2-TODAY(),"x")
18) Using menus, go to Insert->Names->Manage
19) Notice that the ranges you previously defined have been corrupted and are now pointing to different cells than you specified in steps 2-15

Happens every time.

If functions depend on the range names, all cells depending on those range names in the all related spreadsheets will be erroneous.

Time spent isolating this bug: 6 hours.
Comment 1 Joel Madero 2014-07-22 02:53:17 UTC
First - thanks so much for the awesome instructions, really really appreciated from our side.

That being said:
Confirmed
Ubuntu 14.04 x64
LibreOffice 4.3.0.2 rc as well as 3.3

*This bug was inherited from OOo therefore updating version, version is the oldest version that we can confirm the problem.

Priority:
Agree that it's major (loss of data)
high - default for major, seems fine

cc'ing Markus - Markus I thought I remember you doing some stuff with named ranges in the past, thought this might interest you
Comment 2 helplibreoffice 2014-07-22 03:40:25 UTC
You are welcome.  Glad it's appreciated.  I'm exhausted.  Thanks for the verification on Ubuntu and the version number explanation.
Comment 3 QA Administrators 2015-09-04 02:49:39 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.0.5 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 

4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-09-03
Comment 4 Arul Michael 2016-02-02 13:29:37 UTC
Following patch has been submitted as a fix for this issue
https://gerrit.libreoffice.org/#/c/22029/

Thanks
Comment 5 Markus Mohrhard 2016-02-02 23:30:28 UTC
There is no bug here. The references are relative to the selected cell as they would be if you use them in the current cell.

How do you want to handle that problem?