Bug Hunting Session
Bug 81789 - unpredictable "Places" Dialog - WebDAV, remote connections
Summary: unpredictable "Places" Dialog - WebDAV, remote connections
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.8.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard: needsWebDAV
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-26 17:36 UTC by Obiwan72
Modified: 2016-02-15 22:53 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
webdav (137.96 KB, application/pdf)
2015-03-16 18:35 UTC, raal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Obiwan72 2014-07-26 17:36:28 UTC
It is difficult to create a new WebDAV "place" under "places". I have to try many times until the WebDAV "place" works. The little dialog window where it is possible to enter the WebDAV connection properties doesn't seems to store the entered data the way it was entered. After saving the entry, exiting and reopening, the "Host" field shows a different property and same for path. After repeating it many time, suddenly the WebDAV place works. I still don't understand why... But at least I am able to store the WebDAV place succesfully (after going through a long try and error excercise). I think this dialog deserves some attention and thorough bugfixing. Professional grade users using Libreoffice in a network environment may get quite annoyed.
Comment 1 raal 2015-03-16 18:35:35 UTC
Created attachment 114136 [details]
webdav

Hello,
please take a look at the attachment. First page is how to create places shortcut to webdav. I think you describe problem on page 2? Am I right?
Comment 2 Obiwan72 2015-03-16 19:02:01 UTC
Hi, yes it was something among these lines - the parameters were split as outlined by your screenshots.
I wouldn't have a problem with the splitting. But the (correct) URL I entered didn't work. I had to repeat many times until it suddenly worked.

For example I pasted following URL into the Path field of the 2nd dialog:
https://document.servername.com/owncloud/remote.php/webdav
...and then hit OK to return to the 1st dialog window.

When trying to connect it will show following error:
"http://document.servername.com/https://document.servername.com/owncloud/remote.php/webdav does not exist"

Then I want to correct it by doubleclicking on the Webdav connection (open the 2nd dialog). The path field would show an entry that is different than what the error dialog has shown:
/https://document.servername.com/owncloud/remote.php/webdav

Then I remove the "/" at the beginning of the string and click on OK in the second dialog, thinking that now there is a correct Path in the "Path"-field... 

Back in the 1st dialog I click on the webDAV connection attempting to access the webDAV share. But again, it would show the same error message with a messed up URL as above, as if it didn't store the updated path.

Also, if the name of the WebDAV connection is updated in the "name" field of the 2nd dialog, then after hitting OK and returning to the first dialog, the new name is not shown immediately. Only after the 1st dialog is closed too and re-opened it would display the updated WedDAV connection name.

I hope this is understandable. Please shout if more infos needed.

Thank you. :-)
Comment 3 Robinson Tryon (qubit) 2015-09-02 20:45:48 UTC
Looks like q's were answered, so I'm going to put this back into UNCONFIRMED for now.
Comment 4 tommy27 2015-09-19 06:13:32 UTC
CC'ing Beppe Castagno who's a WebDav expert
any ideas about this one?
Comment 5 tommy27 2015-09-19 06:14:13 UTC
@ Obiwan72 
please tell your LibO version and Linux distro
Comment 6 Obiwan72 2015-09-19 07:34:42 UTC
Hi tommy27

These are the current versions.
LibreOffrice: 4.2.8.2, build id: 420m0(Build:2)

Linux RVGHQWS1 3.13.0-63-generic #103-Ubuntu SMP Fri Aug 14 21:42:59 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
Comment 7 Buovjaga 2015-09-19 07:45:55 UTC
Obiwan72: You should try with 5.0.1
You can get it for your Ubuntu from this ppa: https://launchpad.net/~libreoffice/+archive/ubuntu/ppa
Comment 8 tommy27 2016-02-14 09:28:27 UTC
please retest with 5.1.0.3
some work has been done on WebDAV.
did it improve the situation?
Comment 9 Obiwan72 2016-02-14 10:10:38 UTC
(In reply to tommy27 from comment #8)
> please retest with 5.1.0.3
> some work has been done on WebDAV.
> did it improve the situation?

I will retest asap. Need to download and install first.
Comment 10 Obiwan72 2016-02-15 20:51:47 UTC
(In reply to tommy27 from comment #8)
> please retest with 5.1.0.3
> some work has been done on WebDAV.
> did it improve the situation?

I have tested it with 5.1.0.3 now and I was able to setup my owncloud WebDAV server connection without any issues or glitches. This functionality is well fixed and greatly enhanced (now with the possibility to add some more servers like Alfresco, Sharepoint, Lotus etc...) which makes it as easy as never before to integrate LibreOffice into a professional work environment. Great job well done! Thank you.
Comment 11 steve -_- 2016-02-15 22:53:13 UTC
Since we do not have a commit fixing this, the correct status is worksforme. adjusting accordingly.

@Obiwan72: thanks for the test and your feedback. that's great news (: