Bug Hunting Session
Bug 81817 - "file cannot be opened" when trying to insert an image from a webDAV source
Summary: "file cannot be opened" when trying to insert an image from a webDAV source
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: needsWebDAV
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-27 19:43 UTC by Obiwan72
Modified: 2015-03-16 19:13 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot: LibreOffice insert image dialog, displaying WebDAV folder (231.58 KB, image/png)
2014-07-27 19:43 UTC, Obiwan72
Details
screenshot (135.70 KB, application/pdf)
2015-03-16 17:30 UTC, raal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Obiwan72 2014-07-27 19:43:55 UTC
Created attachment 103558 [details]
screenshot: LibreOffice insert image dialog, displaying WebDAV folder

OS: Ubuntu 14.04 (64-bit)
LibreOffice: 4.2.4.2
WebDAV by: ownCloud

Problem description:
1) create new text document
2) goto Insert->Image->From File
3) click on WebDAV source and navigate to the webDAV folder containing the image
4) click on the image and then on the "open" button
5) error message: "Image file cannot be opened"
I have no idea why that doesn't work. Also the preview function is slow and partially doesn't work (most images don't show up in the preview) even though my workstation is connected with a Gigabit ethernet cable to the server. Normal WebDAV file access like opening and saving LibreOffice documents seems to be working well so far.

Workaround:
Open the image in a browser and then copy it (copy/paste) into the LibreOffice Writer document. If necessary use CTRL-SHIFT-V for pasting the image (dialog box to define if bitmap or html source to be pasted).
Comment 1 raal 2015-03-16 17:30:34 UTC
Created attachment 114134 [details]
screenshot

Hello,
tested with Version: 4.4.3.0.0+
Build ID: 8106e522c4ea2ae4441ec571579a38eeb6d9af04
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:libreoffice-4-4, Time: 2015-03-13_12:39:32  and owncloud webdav. Seems to be fixed, I can see preview of the image and insert image into the document.
Closing as worksforme, if you still have problem install latest version of LO.
Comment 2 Obiwan72 2015-03-16 19:13:09 UTC
(In reply to raal from comment #1)
> Created attachment 114134 [details]
> screenshot
> 
> Hello,
> tested with Version: 4.4.3.0.0+
> Build ID: 8106e522c4ea2ae4441ec571579a38eeb6d9af04
> TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:libreoffice-4-4, Time:
> 2015-03-13_12:39:32  and owncloud webdav. Seems to be fixed, I can see
> preview of the image and insert image into the document.
> Closing as worksforme, if you still have problem install latest version of
> LO.

Thank you. I can confirm. It seems to be fixed already in 4.2.7.2. 
- Preview works
- Insert works