Bug Hunting Session
Bug 81821 - Available paper formats depend on system (CUPS) settings
Summary: Available paper formats depend on system (CUPS) settings
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevAdvice
Depends on:
Blocks: Printer-Settings
  Show dependency treegraph
 
Reported: 2014-07-27 22:13 UTC by gszymaszek
Modified: 2019-01-05 11:55 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gszymaszek 2014-07-27 22:13:17 UTC
[test printer: Samsung Xpress M2875; test OS: Debian Jessie]
When I try to print something on DL Envelope paper size, it has to be earlier configured in system-wide settings (http://localhost:631, system-config-printer, etc.). I mean, that in File->Print->[select printer]->Properties->Paper size I can't see all sizes, but only suitable with default (currently configured in CUPS) (assume that it's 'Plain') paper type. So that I can't print on DL Envelope, because it's not listed.

I have to select (assume that using system-config-printer) in Printer Options:
- page size: DL Env.,
- paper type: [thick or not] envelope.
You can see that there's condition: I can't save option [page size]=[DL Env.], if paper type isn't compatible. There was no such condition in older PPDs (eg. when trying to print DL Envelope on older Kyocera printers, there weren't such problems).

After that I restart LibreOffice and try File->Print->[select printer]. Wow. I see the magical DL Envelope. If I click Properties, then I can see all page sizes available for [thick or not] envelope paper type.

I think that it's only a workaround, because normally I need superuser permissions to change CUPS settings.

I've tried to test it on Windows, but after click on Properties, there's only configuration window from Samsung.
Comment 1 Robinson Tryon (qubit) 2015-12-18 10:37:05 UTC Comment hidden (obsolete)
Comment 2 tommy27 2016-12-21 15:35:10 UTC
please give an update of the bug status with latest LibO 5.2.3.3

set status to UNCONFIRMED if bug is still present or RESOLVED WORKSFORME if bug is gone.

NEEDINFO until then
Comment 3 gszymaszek 2017-01-10 16:00:02 UTC
It seems the bug is still there (LO 5.2.4.2.1+), but has gone worse or my
settings have changed. Currently, I can’t change the paper size nor orientation
in the printer properties dialog, regardless of selected printer (M2875, PDF or
another). Other printers just apply document’s paper size and orientation but
M2875 chooses its system-wide settings.

Steps to reproduce:

1. Install Samsung M2875 printer (just in CUPS, I think it isn’t necessary to
have an actual printer) and eg. PDF printer (may already be installed).
2. Set default options in both printers: A4 paper size and portrait orientation.
3. Create new Writer document and set page size to DL Envelope.
4. Open printing dialog. On the left there’s a preview, labelled with paper
size. PDF’s (and another physical printer’s, not the M2875) paper size is OK,
that is DL Envelope. And M2875’s paper size is still A4 (and that’s one
problem). Open printer properties — you cannot change the paper size (the second
problem).
5. Set M2875’s paper size in system-wide settings to DL Envelope.
6. Open the printing dialog again — M2875’s size is still A4. You have to
restart LO to see DL Envelope (third problem). But now it’ll be the same
regardless of your document’s paper size setting (again the first problem).
Comment 4 Thomas Hackert 2017-01-21 13:28:26 UTC
Hello gscscnd, *,
thank you for reporting this bug :) I can confirm it with

OS: Debian Testing AMD64
Printer: Samsung XPress M2070 series
CUPS: 2.2.1-4
LO: Version: 5.1.6.2
Build-ID: 07ac168c60a517dba0f0d7bc7540f5afa45f0909
CPU-Threads: 4; BS-Version: Linux 4.5; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE.UTF-8); Calc: group

and

LO: Version: 5.3.0.2
Build-ID: 5ad7b2889021c491af62f7930a4b1cb631392f16
CPU-Threads: 4; BS-Version: Linux 4.5; UI-Render: Standard; VCL: gtk2; Layout-Engine: neu; 
Gebietsschema: de-DE (de_DE.UTF-8); Calc: group

so setting status to "NEW". In both LO version, I have no choice to change the paper size nor orientation (= both options are greyed out) ... :(
Have a nice day
Thomas.
Comment 5 QA Administrators 2018-01-22 03:20:15 UTC Comment hidden (obsolete)
Comment 6 nix666 2018-02-20 12:43:15 UTC
I have experienced the same : Printing sizes are greyed out in LO 6.0.1.1 and 5.4.0.3. I installed 4.4.2.2 and the printing dialogue is back to normal and I can select the paper size.

Tested on Linux Mint 18.3 and 17.3.
Comment 7 nix666 2018-02-20 12:44:49 UTC
Please see this link : https://www.ryananddebi.com/2016/02/02/linux-libreoffice-print-dialog-orientation-greyed-out/

Seems to present for a long time already.