Download it now!
Bug 82007 - com.sun.star.system.SimpleCommandMail - Attachment ignored
Summary: com.sun.star.system.SimpleCommandMail - Attachment ignored
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-01 10:55 UTC by Helmut Seidel M.A.
Modified: 2015-07-18 17:27 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Helmut Seidel M.A. 2014-08-01 10:55:34 UTC
Hello everybody,

I use the following piece of (basic-)code to send documents from LibreOffice-Base via E-Mail. The code used to work in LibreOffice 3.x but does not in LibreOffice 4.x (I've tested it on LibreOffice 4.2 and 4.3 on Ubuntu 13.10, 14.04). The Problem is the document is not attached - though no error occurs. It's simply the attachment's gone missing.

I'm not sure whether it is actually a bug.

Thanks and regards


Here's the piece of code in question:

        ' ...
        ' Testen, ob Windows
        If GetGuiType() = 1 Then
            objMail = createUnoService("com.sun.star.system.SimpleSystemMail")
        ' Sonst Liux/Mac
        Else
            objMail = createUnoService("com.sun.star.system.SimpleCommandMail")
        End If
        ' Zugriff auf Mail-Client-Programm
        objMailClient = objMail.querySimpleMailClient()
        ' Message-Objekt erstellen
        objMessage = objMailClient.createSimpleMailMessage()
        ' Nachrichtenempfänger setzen
        objMessage.setRecipient(strEmailAddress)
        ' Betreff setzen
        objMessage.setSubject(strSubject)
        ' Aktuelles Dokument als Anhang
        mAttachment(0) = strDateiName
        objMessage.setAttachement(mAttachment())
        ' MailClient öffnen
        objMailClient.sendSimpleMailMessage(objMessage, 0)
        ' ...
Comment 1 Buovjaga 2014-11-18 12:03:58 UTC
Is it possible for you to prepare a test case Base file with the macro that can be shared publicly?

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the document.
Comment 2 QA Administrators 2015-06-08 14:29:13 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least
6 months. Please provide the requested information as soon as
possible and mark the bug as UNCONFIRMED. Due to regular bug
tracker maintenance, if the bug is still in NEEDINFO status with
no change in 30 days the QA team will close the bug as INVALID
due to lack of needed information.

For more information about our NEEDINFO policy please read the
wiki located here:
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Status/NEEDINFO

If you have already provided the requested information, please
mark the bug as UNCONFIRMED so that the QA team knows that the
bug is ready to be confirmed.
 
Thank you for helping us make LibreOffice even better for everyone!

This NEEDINFO Message was generated on: 2015-06-08

Warm Regards,
QA Team
Comment 3 QA Administrators 2015-07-18 17:27:45 UTC
Dear Bug Submitter,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INVALID due to inactivity and a lack of information which is needed in order to accurately reproduce and confirm the problem. We encourage you to retest your bug against the latest release. If the issue is still present in the latest stable release, we need the following information (please ignore any that you've already provided):

a) Provide details of your system including your operating system and the latest version of LibreOffice that you have confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED and we will attempt to reproduce the issue. 
Please do not:
a) respond via email 
b) update the version field in the bug or any of the other details on the top section of FDO

Message generated on: 2015-07-18