Bug 82189 - BUGZILLAASSISTANT: "older version" wrongly transferred to Bugzilla
Summary: BUGZILLAASSISTANT: "older version" wrongly transferred to Bugzilla
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: WWW (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-05 12:14 UTC by Bugcruncher
Modified: 2014-08-06 16:03 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
screenshot (140.19 KB, image/png)
2014-08-05 12:14 UTC, Bugcruncher
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bugcruncher 2014-08-05 12:14:43 UTC
Created attachment 104068 [details]
screenshot

Problem description: 
If in the Assistant for "Version the bug appeared" "older versions" has been selected, with "SUBMIT an error message "There is no version named 'older versions' in the LibreOffice project.

Steps to reproduce:
1. Launch Bug Submission Assistant, create a mimum bug report 
   with "older versions" for "Version the bug appeared"
2. Click SUBMIT button
   » Error message as described will appear

An appropriate Version will have to be created for this selection, so that still existing bugs what started in an older version can be reported.
Operating System: Windows 7
Version: 4.4.0.0.alpha0+ Master
Comment 1 Joel Madero 2014-08-06 02:00:03 UTC
This is expected and that's why you get the following when you select "older version"

[QUOTE]
The Document Foundation is no longer supporting this version of LibreOffice as it has reached its End of Life. We encourage you to update to a new release and see if your bug is still present:
[/QUOTE]

And you get links to get newer versions for each operating system.

We don't want users continuing to report bugs against versions that are EOL because many of these are resolved in supported versions and we don't have the man power to keep wasting time marking bugs as WORKSFORME because the issue is resolved in a newer release.

Marking as NOTABUG.
Comment 2 Bugcruncher 2014-08-06 13:20:15 UTC
(In reply to comment #1)
This comment is wrong².. Simply reading the UI you can see that that field is concerning the version where the problem appeared, not concerning some information what Version might be "supported" or what version the user actually might use. If you want to see with what last Version reporter observed the problem you can add such a field to Bugzilla (AOO Issuezilla has it) or you can add a selector to the Assistant what will add a string to the Report text like "last seen with Version <SelectorContents>"

And also you should explain why there is no selection item for the Versions "Inherited from OOo" (and some others).

Additionally even if LibO staff would do such a nonsense, the nonsense should be done some more user friendly, what means the message should be visible after "Submit" and not be hidden at the invisible top of the page.

And you should explain why you did not find any better message than the original Bugzilla message, what simply tells that the Bugzilla Database does not accept the transferred Version for that Product. 

And it  is  not wasting time to check whether a bug (reported with information with what old version the bug appeared) still does exist in current versions (if reporter forgot to tell, because LibO staff thoughtless did not ask in assistant)

Good grief, Using Libreoffice is not good for me with my high blood pressure. I should save my time for more pleasurable avocation than reporting Bugs here.



--

2: to avoid the word "nonsense"
Comment 3 beimaginativeegroup 2014-08-06 16:03:18 UTC
Can you explain more clearly what solutions do you think would be better?