Bug 82229 - "NaN" instead of percentage values with some locales (Ubuntu 12.04 + PPA / Debian backports only)
Summary: "NaN" instead of percentage values with some locales (Ubuntu 12.04 + PPA / De...
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 83757 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-08-06 07:31 UTC by Antanas
Modified: 2014-11-26 08:15 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot of the Tools>Options window (90.93 KB, image/png)
2014-08-06 07:31 UTC, Antanas
Details
Wheezy-backports dependences (8.98 KB, text/plain)
2014-10-11 09:06 UTC, Alexandr
Details
Jessie dependences (9.66 KB, text/plain)
2014-10-11 09:10 UTC, Alexandr
Details
different unit separators (21.48 KB, image/png)
2014-11-25 08:10 UTC, Rico Tzschichholz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Antanas 2014-08-06 07:31:05 UTC
Created attachment 104131 [details]
Screenshot of the Tools>Options window

Go to menu: Tools>Options>LibreOffice>View.
'User Interface.Scaling' field as well as 'Selection.Transparency' field allways show "NaN" (Not a Number?) despite what you enter there. Entered values still affects GUI view as expected.
Comment 1 Maxim Monastirsky 2014-08-06 12:40:04 UTC
New bug should start as UNCONFIRMED, until someone else confirm it.

I'm not able to reproduce with 4.3.0.4 under Fedora 20.
Comment 2 Antanas 2014-08-06 15:19:07 UTC
mariosv, Maim, 
thanks both for corrections.

The bug appears on two machines, both still running Ubuntu 12.04.5 LTS.
LO installation from https://launchpad.net/~libreoffice/+archive/ubuntu/ppa
I just purged LO, removed directory ~/.config/libreoffice and did fresh install of LO – Version: 4.3.0.4 Build ID: 430m0(Build:4). 
The bug persists.
Comment 3 Julien Nabet 2014-08-06 21:02:22 UTC
For the test, could you rename your LO directory profile and give it a new try?
(see https://wiki.documentfoundation.org/UserProfile#GNU.2FLinux)
Comment 4 Julien Nabet 2014-08-06 21:02:57 UTC
Forgot to say I don't reproduce this either on pc Debian x86-64 with 4.3 sources updated some days ago.
Comment 5 Antanas 2014-08-07 05:28:41 UTC
Julien and all,

thanks for responses.
I did some research: the bug disappears when I switch Ubuntu system language to English (my preference is Lithuanian).
Should I mark the bug as RESOLVED and forward it to Ubuntu? 
Or there still is a LO bug appearing in particular circumstance?
Comment 6 Julien Nabet 2014-08-07 06:15:42 UTC
I switched LO to Lithuanian UI (on pc Debian x86-64 with master sources updated yesterday), I don't reproduce the problem.

Andras: should we put this one "NOTOURBUG" since it could be indeed an Ubuntu bug?
Comment 7 Peter Harde 2014-08-17 06:41:29 UTC
I updated LO to 4.3.0.4 (Build 4) yesterday and I confirm this bug. I am working with Ubuntu 12.04.5 LTS, language set to german for the operating system and for LibreOffice. Not only the dialogs show the NaN but also the field for the actual magnification in the lower right corner of the main window of Writer or Calc.
Comment 8 Maxim Monastirsky 2014-08-17 16:13:24 UTC
Reproducible with Russian locale under Ubuntu 12.04.5, but not under Ubuntu 14.04.1. In both cases used the build from ppa:libreoffice/ppa. Note that this depends on the system locale, not on LO UI language.
Comment 9 Maxim Monastirsky 2014-09-12 08:23:07 UTC
*** Bug 83757 has been marked as a duplicate of this bug. ***
Comment 10 Maxim Monastirsky 2014-09-12 08:27:26 UTC
Also affects other places where percentage values supposed to show (see Bug 83757 for examples). Not reproducible with the packages from libreoffice.org, only with the ones from the PPA.
Comment 11 ign_christian 2014-09-12 13:53:22 UTC
Not occured with LO 4.2.6.3 from PPA under Ubuntu 12.04 x86, system locale: English US
Comment 12 Antanas 2014-09-13 20:04:51 UTC
Ign Christian,

(In reply to comment #11)
> Not occured with LO 4.2.6.3 from PPA under Ubuntu 12.04 x86, system locale:
> English US

Indeed, the bug is observed in non-english locales only.
Comment 13 Alexandr 2014-09-19 17:29:00 UTC
Hello.
I reproduce the bug with LibreOffice 4.3.1.2 from Debian Wheezy backports with i386 and amd64 architecture. I do not reproduce it with upstream or Jessie build on Jessie.
I use Russian locale.

Rene, I add you to cc list, because it seems to be Debian/Ubuntu specific
Comment 14 Pal'o 2014-09-22 15:59:40 UTC
I do not agree with dependency on Debian/Ubuntu - I think it iss problem with something in some older version of required library. I have Fedora 14 (self-updated with some of the development/rawhide packages, versions below) with Slovak locale and the bug is present here, too.

glibc-2.18-12.0.fc14.x86_64
nspr-4.10.7-1.0.fc14.x86_64
nss-3.17.0-2.0.fc14.x86_64
openssl-1.0.1h-6.0.fc14.x86_64
gcc-4.8.2-7.0.fc14.x86_64

(more package versions can be provided if requested)
Comment 15 Marcin M. 2014-10-10 09:45:24 UTC
Installed Fedora 14, locale set to Polish, downloaded the same version of LibreOffice and this bug still persists. It's definitely not Debian/Ubuntu specific. It applies to many places in UI (zoom, opacity settings, image properties) of Libreoffice in all of its parts (Writer, Calc, Impress, Draw). I think it has something to do with locales like Polish where a decimal separator is not a period but a comma.
Comment 16 Olibuntu 2014-10-10 12:03:52 UTC
The bug is present in LO
Version: 4.3.2.2
Build-ID: 430m0(Build:2)
from the Ubuntu PPA for 12.04 32-bit, locale: German

Do you need any other information?
Comment 17 Julien Nabet 2014-10-10 21:40:18 UTC
On pc Debian x86-64 with LO 4.3.2.2 Debian package, I don't reproduce this with French, German or Spanish (UI + local).

apt-cache show libc6 gives:
Package: libc6
Source: glibc
Version: 2.19-11

Indeed nan function is present in glibc (see http://man7.org/linux/man-pages/man3/nan.3.html)

It could be interesting to know if those who reproduce the problem have glibc < 2.19 and those who don't reproduce have glic >= 2.19
Any counter example?
(of course perhaps I'm misleading...)

Michael/Bjoern: thought you might be interested.
Comment 18 Björn Michaelsen 2014-10-10 23:24:46 UTC
(In reply to Julien Nabet from comment #17)
> Michael/Bjoern: thought you might be interested.

From the feedback, this looks like NOTOURBUG to me as it only seems to happen with backports (see Comment 8). This suggests a some of the scaling (which is relativly recently changed for HiDPI support) needs more recent libraries as dependencies.

We would need to know which system library update between 12.04 and 14.04 "fixed" this[1] => NEEDINFO

[1] Note this doesnt mean we will be sure to be able to fix that -- while we might backport some libs in a ppa, for most we wont be able to backport to Ubuntu 12.04/Fedora 14/Other ancient distro.
Comment 19 Olibuntu 2014-10-11 07:00:42 UTC
(In reply to Olibuntu from comment #16)
> The bug is present in LO
> Version: 4.3.2.2
> Build-ID: 430m0(Build:2)
> from the Ubuntu PPA for 12.04 32-bit, locale: German

Package: libc6
Source: eglibc
Version: 2.15-0ubuntu10.7
Comment 20 Alexandr 2014-10-11 09:06:42 UTC
Created attachment 107704 [details]
Wheezy-backports dependences

> I reproduce the bug with LibreOffice 4.3.1.2 from 
> Debian Wheezy backports with i386 and amd64 architecture.

Libc6 version: 2.13-38+deb7u4

I attach all LibreOffice dependences in case the issue is caused by another library.
Comment 21 Alexandr 2014-10-11 09:10:31 UTC
Created attachment 107705 [details]
Jessie dependences

> I do not reproduce it with Debian Jessie package.

Libc6 version: 2.19-7
Comment 22 Antanas 2014-10-12 09:41:00 UTC
Now I'm using fresh install of Ubuntu 14.04.1
LibreOffice 4.3.2.2
Libc6 varsion 2.19-0ubuntu6.3

The problem is gone.
Comment 23 Julien Nabet 2014-10-12 09:54:36 UTC
So it seems that the bug appears only for those having glibc < 2.19.
Don't hesitate to reopen this tracker if I'm wrong.
Comment 24 Rene Engelhard 2014-10-13 07:23:51 UTC
fwiw, I made the next debian packages gehttp://anonscm.debian.org/cgit/pkg-openoffice/libreoffice.git/commit/?id=0af472decd4508d58680dda29665ec28c74cbdfct
Comment 25 Pal'o 2014-10-19 13:00:52 UTC
Updating to glibc-2.19 does not solve the issue, nor recompiling libreoffice-4.3.2 in environment using glibc-2.19
Comment 26 Peter Harde 2014-10-30 08:51:45 UTC
Just updated to LO 4.3.3 on Ubuntu 12.04.5, german locale, libc6 version 2.15-0ubuntu10.7. The bug is still present and concerns all entries in all dialogs of all parts of LO which use the unit %.
Comment 27 Javier Puche 2014-10-30 11:10:19 UTC
Just in case it helps:

 In ubuntu 12.04-5 based distro, if I set:
export LC_ALL=
export LANG=wrong
lowriter

 It will open up in English but it will let me change default language to Spanish (not Default: Spanish)  and afterwards it will work ok in Spanish without the NaN problem.
 
 I hope it gets solved soon.
Comment 28 Javier Puche 2014-10-31 11:56:44 UTC
LANG=C  will also do, then changing Preferences is needed only on first run.

 I have analysed differences between two Ubuntu 12.04-5 based systems, one with LO 4.2.2.3 without the problem and another with LO 4.3.1.2 with it.

The difference between the who systems (minimal updating from first one to the second)

libboost-iostreams1.54.0 libboost-system1.54.0 libcdr-0.1-1 libglew1.10
libmspub-0.1-1 librevenge-0.0-0 libvisio-0.1-1 libwpd-0.10-10 libwpg-0.3-3
libwps-0.3-3

libreoffice libreoffice-base libreoffice-base-core libreoffice-base-drivers
libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw
libreoffice-gnome libreoffice-gtk libreoffice-impress
libreoffice-java-common libreoffice-math libreoffice-style-galaxy
libreoffice-style-human libreoffice-writer python-uno uno-libs3 ure

 Just in case it gives hints on what component might be triggering the NaN behaviour.
Comment 29 Javier Puche 2014-11-03 09:00:21 UTC
Well, I installed LibreOffice 4.3.3 downloaded from libreoffice.org and this time it works fine without the NaN problem.
Comment 30 Olibuntu 2014-11-03 14:01:29 UTC
(In reply to Javier Puche from comment #29)

For me, the bug is still present in Version: 4.3.3.2, Build-ID: 430m0(Build:2) installed from the PPA on a fully updated Mint 13 Xfce (i.e., Ubuntu 12.04).
Comment 31 Joel Madero 2014-11-04 04:05:42 UTC
Never confirmed by QA team - moving to UNCONFIRMED.
Comment 32 Maxim Monastirsky 2014-11-04 07:51:08 UTC
(In reply to Joel Madero from comment #31)
> Never confirmed by QA team - moving to UNCONFIRMED.
Hmm, Actually there are several confirmations in this bug (including from me in comment 8). Moving back to NEEDINFO, since we need to identify which library is causing this bug (see comment 18).
Comment 33 Marcin M. 2014-11-04 12:12:25 UTC
Installed fresh LO (Wersja: 4.3.2.2 Build ID: 430m0(Build:2) ), Ubuntu 12.04 fully updated - bug still exists. What kind of information should I provide to help with this bug?
Comment 34 Pal'o 2014-11-04 12:40:36 UTC
I have the NaN problem and my versions of mentioned libs are:

boost-iostreams-1.55.0
boost-system-1.55.0
libcdr-0.1.0
libGLEW-1.10.0
libmspub-0.1.1
librevenge-0.0.1
libvisio-0.1.0
libwpd-0.10.0
libwpg-0.3.0
libwps-0.3.0

and of course libreoffice-4.3.2.2
Comment 35 Björn Michaelsen 2014-11-04 14:22:51 UTC
This bug would benefit from trying to bisection. Note that the bug is likely not in LibreOffice itself, but in an outdated library/dependency.As this bug happens on multiple distros, but does not happen on recent releases for most, it would be most helpful to find:
- which version was the last release of Ubuntu, where this was broken? Which one was the first, were it works?
- which version was the last release of Fedora, where this was broken? Which one was the first, were it works?
- etc.
Comment 36 Peter Harde 2014-11-05 07:15:46 UTC
(In reply to Björn Michaelsen from comment #35)
On my System (german locale) the bug is reproducible :
  Linux 3.5.0-54-generic
  #81~precise1-Ubuntu SMP Tue Jul 15 04:05:58 UTC 2014
  Ubuntu 12.04.5 LTS precise
  unity 5.20.0
fully updated, with the latest version of LibreOffice :
  4.3.3~rc2-0ubuntu1~precise1
I do not know, if this is the last release of Ubuntu where the bug is present. I cannot upgrade my System because newer kernel versions do no longer support my old hardware. Please let me know if you need detailed information about the versions of installed libraries.
Comment 37 Runakuna 2014-11-05 20:44:48 UTC
The bug is present (spanish locale):

Debian Wheezy 7.7
Linux 3.2.0-4-686-pae #1 SMP Debian 3.2.63-2+deb7u1 i686 GNU/Linux
Mate Desktop 1.8.1
LibreOffice 4.3.2.2.0
libc6 2.13-38
Comment 38 Pal'o 2014-11-06 07:08:31 UTC
Finally I've found it.
The problematic library is icu - after upgrading from icu-4.6 to icu-53.1 and recompiling the dependencies (boost, harfbuzz, libcdr, libe-book, libmspub, libvisio, raptor and of course libreoffice) the problem is gone.
Comment 39 Björn Michaelsen 2014-11-06 09:27:54 UTC
(In reply to Pal'o from comment #38)
> Finally I've found it.
> The problematic library is icu - after upgrading from icu-4.6 to icu-53.1
> and recompiling the dependencies (boost, harfbuzz, libcdr, libe-book,
> libmspub, libvisio, raptor and of course libreoffice) the problem is gone.

And with that closing this one as NOTOURBUG here, as TDF releases bundle a proper icu.
Comment 40 Rene Engelhard 2014-11-06 10:43:07 UTC
but then configure should still check for a working icu so you don't un into this at all.
Comment 41 Eike Rathke 2014-11-06 12:41:25 UTC
For the records, I tried with icu-50.1 and LANG=de_DE.UTF-8 LC_ALL=de_DE.UTF-8 (selecting a default German UI according to comment 7 and comment 16) and LANG=es_ES.UTF-8 LC_ALL=es_ES.UTF-8 (selecting a default English UI because Spanish not installed) and could not reproduce.
Comment 42 Javier Puche 2014-11-12 14:26:06 UTC
Hello again,

 Ok, in our Ubuntu 12.04-5 based distro with libicu48 ppa's libreoffice 4.3.3.2 has the NaN but LibreOffice 4.3.3.2 downladed from libreoffice.org will not show NaN  , in both cases the system with libicu48 (4.8.1.1-13+nmu1~precise1),  so I guess the problem is at compile time, isn't it?

Thanks.
Comment 43 Javier Puche 2014-11-12 14:38:19 UTC
Sorry, I see now that you wrote:

 "TDF releases bundle a proper icu"

 So everything is clear now. Thanks. Regards.
Comment 44 Björn Michaelsen 2014-11-12 15:18:45 UTC
(In reply to Javier Puche from comment #43)
> Sorry, I see now that you wrote:
> 
>  "TDF releases bundle a proper icu"
> 
>  So everything is clear now. Thanks. Regards.

For the ppa, the easiest solution would thus be to comment out the line:

http://anonscm.debian.org/cgit/pkg-openoffice/libreoffice.git/tree/rules?h=ubuntu-utopic-4.3&id=b98ef4867c9bc8461f39a77cf4784af7fdcb2073#n203

saying:
SYSTEM_STUFF += icu

and rebuilding ./debian/control for the next upload of 12.04 backports. Maybe Rico can take care of that (https://launchpad.net/~ricotz).
Comment 45 Rico Tzschichholz 2014-11-24 21:50:57 UTC
(In reply to Björn Michaelsen from comment #44)
> For the ppa, the easiest solution would thus be to comment out the line:
> 
> http://anonscm.debian.org/cgit/pkg-openoffice/libreoffice.git/tree/
> rules?h=ubuntu-utopic-4.3&id=b98ef4867c9bc8461f39a77cf4784af7fdcb2073#n203
> 
> saying:
> SYSTEM_STUFF += icu
> 
> and rebuilding ./debian/control for the next upload of 12.04 backports.
> Maybe Rico can take care of that (https://launchpad.net/~ricotz).

Not really possible without a full source tarball in ubuntu. The "external" source tarball does not include all needed libraries, e.g. icu.
Comment 46 Peter Harde 2014-11-25 07:56:46 UTC
Just updated to LO Version 4.3.4.1  430m0(Build:1)
4.3.4~rc1-0ubuntu1~precise1
(german locale)

Linux 3.5.0-54-generic
  #81~precise1-Ubuntu SMP Tue Jul 15 04:05:58 UTC 2014
  Ubuntu 12.04.5 LTS precise
  unity 5.20.0

The NaN-bug is still present !
Comment 47 Rico Tzschichholz 2014-11-25 08:10:32 UTC
Created attachment 109989 [details]
different unit separators

I would not fully blame older ICU here. I am seeing an issue using 4.3.4.1 with ICU 52.1 here which indicates that the used unit separators are different and likely the cause of the broken "percentage" fields with an older ICU.

The attached screenshot shows the visual character issue.
Comment 48 Alexandr 2014-11-25 12:23:13 UTC
> I would not fully blame older ICU here.

Anyway, the issue was fixed in Debian Wheezy backports (thank you, Rene) in version 4.3.3~rc2-1~bpo70+1.

Information from changelog.Debian:

libreoffice (1:4.3.3~rc2-1~bpo70+1) wheezy-backports; urgency=medium

  * Rebuild for wheezy-backports.

  * debian/rules:
    - comment out some conditionals as they don't exactly do what we want
      on wheezy-backports and use hardcoded values
    - fix coinmp conditional, use internal one on wheezy...
    - use internal icu -
      see https://bugs.freedesktop.org/show_bug.cgi?id=82229#c38

  * debian/rules, debian/shlibs.local.coin: add shlibs.local.coin to override
    all the internal coin dynamic libraries....
  * debian/rules, debian/shlibs.local.libc: revert libc 2.19 hack
  * debian/shlibs.override.icu: update to actual current SOVERSION

 -- Rene Engelhard <rene@debian.org>  Thu, 06 Nov 2014 16:49:34 +0100
Comment 49 Rico Tzschichholz 2014-11-25 19:08:04 UTC
(In reply to Peter Harde from comment #46)
> Just updated to LO Version 4.3.4.1  430m0(Build:1)
> 4.3.4~rc1-0ubuntu1~precise1
> (german locale)
> 
> Linux 3.5.0-54-generic
>   #81~precise1-Ubuntu SMP Tue Jul 15 04:05:58 UTC 2014
>   Ubuntu 12.04.5 LTS precise
>   unity 5.20.0
> 
> The NaN-bug is still present !

I uploaded 4.3.4~rc1-0ubuntu1~precise2 which works around this issue.
Comment 50 Peter Harde 2014-11-26 08:15:29 UTC
(In reply to Rico Tzschichholz from comment #49)
> I uploaded 4.3.4~rc1-0ubuntu1~precise2 which works around this issue.

I confirm, in this version the issue is gone. Thank you, Rico.