Bug 82251 - EDITING: Crash Draw upon past of graphic
Summary: EDITING: Crash Draw upon past of graphic
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
(earliest affected) release
Hardware: x86 (IA32) Windows (All)
: high critical
Assignee: Not Assigned
Whiteboard: BSA
Depends on:
Reported: 2014-08-06 14:59 UTC by Rui
Modified: 2016-04-29 03:17 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:

Network Diagram that causes crash (48.35 KB, application/vnd.oasis.opendocument.graphics)
2014-08-07 15:22 UTC, Rui

Note You need to log in before you can comment on or make changes to this bug.
Description Rui 2014-08-06 14:59:51 UTC
Highlight a graphic and press Ctrl-c to copy then Ctrl-v to Paste move the pasted graphic then Press Ctrl-v to make a second copy and move the second copy and it crashes. File was originally a MS Vision file saved to a Draw odg file.

Does not happen if I make a copy save and close the file the open it and make another copy.

Operating System: Windows 7
Version: release
Comment 1 Julien Nabet 2014-08-06 21:00:59 UTC
On pc Debian x86-64 with 4.3 sources updated some days ago, I don't reproduce this. However, I must recognize I just created a simple draw to try.

Would it be possible you attach a file so we can try to reproduce this?
Comment 2 Rui 2014-08-07 15:22:12 UTC
Created attachment 104233 [details]
Network Diagram that causes crash

Notice the two unlabeled items at bottom that look like a rack server. Those were copied from the original and they are the ones that when pasted twice made draw crash. so copy the original with the label.
Comment 3 Julien Nabet 2014-08-09 05:38:59 UTC
I don't reproduce this but when I copy the graphic, I just have the border of it, not the whole content.
Comment 4 Ares Starčić 2014-08-14 07:51:51 UTC
Can you try copy pasting a new document, since I've had problems with THAT. On Win8 x64 onlyy, on my Mac it works without a problem...
Comment 5 ign_christian 2014-08-14 09:06:46 UTC
Not reproducible with LO - Ubuntu 12.04 x86. 

But I notice that operations a little bit slow / laggy, also happen while open that file.

Perhaps Windows only as Bug 82600
Comment 6 Sun 2014-08-21 08:30:07 UTC
I have the similar problem. To reproduce, just select an object and move it, Draw will crash. Here are different conditions:

Crash: While moving (hold the left mouse button and move the object around), in about 5~10 sec, Draw will crash. 

Not Crash: But if you just move to a fix place (not moving, but still holding the left mouse button), Draw will not crash for a long time (>60 sec.)

Crash:  Move the object in the attached file, Draw will crash.

Not Crash:  If just moving a simple object, like a rectangle, Draw will not crash.

Hope this will help to reproduce the issue.

(Note: I can't make the attachment work for some reason, I put the test file on the Google drive. Here is the link:
https://drive.google.com/file/d/0BxFIZ2EIH0kHSFlHQ19hR18yWGc/edit?usp=sharing )
Comment 7 Florian Reisinger 2014-09-04 13:13:18 UTC
Tested with Windows 7 x64 with Version: Build ID: 5ef4bdc7b15686e55fa19f2e98a828763a0cfae6 TinderBox: Win-x86@42, Branch:master, Time: 2014-09-03_10:10:14. Could reproduce the bug
Comment 8 Armin Le Grand 2015-11-06 16:57:17 UTC
Tried on win7, no crash with LO
@RUI: The 'racks' get loaded fine
@SUN: Objects are made with many small parts, group them before moving
Comment 9 Armin Le Grand 2015-11-11 16:11:59 UTC
Checked test file from comment 6. Got no crash, but speed is bad. Checked the contents, every rectangle is a CustomShape. This is probably because these get created when the rectangle shape creation gets started from the UI, using the simple RectangleShape would probably make this cheaper.
A guess: When starting to drag the object an dthe drag takes longer as the time to start D&D mode (muse cursor changes, no overlay preview) racing conditions may be involved.
@Florian: With which test file did you reproduce? Comment 6 or comment 2? Did you try a LO5 version yet?
Comment 10 Florian Reisinger 2015-11-12 09:21:29 UTC
#6 works
Original attachment cannot be opened with:
Build-ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe-GL
Gebietsschema: en-US (de_AT)
Comment 11 Armin Le Grand 2015-11-17 13:21:25 UTC
Tried again with updated LO on Win7, could not reproduce
Comment 12 MarjaE 2016-04-29 00:40:00 UTC
Could not reproduce in OSX.
Comment 13 V Stuart Foote 2016-04-29 03:17:37 UTC
Version: (x64)
Build ID: d3bf12ecb743fc0d20e0be0c58ca359301eb705f
CPU Threads: 8; OS Version: Windows 6.19; UI Render: default; 
Locale: en-US (en_US)

Was this ever confirmed as an issue?

Anyhow, in both test documents comment 2 and comment 6 no issues with copy paste, paste move, paste--nor the select and move, nor select and hold in place.

Seems pretty stable at resolved WFM.